5 Replies Latest reply on Sep 28, 2018 2:44 PM by seattleman1969

    Provisioning stopping on one particular package, help please! - IEM 2017.1

    Apprentice

      Hi there,

       

      I'm trying to get a provisioning template to work with a new Windows 10 image using IEM 2017.1 and running into an issue that seems a bit strange.

      Although this particular package (Shoretel Communicator) installs fine when pushed out to a test Windows 10 machine already imaged as a stand alone package, it stops at this package during a provisioning job.

      It doesn't error, just doesn't go any further.  I'm not sure if I should try a reboot action just before installing this one or not...

      I know the new SU1 update released on Monday has bug fixes, one of which is to deal with reliable package deployment so I'm wondering if this might sort it out, but I'm not confident.

       

      Can anyone point we to where I should be checking to get to the bottom of this?

       

      (btw - we haven't configured HII or added any drivers as it's not needed for this model so don't worry about that)

      Capture.JPG

        • 1. Re: Provisioning stopping on one particular package, help please! - IEM 2017.1
          FrugalRain Apprentice

          Hi, couple of ideas which might help..

          Have you tried adjusting the order in which the app gets installed, maybe move it up to just after the reboot?

          After you run the task and it fails right click on the machine and look at provisioning history, you might get an idea in there of why it failed.

          Believe the full agent installed at the beginning can sometimes cause issues - We had to use a provisioning agent at the start of our system configuration phase then run the full agent at the end - the full agent being installed too early on was interfering with software installations at random places but might not be the case here if stopping at that same package constantly.

          Take a look on the client in C:\Program Files (x86)\LANDesk\LDClient\Data\ directory for an sdclient_task#.log file, see if any indication in there.

           

          How is the package created, msi, exe, batch file ?

           

          goodluck

          Geoff

          • 2. Re: Provisioning stopping on one particular package, help please! - IEM 2017.1
            Apprentice

            Hi Geoff,

             

            Thanks for the help.

            Yeah, I tried changing the order. 

            I tried it just by itself without any other apps too.

            The funny thing is it installs ok as a separate task after provisioning.

            The provisioning history doesn’t give away any clues and the task log just shows it starting, but that’s it.

            The package is an MSI with nothing fancy and these as switches - /quiet /norestart /i

             

             

             



             
             
             
             
             
             
             
             
             
             
             
             


             


             


             

             

            • 3. Re: Provisioning stopping on one particular package, help please! - IEM 2017.1
              FrugalRain Apprentice

              if you run the template against a machine with the agent already installed with just the app installation in the system configuration section, does that work? - so nothing in pre-os, os installation, post os etc ??

               

              I have seen this once before when installing lenovo driver software package - i think i had to create a batch file that called the msi -  try something like.. msiexec /i "ShoreTel Communicator.msi" /q in your batch file.

               

               

               

               

              • 4. Re: Provisioning stopping on one particular package, help please! - IEM 2017.1
                Apprentice

                I tried to recreate the Shoretel package as a BAT file calling the MSI.  Again, this worked deploying as a post provisioning task, but when contained within the provisioning template is fails to install.

                It seems to copy all the files to sdmcache, but won't launch the bat file and just sits there doing nothing.

                Top pic shows the template stuck again.  Second, shows the laptop, files are there, no msi process running though.

                Do you know any logs I can check or have any other ideas?

                 

                 





                • 5. Re: Provisioning stopping on one particular package, help please! - IEM 2017.1
                  seattleman1969 SupportEmployee

                  Take a look at the following document: How To Troubleshoot Provisioning Template Action Handlers

                   

                  To troubleshoot a SW Dist Package in Provisioning your requisite logs will be:

                   

                  On the Client (Agent) in x:\ldprovision or systemdrive:\windows\temp:

                  ldprovision.log

                  sdclienthandler.log

                   

                  If not using a preferred server:

                  Getfilehandler.log

                   

                  If using preferred server:

                  maptopreferedhandler.log

                  downloadhandler.log

                   

                  Lastly:

                  C:\ProgramData\LANDesk\Log\sdclient_task#.log  - where task# = the Task ID for the task specified in the action (Right Click task and look at Info)

                   

                  The flow of actions is:

                  LDProvision executes the action and downloads the requisite action handler files if necessary. Once the files are downloaded and verified it executes the action handler file with the necessary switches.

                  The action handler begins it's process, calls the package, downloads files by calling the requisite handlers mentioned above, and then executes the package.

                   

                  I would start with collecting the log files in question and reviewing them or posting them here to be reviewed. It is possible that a reboot is necessary, but there could be other issues as well. It may be necessary to turn on Xtrace logging in Provisioning. To do this inject a Wait action (allowing time to edit the registry and turn on 4 registry keys, I usually recommend 2-5 minutes) as the first action in the System Config section of your template. While Waiting, either Remote Control, or access your target device directly, and open a console then execute Regedit and edit the keys as specified in this article: How To: Enable XTrace Diagnostic Logging for the LANDESK Core and Clients

                   

                  You can also add the ability to select a device in the console, right click, and turn on the extended logging with two clicks using the following article: How To: Add (or Stop) XTrace + Log Verbose for 1 device in 2-CLICKS from any LDMS Console you will find this very helpful in troubleshooting many issues and it is highly suggested to make this change in your console!