4 Replies Latest reply on Jul 10, 2017 3:17 PM by 1977-ITGuy

    Dell Latitude 5580 - SATA Config / Can't provision

    1977-ITGuy Apprentice

      LANDesk 9.6 SP2

      Windows 10

      Dell Latitude 5580, M.2 SSD

      Using latest boot_x64.wim


      We have just received a new model type and I wanted to get a head start on provisioning this device for future deployments.  However, I run into a problem immediately and I know it has something to do with the hard drive controller (or at least I hope it does.) 


      Here are the steps I have taken...


      BIOS Changes:


      UEFI Enabled

      Secure Boot Enabled

      SATA Configuration = RAID


      I created a bare metal server and deployed the provisioning task.  It loads the boot_x64.wim and once it finishes, I see a loading screen for about 2 seconds and immediately get a "Your pc ran into a problem and needs to restart."  Usually it goes right into wpeinit and proceeds.  The specific error messages say page_fault_in_nonpaged_area OR kernel_security_check_failure or iastor.sys error.  I assumed I haven't injected the necessary IRST drivers so I went to Intel's website and downloaded / injected into the Windows PE image.  Deployed to PXE reps and tried executing the template again - same problem.  If I go into the BIOS and change SATA configuration to AHCI, I can get a little further.  Boot_x64.wim loads and then wpeinit starts.  It eventually tells me I need to inject the hard drive controller so basically back to square one.  Even going this route, it still doesn't accept the IRST drivers I injected previously.  I'm going to assume I want to keep the SATA configuration to RAID since I am using a M.2 SSD (I heard using ITRS it increases drive performance.) 


      I am at a loss as to how I am suppose to get this thing to work. Any help would be greatly appreciated - spent the last 5 hours on this thing and every time I try something, same dead end