4 Replies Latest reply on Jul 12, 2017 1:55 AM by KaiNitzsche

    Treiber-Paket (InstallPnpDevices) schlägt neuerdings fehl

    KaiNitzsche Apprentice

      Hallo zusammen.

       

      Ich habe mal wieder eine Merkwürdigkeit, die ich mir nicht erklären kann. Seit knapp einem Jahr benutze ich für Windows 10 64Bit einen abgezogenen LAN-Treiber zur Installation für ein bestimmtes PC-Modell. Die Installation hat bisher auch immer funktioniert, bis jetzt. Das Paket wirft in der Konsole folgenden Fehler aus:

      Fehler_DSMC.png

      Im Log-File sieht das dann wie folgt aus:

       

       

      11:01:56.853 2        ---->Starting installation of "Intel(R) Ethernet Connection (2) I219-V"

      11:01:56.853 2        -> : GeneratedInstallCodeStart

      11:01:56.854 2        -> InstallPnpDevices
      11:01:57.078 2         xniTools: Now copying complete driver package from C:\Program Files (x86)\Common Files\enteo\RepositoryCache\107142\rev\1\Extern$\drv\{17FCC02E-6482-4C7B-B5F5-FD423CEFD01C} to C:\Users\nitzschekadm\AppData\Local\Temp\PNPD909.tmp
      11:01:57.078 1         xniTools: Trying Pnp Installation from inf file C:\Users\nitzschekadm\AppData\Local\Temp\PNPD909.tmp\e1d62x64.inf
      11:01:57.079 1         xniTools: Updating matching hwID PCI\VEN_8086&DEV_15B8&SUBSYS_06BA1028 from file C:\Users\NITZSC~1\AppData\Local\Temp\PNPD909.tmp\e1d62x64.inf with its 1st hwID PCI\VEN_8086&DEV_15B8&SUBSYS_06BA1028&REV_31
      11:01:57.090 2         xniTools: Could not get DocumentsAndSettings Folder for default user
      11:01:57.092 1         xniTools: Target OS for driver packaging is 'ntamd64.10.0.1.0x100'
      11:01:57.093 2         xniTools: Searching information for Target ntamd64.10.0.1.0x100
      11:01:57.093 1         xniTools: XP: Adding potentially decorated Model [intel] section in file c:\windows\inf\net1ic64.inf
      11:01:57.093 1         xniTools: Os decorator ntamd64.6.2.1.0x0 (NTamd64.6.2.1) is the best match for the target ntamd64.10.0.1.0x100.
      11:01:57.093 1         xniTools: XP: Adding potentially decorated Model [intel.ntamd64.6.2.1] section in file c:\windows\inf\net1ic64.inf
      11:01:57.095 1         xniTools: Enumerating Hardware IDs in CPnpHwInfFile::GetSupportedHardwareIDs
      11:01:57.148 1         xniTools: Enumerating Hardware/Compatibility IDs in CPnpHwInfFile::GetSupportedHardwareCompatIDs

      11:01:57.148 2         xniTools: Starting examination of file c:\windows\inf\net1ic64.inf in language
      11:01:57.149 2         xniTools: Could not get DocumentsAndSettings Folder for default user
      11:01:57.150 1         xniTools: Target OS for driver packaging is 'ntamd64.10.0.1.0x100'
      11:01:57.151 2         xniTools: Searching information for Target ntamd64.10.0.1.0x100
      11:01:57.151 1         xniTools: XP: Adding potentially decorated Model [intel] section in file c:\windows\inf\net1ic64.inf
      11:01:57.151 1         xniTools: Os decorator ntamd64.6.2.1.0x0 (NTamd64.6.2.1) is the best match for the target ntamd64.10.0.1.0x100.
      11:01:57.151 1         xniTools: XP: Adding potentially decorated Model [intel.ntamd64.6.2.1] section in file c:\windows\inf\net1ic64.inf
      11:01:57.153 1         xniTools: Scanning file net1ic64.inf (net1ic64.inf) from location c:\windows\inf\net1ic64.inf....
      11:01:57.155 1         xniTools: Potential Device Driver Installation Section [e15b8.6.2.1.ntamd64] not found in file c:\windows\inf\net1ic64.inf

      ... usw.

      Am Ende geht er dann mit dem Fehler raus...

       

      11:01:57.544 1         SI: Starting ExRSend.exe ...
      11:01:57.544 2         SI: Rewriting SI client state data...
      11:01:57.544 1          SI: Reading client state...
      11:01:57.559 1          SI: Writing possible changes of client state...
      11:01:57.564 E         Error (Module:xniTools, Severity:0x0b): Treiberinstallation/Aktualisierung für DeviceInstance/Treiberpfad PCI\VEN_8086&DEV_15B8&SUBSYS_06BA1028&REV_31 C:\Users\NITZSC~1\AppData\Local\Temp\PNPD909.tmp\e1d62x64.inf
      Es sind keine Daten mehr verfügbar.
      fehlgeschlagen.
      Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen. (0x0000006e)
      11:01:57.565 2         Messagebox suppressed  (No output allowed), output is written to the log files
      11:01:57.565 2         MsgBox: [Treiberinstallation/Aktualisierung für DeviceInstance/Treiberpfad PCI\VEN_8086&DEV_15B8&SUBSYS_06BA1028&REV_31 C:\Users\NITZSC~1\AppData\Local\Temp\PNPD909.tmp\e1d62x64.inf
      Es sind keine Daten mehr verfügbar.
      fehlgeschlagen.
      Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen. (0x0000006e)
      Installation wird beendet.]
      11:01:57.565 2         SWMSRT: //------------| Starting Checking if policies should run for the trigger 'On error'. |------------\\
      11:01:57.565 2         SWMSRT: \\------------| Finished Checking if policies should run for the trigger 'On error'. |------------//
      11:01:57.566 2        New last error from script command is 2147614729 (0x80020009)
      11:01:57.566 2        Resolved new last error from script command is: Ausnahmefehler aufgetreten.
      11:01:57.566 2       Execution terminated on error
      11:01:57.567 1       Logging up ExR event 3002 (0x00000bba)

      11:01:57.570 1       SI: Starting ExRSend.exe ...
      11:01:57.570 2       SI: Rewriting SI client state data...
      11:01:57.570 1        SI: Reading client state...
      11:01:57.571 1        SI: Writing possible changes of client state...
      11:01:57.576 2       xniFPS: '{0606B1EA-C96D-42E1-B3B7-41276A424E68}' is installed

      11:01:57.576 2       ---->Installation of Intel(R) Ethernet Connection (2) I219-V has not completed on exit.

      Die Dateien liegen im angegebenen Projektverzeichnis, sind also vorhanden. Allerdings schafft er es nicht diese in den Temp-Ordner zu kopieren.Kann mir jemand das Verhalten erklären und vor allem, wie kann man dies beheben?

       

       

      Danke euch!

      Kai

        • 1. Re: Treiber-Paket (InstallPnpDevices) schlägt neuerdings fehl
          SupportEmployee

          Als grundsätzlicher Test würde ich mal einen Rechtsklick auf das Treiberpaket machen -> Driver matches computer

          Dort kann man dann einen Client auswählen und prüfen

           

          Interessant ist auch wie die net1ic64.inf Datei aussieht und ein kompletter Logfileauszug

           

          Was wurde denn geändert, bevor es nicht mehr funktioniert hat?

          Fehlt denn der Treiber im Geräte Manager?

          Wenn man noch ein Logfile von einem funktionierenden Client hat, könnte man diese vergleichen um einen Unterschied zu erkennen

          • 2. Re: Treiber-Paket (InstallPnpDevices) schlägt neuerdings fehl
            KaiNitzsche Apprentice

            Sorry, hatte ich vergessen zu schreiben.

             

            Ja, der Treiber-Check klappt, DSM ist der Meinung das das Paket kompatibel ist. Wenn ich mir die letzten Policys anschaue, gibt es das Problem wohl erst seit ein paar Wochen. Die letzten erfolgreichen Installationen sind vom 26.06.2017 und 04.07.2017, die vorhandenen drei erfolglosen vom 09.06., 30.06. und 10.07. Im Mai sind wir auf 2012.2 (da wurden mehrere Depots und der BLS abgelöst) und Anfang Juli auf 2016.2 R2.

             

            Die Netzwerkkarte funktioniert momentan schon, Windows nimmt einen Standardtreiber (e1i63x64.sys), sodass die LAN-Verbindung erst einmal schon funktioniert.

             

            Den Inhalt der net1ic64.inf würde ich mal nicht posten, da die ziemlich groß ist. Anhängen kann man sie scheinbar nicht oder gibt es einen nicht gefundenen Spoiler?! Ich habe sie eben mit der inf auf meinem System (anderes PC-Modell, aber auch W10 64Bit 1703) verglichen und die sind identisch. Die Device-ID ist da drin zu finden, nur nicht der SUBSYS-Eintrag.

             

             

            Gruß Kai

            • 3. Re: Treiber-Paket (InstallPnpDevices) schlägt neuerdings fehl
              _Mel_ Master

              im avanced editor kannst du dateien anhängen.

               

              schau dir mal die installationssourcen des treibers an, ob da dateien drin sind, die im paket fehlen.

              • 4. Re: Treiber-Paket (InstallPnpDevices) schlägt neuerdings fehl
                KaiNitzsche Apprentice

                Ah okay, hab die inf mal dran gehängt.

                 

                Die Dateien sind auf den Servern vorhanden und wurden auf den Client gestaged. Dort sind sie ja auch im RepositoryCache vorhanden.

                 

                Jetzt wird es ganz merkwürdig:

                Ich habe eben versucht über den Gerätemanager -> "Treiber aktualsieren" versucht den Treiber händisch der Netzwerkkarte zuzuweisen, da sagt Windows das der Treiber nicht kompatibel sei?!

                 

                Ich glaub ich mach den Treiber einfach komplett neu, scheint wohl doch nicht am DSM zu hängen, sondern irgendeine Windows-Merkwürdigkeit zu sein. Liegt vielleicht auch daran, das das nun 1703 ist, paketiert wurde noch unter 1607 oder gar 1511.

                 

                 

                /Edit: Ja das war's. Der Treiber ist seit dem 1703-Update nicht mehr kompatibel. Die Rechner auf denen er noch lief waren mit 1603 und 1511 bestückt. Da freut man sich so richtig auf die Windows 10-Einführung, wenn man mit jedem Build nicht nur hunderte Programme, sondern auch tausende Treiber testen darf.

                 

                 

                Danke euch trotzdem!

                Kai