3 Replies Latest reply on Jul 31, 2017 8:01 AM by SitzRieSe

    Windows 10 Workgroup + Autologon

    SitzRieSe Expert

      Hi Leute,

       

      ich brauch mal eure Hilfe. Ich versuche hier eine Workgroup Installation mit AutoLogon User zu basteln. Leider wird das PW des AutoLogon Users nicht korrekt gesetzt und ich verstehe nicht wieso. Hier die Unattend:

       

         <RunAsynchronous>
         <RunAsynchronousCommand wcm:action="add">
         <Description>AutoAdminLogin</Description>
         <Order>1</Order>
         <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v AutoAdminLogon /t REG_SZ /d %InstallationParameters.EnableAutoAdminLogin% /f</Path>
         </RunAsynchronousCommand>
         <RunAsynchronousCommand wcm:action="add">
         <Description>DefaultUserName</Description>
         <Order>2</Order>
         <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultUserName /t REG_SZ /d %InstallationParameters.DefaultAutoLogonUser% /f</Path>
         </RunAsynchronousCommand>
         <RunAsynchronousCommand wcm:action="add">
         <Description>DefaultPassword</Description>
         <Order>3</Order>
         <Path>reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v DefaultPassword /t REG_SZ /d %InstallationParameters.DefaultAutoLogonPassword% /f</Path>
        

      </RunAsynchronousCommand>

       

      und später:

       

         <LocalAccounts>
         <LocalAccount wcm:action="add">
         <Password>
         <Value>%[OSD.Base64.%InstallationParameters.LocalAdminPassword%Password]%</Value>
         <PlainText>false</PlainText>
         </Password>
         <Description>Local Administrator Account</Description>
         <DisplayName>%InstallationParameters.LocalAdminName%</DisplayName>
         <Name>%InstallationParameters.LocalAdminName%</Name>
         <Group>Administrators</Group>
         </LocalAccount>
         <LocalAccount wcm:action="add">
         <Password>
         <Value>%[OSD.Base64.%InstallationParameters.DefaultAutoLogonPassword]%</Value>
         <PlainText>false</PlainText>
         </Password>
         <Description>Auto Logon User</Description>
         <DisplayName>%InstallationParameters.DefaultAutoLogonUser%</DisplayName>
         <Name>%InstallationParameters.DefaultAutoLogonUser%</Name>
         <Group>Users</Group>
        

      </LocalAccount>

       

      In der Registry ist das PW korrekt gesetzt:

       

      Der Benutzer ist auch angelegt und aktiv:

       

       

      Beim Anmeldeversuch, sowohl manuell als auch über den AutoLogon Eintrag bekomme ich aber immer falsches Passwort...

       

       

      Im Configuration Package:

       

       

      Jemand ne Idee was hier falsch läuft?

       

      (DSM 2016.2:3660)

       

      Gruß

       

      Alex

        • 1. Re: Windows 10 Workgroup + Autologon
          SitzRieSe Expert

          Mh... mit weiteren rumprobieren gehts jetzt so:

           

             <LocalAccount wcm:action="add">
             <Password>
             <Value>%InstallationParameters.DefaultAutoLogonPassword%</Value>
             <PlainText>true</PlainText>
             </Password>
             <Description>Auto Logon User</Description>
             <DisplayName>%InstallationParameters.DefaultAutoLogonUser%</DisplayName>
             <Name>%InstallationParameters.DefaultAutoLogonUser%</Name>
             <Group>Users</Group>
            

          </LocalAccount

           

           

          Verstehe zwar nicht wieso es nicht mit Plaintext = false funktioniert... aber ok... In der unattend ist das PW trotzdem deleted, aktuell sehe ich kein Grund das nicht so einsetzen zu können...

          • 2. Re: Windows 10 Workgroup + Autologon
            _Mel_ Master

            der fehler ist das hier:

            <Value>%[OSD.Base64.%InstallationParameters.DefaultAutoLogonPassword]%</Value>

            schon die % stimmen nicht - da sind 3

            d.h. es müßte so lauten

            <Value>%[OSD.Base64.%InstallationParameters.DefaultAutoLogonPassword%]%</Value>

            das wäre richtig, wenn in der unattend.xml das codierte passwort einfach nur so drin stehen würde; tut es nur leider nicht, da muß noch der text "Passwort" angehängt sein (bzw "AdministratorPasswort" beim administratorpasswort)

            <Value>%[OSD.Base64.%InstallationParameters.DefaultAutoLogonPassword%Passwort]%</Value>

            • 3. Re: Windows 10 Workgroup + Autologon
              SitzRieSe Expert

              Ach da ist der Fehler... Ich hatte mich über die 3 % schon gewundert, aber es so in dem Template gesehen. Mir ist nicht aufgefallen das hier nochmal eins ist:  %[OSD.Base64.%InstallationParameters.LocalAdminPassword%Password]%

               

              Danke Mel