11 Replies Latest reply on Aug 2, 2017 8:24 AM by phoffmann

    Image failing on "Configure Target OS"




      I am pretty OK with Landesk but i have been stumped by this issue.


      We have a Core in London and a preferred server in Amsterdam, we have two Provisioning templates, One London and One Amsterdam. When i image using either in london they work fine. When i try both template in Amsterdam they fail at the task "Configure Target OS" see this image.

      Screen Shot 2017-07-28 at 9.27.18 PM.png

      So i looked into this and found some logs on the WinPE host machine I am trying to image. The first one is the maptopreferredhandler.log, its coming up with an error code 2250 could not map or unmap drive.


      Screen Shot 2017-07-28 at 1.17.57 AM.png

      This led me to think it may be a permissions thing on the folders on the preferred server but all look fine to me?


      I am truly stuck! If anyone could help with a guide or ways to resolve this issue it would be amazing.





        • 1. Re: Image failing on "Configure Target OS"
          phoffmann SupportEmployee

          Point 1 - is either of the LHR1xxx / AMS3LDxxx servers ones that you MEAN to connect to?


          Point 2 - turn on NT-auditing on both servers. Could be that the username/password is failing.


          This can be due to things playing up such as AD authentication - so you may want to try using / defining a "server local" account / password to access stuff.


          Also - make sure that the shares actually work / exist on the Amsterdam server, perhaps?

          • 2. Re: Image failing on "Configure Target OS"



            Thanks for the response


            Point 1 If i am imaging in AMS then the files on the preferred server in AMS need to come from there, but the core is the LHR.


            Point 2 when you say the username and password is failing, what one do you mean? is this a username and password set up in the Landesk console? if so where?


            Once i know what account is being used ill go check that AD authentication is working?

            • 3. Re: Image failing on "Configure Target OS"
              phoffmann SupportEmployee

              The username/password combo is defined with each Preferred server entry.


              So that's what I was referring to.

              • 4. Re: Image failing on "Configure Target OS"

                Can you just highlight were in LDMS i add that AD account, is it under server replication and preferred servers?

                • 5. Re: Image failing on "Configure Target OS"
                  phoffmann SupportEmployee

                  My suggestion was to try NOT using an AD-account, but using a local-account (and creating it, obviously, and giving it access to the share).


                  Here's the area you should be doing it in:


                  And then just find your respective entry:


                  Does that help you?

                  • 6. Re: Image failing on "Configure Target OS"

                    Could you also use another AD account that you know works and that aslo has the correct permissions? or does this need to be an account only locally

                    • 7. Re: Image failing on "Configure Target OS"
                      phoffmann SupportEmployee

                      For troubleshooting, I would prefer using a local account (no AD involvement == eliminate AD as a potential source for problems).


                      There's nothing stopping you from using a different account (heck - you COULD use a domain admin, we're not going to stop you) -- but you're looking to eliminiate "weird things" happening, so I figured it'd make logical sense to remove the AD-related stuff (and things like "domain trusts" not working 100%) to make life simple.


                      Start out with simple.

                      Simple is good.

                      And from THERE, you can go and make things more complicated 1 step at a time .


                      Does that make sense?

                      • 8. Re: Image failing on "Configure Target OS"



                        So i created a local admin account called Landesk on both the core server and preferred server. Then i went into Content replication and Preferred servers and double clicked on the AMS preferred server.


                        under configuration i changed the username to



                        the password i created for this account


                        then when i tested the credentials its fails on UNC path.


                        am i doing this right? do i need to change the credentials on a different server?


                        So sorry

                        • 9. Re: Image failing on "Configure Target OS"
                          phoffmann SupportEmployee

                          Hmm - wouldn't use ".\Landesk" -- I'd specify "{the_preferred_server}\Landesk".


                          You're authenticating with that user explicitly when talking to that preferred server, so you can be specific with the server name.


                          You don't need to change any of the credentials for the Core (if it's acting as a preferred server) since you've only listed issues with clients reaching "that one remote preferred server", right?

                          • 10. Re: Image failing on "Configure Target OS"

                            So i did the following on the Preferred server properties.



                            \\{servername}\landesk and i also tried {servername}\landesk


                            the password i created for this account


                            when i tested the credentials i get UNC Authentication failed.

                            • 11. Re: Image failing on "Configure Target OS"
                              phoffmann SupportEmployee

                              A few points:


                              1 - I edited your post to anonymise the server name. Generally, don't put "real" server names out here, it's a public forum, and it may pose a security risk as it's volunteering information about your organisation . Keep security in mind please.


                              2 - You don't use "\\{servername}\{username}" for authentication. The double-backslash stuff is for connecting to a UNC share. You still would authenticate with "ServerName\BobTheAdmin" or whatever.


                              3 - If authentication fails ... turn on local security auditing on the server and repeat. (you can google how to do this for your edition of Windows).

                              You're looking for the following things:


                              3.A - The Core is actually trying to authenticate to this box (i.e. "we're talking to the right system & resolving it correctly").


                              3.B - The Core is using the credentials you specified (i.e. - there's no login attempt with "SomeOtherDomain\SomeOtherUser") ...


                              3.C - You can find out why Windows has failed the authentication. Could be something as simple as "wrong password" (because of some illegal characters, for instance?) or some such. Based on WHAT is / isn't being failed on, that's what'll help you to figure out what's wrong.


                              (If it's any use, a "simple to remember" password I tend to use on test kit that covers most password requirements is -- Land3sk! -- ).


                              Also, you can cross-check connect to that server from a legtimate device on both "its own local" network with your test account (to see if that works), and then "from your home network" ... to double-check / cross check. Could be some weird networking shenanigans that could be at fault.


                              In this way, you "start easy" and work your way up one logical step at a time.


                              Hope that helps.