10 Replies Latest reply on May 18, 2009 9:17 AM by homermg

    msi cancel

    Apprentice

      Hi all,

       

      i have some trouble with a msi file.

       

      I have an small app which is sonsist of only one file.

       

      By installing this msi i have to type in the repository path. So i edit the msi with orca and paste the path in. (\\repository\app)

      Now if i install the software the path is allready in. So i can start manually the quiet installation.

      Mnaually on th client with cmd it is no problem to install the software but over landesk its abort.

      I recieve the erro: 1606 could not access network location \\repository\app.

       

      any idea?

       

      i think it something wrong with the rights of the agent on the client(for the client are enough permission there, but not for repository i think), but forgot where the permission of the agent are define. Can somebody help me please?

       

       

      thanks in advance

        • 1. Re: msi cancel
          Employee

          Homermg,

           

          The agent will run pretty much everything as LocalSystem on that client machine.  You need to make sure that when you test it you can do it as LocalSystem.  To do that you'll need to either allow Domain Computers rights to the share (if you're on AD), or create a null session share (meaning it is completely open, and authentication isn't even required).

           

          To test as LocalSystem it is easiest to go to the folder where the agent is installed on a client machine, usually %programfiles%\LANDesk\LDClient, and type localsch /exe=cmd.  This won't work in Vista, but it will in XP.  Within a few seconds a command prompt should open that is running as LocalSystem.  Try to launch whatever you need to use from that screen and you should get results that will mirror what happens when you deploy through LANDesk.

          • 3. Re: msi cancel
            Apprentice

            Hi all,

             

            i added the computer account where the msi should installed on the share (repository), but i cant still install the msi on the client. I dont want to make a null session.

             

            can somebody help me?

            • 4. Re: msi cancel
              ahe Expert

              Without a null session share,

              • you have to create a installation script which download the msi (and it's components) to your client and start it locally or
              • you have to create a compressed EXE file (Package Builder, AutoIT,...), download it and start it locally or
              • you have to use the method via HTTP instead of UNC share. (I've no experiences wiht HTTP-MSI-installation, I prefer download compressed EXE...)

               

              Regards

              Axel

              • 5. Re: msi cancel
                Apprentice

                All the the advices are not really possible with this app.

                 

                I install this app (msi) now without repository entry. After that i push i script which edit the regsitry and insert the ropistory entry.

                After this two steps this script starts to install the main apps with the help of the msi from the repository.

                Now i copy the rpository to ther landeskshare and edit my script: first the script insert the repository entry to my landesk share install the apps and insert the correct repository entry after that. The istalltion now runs completly but the app start with erro massage.

                I think after installing from wrong repository(Landesk) the app copy the path in some files. But i dont know wihich files that are.

                 

                So i have to find another solution the best one is to add the domain coputer th the share, what i done but why it wnats to run?

                 

                Cab i run the script as another user?

                • 6. Re: msi cancel
                  ahe Expert

                  Could you give us some more info's about the application?

                   

                  Sometimes it's possible to install MSI with Local System account and sometimes not. And sometimes userrights are enough to install a package and sometimes not. It depends on the developer of the MSI, the location of the destination on the client, etc....

                   

                  You can use STARTASUSER.EXE or with login script if user rights are enough:

                  Running Commands as the Logged on User Using StartAsUser.exe

                   

                  Regards

                  Axel

                  • 7. Re: msi cancel
                    Apprentice

                    Hi Axel,

                     

                    unfortunatly i cant run the script(*.vbs) with runasuser. :-(

                     

                    any other idea?

                     

                    what im not really understand, if move the repository to the landesk share i can install he app, so it is not depend on local system account, but what is the problem?

                     

                    The tool is named daisy

                    • 8. Re: msi cancel
                      Employee

                      Which LANDesk share works?  If it's ldlogon then that's a null session share.

                       

                      So, here's what I see:

                       

                      You can't runasuser, because of system rights.

                      You can't run as localsystem (as it currently stands) because of share rights.

                      You don't want to allow for localsystem to have the rights needed to run.

                       

                      Looks to me like we're kind of running thin on options.  This isn't a LANDesk imposed limitation, this is Windows security at it's very most basic.  You can add rights to Domain Computers (if you're running an AD environment), or you really need a null session share.  I guess you could try to run a bunch of net use commands in a batch file or something, but then you're sending account information in clear text.

                       

                      How do you think it would be best to proceed?

                      • 9. Re: msi cancel
                        ahe Expert

                        Hello,

                         

                        could you attach your script and are there any other informations about "daisy"...?

                         

                        How do you install it from share successfully? With a local admin account and a mapping to the share?

                         

                        What's happen if you start the installation as local system from a local directory?

                         

                        Regards

                        Axel

                        • 10. Re: msi cancel
                          Apprentice

                          i have not really lot of infos about daisy.

                           

                          but this script is runnig perfekt if i started it manaully als Administartor.

                           

                          only by pushing over ldms it don install the apps.

                           

                          To Install the daisy software you have to install at first the daisy client and start it.

                           

                          After that you cann install the apps out of the client which is connect to the repository.

                           

                          1. My Way is to push the cleint and install it. That is runnigt without any problems.

                          Then i push the script which tell the cleint where the repository is (WSHShell.RegWrite "HKLM\SOFTWARE\Donovan Data Systems\Daisy\RepositoryPath", "\\Repository\D3")

                          2. Than i isntall the apps. (shell.run "C:\Programme\DDS\Daisy\DAISY.EXE /I{33087ED0-DA53-11d3-A284-00C04F7E5577} /N"
                          wscript.sleep 120000
                          shell.run "C:\Programme\DDS\Daisy\DAISY.EXE /I{4EB79F70-4841-11d4-AD49-00C04F10F2B5} /N"


                          That it.

                           

                          As domain admin i can install it without any problems with my script. There is no chance to run the script as domain admin?

                           


                          I copy the repository to the share where all the packges are and it runs so i think it is not the problem to run as local system account.

                           

                          -------------------

                           

                          Hi Mach9

                           

                          i would like to give the local system enough rights but it down work. I add to the share the Domain Computers. But i have still the same problem.

                          By trying to run the script with "run as" out of local system cmd i reciev an error access denied

                           

                          I created my own share on landeskserver where i paste all the software and imges for deployment