5 Replies Latest reply on Sep 1, 2017 6:38 AM by dcogny

    Request Offering Categories not Appearing in Service Catalog

    Rookie

      Not all of my Request Offering Categories are appearing in the Service Catalog.  Can anyone advise on how to get them to appear?

       

      Thanks in advance

      Jo Layzell

        • 1. Re: Request Offering Categories not Appearing in Service Catalog
          dcogny Expert

          Hi Jo,

           

          If there is no Service Request available for you in a specific category, it just won't show up. For example: You have a category called "Email" and inside a "Request to archive .pst", but the only people in your organization allowed to archive .psts are thr admin assistants. Whenever an admin assistant goes to the Service Portal they will see the Category "Email" with the "Request to archive . pst" on it, but when any non belonging to that group goes to the Service Portal they will not see anything, for the same reason, if there is a category without any Request Offering on it, no one will see that category.

           

          Hope this helps, if not, provide a little more explanation (screenshots are really helpful) and we will see what can be done.

           

          Regards.

           

          Daniel.

          1 of 1 people found this helpful
          • 2. Re: Request Offering Categories not Appearing in Service Catalog
            Rookie

            Thanks Daniel, sorry about the late response

             

            The problem has now resolved itself.  Ie I can now see the Published Request
            Offerings in the Request Categories from within the Service Catalog

             

            I think part of the problem was due to our Org Units being uploaded into our Staging and Prod environments.

            I initially had this error when trying to edit the "Request for New User Account" form in our Staging environment:

            "unhandled system exception: Composite view table meta was not found for the contract Frs_CompositeContract_Entity"

            I was able to resolve the above by changing the Org Unit to "NCC".  It was after this that I was not seeing the
            Published forms

            When I logged on the next day, I could see all my Published forms

             

            Jo Layzell

            • 3. Re: Request Offering Categories not Appearing in Service Catalog
              dcogny Expert

              Yeah... The Org Units messed up big time with my Offerings too...   (I actually ended up changing the rule so we use role instead of OrgUnits to show/Hide Offerings)

               

              Good thing that is working now!!

              1 of 1 people found this helpful
              • 4. Re: Request Offering Categories not Appearing in Service Catalog
                Rookie

                Hi Daniel

                 

                Which rule did you change to achieve this?

                • 5. Re: Request Offering Categories not Appearing in Service Catalog
                  dcogny Expert

                  Hi,

                   

                  You first have to create the relationship between the control system and the role object, so create a "RoleLink" field in the "ServiceReqTemplateEntityAccess" object:

                  Then create the relationship:

                  Then you to "Build" - "Self Service" - "Configure Access" (it might not work for you, it wasn't working for me, there is a knowledge article about fixing the "User Interface Styles", you would need something similar if you cannot see anything):

                  And "Add Filtering Property":

                  Then you can select the role to filter:

                   

                  That will allow you to select "Role" as a filtering option, the problem is that I am on my own here, so not much time for testing, it is working, but I had a couple cases where I had to filter again by OrgUnit as people with the proper role could still not see it, did not have time to debug, I will recommend to give it a bit of testing (let me know if you encounter issues)

                   

                  Hope this helps!

                   

                  Daniel.