7 Replies Latest reply on Aug 24, 2017 12:50 PM by Leslie2k

    Provisioned image stops at OOBE questions

    Leslie2k Apprentice

      My Provision script does not go past Windows 10 asking OOBE questions.  Below is my Template.

       

      windows 10 sysprep 1703.PNG

        • 1. Re: Provisioned image stops at OOBE questions
          FrugalRain Apprentice

          Hi, your template doesn't show much info - its your attend file you need to look at. This is where oobe questions get answered

          • 2. Re: Provisioned image stops at OOBE questions
            Leslie2k Apprentice

            here is my attend file.

             

            <?xml version="1.0" encoding="utf-8"?>

            <unattend>

              <settings pass="auditSystem">

                <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

                  <DriverPaths>

                    <PathAndCredentials wcm:keyValue="1" wcm:action="add">

                      <Path>c:\windows\LDDriverStore</Path>

                    </PathAndCredentials>

                  </DriverPaths>

                </component>

                <component name="Microsoft-Windows-Shell-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

                  <UserAccounts>

                    <AdministratorPassword>

                      <PlainText>true</PlainText>

                      <Value>%W10Pass%</Value>

                    </AdministratorPassword>

                  </UserAccounts>

                  <AutoLogon>

                    <Enabled>true</Enabled>

                    <Username>%W10User%</Username>

                    <Password>

                      <PlainText>true</PlainText>

                      <Value>%W10Pass%</Value>

                    </Password>

                    <LogonCount>1</LogonCount>

                  </AutoLogon>

                </component>

              </settings>

              <settings pass="auditUser">

                <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

                  <RunSynchronous>

                    <RunSynchronousCommand wcm:action="add">

                      <Order>1</Order>

                      <Path>c:\windows\System32\sysprep\sysprep.exe /oobe /generalize /reboot </Path>

                    </RunSynchronousCommand>

                  </RunSynchronous>

                </component>

              </settings>

              <settings pass="oobeSystem">

                <component name="Microsoft-Windows-Shell-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

                   <OOBE>

                            <HideEULAPage>true</HideEULAPage>

                            <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>           

                            <ProtectYourPC>1</ProtectYourPC>

                            <SkipMachineOOBE>true</SkipMachineOOBE>    

                            <SkipUserOOBE>true</SkipUserOOBE>

                        </OOBE>

                  <ProductKey>%Win10ProdKey%</ProductKey>

                  <RegisteredOwner>%Company%</RegisteredOwner>

                  <RegisteredOrganization>%Company%</RegisteredOrganization>

                  <UserAccounts>

                    <AdministratorPassword>

                      <PlainText>true</PlainText>

                      <Value>%W10Pass%</Value>

                    </AdministratorPassword>

                  </UserAccounts>

                  <AutoLogon>

                    <Enabled>true</Enabled>

                    <Username>%W10User%</Username>

                    <Password>

                      <PlainText>true</PlainText>

                      <Value>%W10Pass%</Value>

                    </Password>

                    <LogonCount>1</LogonCount>

                  </AutoLogon>

                </component>

              </settings>

              <settings pass="specialize">

                <component name="Microsoft-Windows-Shell-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">

                  <ComputerName>%ldHostname%</ComputerName>

                </component>

               </settings>

            </unattend>

            • 3. Re: Provisioned image stops at OOBE questions
              FrugalRain Apprentice

              try this in pass oobeSystem..

                  <OOBE>

                              <HideEULAPage>true</HideEULAPage>

              <HideLocalAccountScreen>true</HideLocalAccountScreen>

                              <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>

                              <HideOnlineAccountScreens>true</HideOnlineAccountScreens>

                              <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>

                              <NetworkLocation>Work</NetworkLocation>

                              <ProtectYourPC>3</ProtectYourPC>

                              <SkipMachineOOBE>true</SkipMachineOOBE>

                              <SkipUserOOBE>true</SkipUserOOBE>

                          </OOBE>

              • 4. Re: Provisioned image stops at OOBE questions
                Peteski Apprentice

                What version of Windows 10? 1607/1703? x86 or x64 OS?

                 

                Your unattend above is for x86 windows- are you really deploying x86 Windows 10 OS and not x64? If so then you need to check your template and make sure you're injecting an x64 Win10 unattend for the correct version (1607 or 1703).

                 

                I'm doing Windows 10 x64 1607 right now and this OOBE works fine for me:

                            <OOBE>

                                <HideEULAPage>true</HideEULAPage>

                                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>

                                <NetworkLocation>Work</NetworkLocation>

                                <ProtectYourPC>3</ProtectYourPC>

                                <HideLocalAccountScreen>true</HideLocalAccountScreen>

                                <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>

                                <HideOnlineAccountScreens>true</HideOnlineAccountScreens>

                            </OOBE>

                • 5. Re: Provisioned image stops at OOBE questions
                  Leslie2k Apprentice

                  I am trying to deploy 1703 64bit. 

                  • 6. Re: Provisioned image stops at OOBE questions
                    Peteski Apprentice

                    In that case this line in your unattend.xml states you are deploying for x86, so this answer file will likely not work.

                    <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86"

                     

                    You need an answer file for x64. So fire up SIM and make sure you are pointing to a 1703 media install.wim, catalog it and generate a new answer file.

                     

                    This thread in deployment also states (as FrugalRain said) that there are some known issues with 1703 with OOBE section and putting in the deprecated skip sections may help:

                    https://community.ivanti.com/thread/35690

                    1 of 1 people found this helpful
                    • 7. Re: Provisioned image stops at OOBE questions
                      Leslie2k Apprentice

                      Thanks for the assistance.