8 Replies Latest reply on Aug 31, 2017 9:54 AM by phoffmann

    Column set copied to Scheduled task bug?

    rvlasak Rookie

      I took a personalized column set and right click copied to the failed devices on a scheduled task, I saw no indication that it changed my column view (I was looking for reason of failure, i.e. incorrect agent, reboot needed etc. etc.) However, unannounced to me it created a targeted queries group in the Targeted items, then later that evening when the job was rescheduled and started it targeted 4000 additional machines based on a query that has something to do with the column view.  Is this a know bug or a designed feature?

        • 1. Re: Column set copied to Scheduled task bug?
          Recursion SupportEmployee

          When you say you copied the column set to the failed devices on a task, how exactly did you go about doing that?

           

          Since you can't paste a column set to a task, I imagine you ended up copying the devices shown in the column set, and pasted those into that task.

          • 2. Re: Column set copied to Scheduled task bug?
            rvlasak Rookie

            create a job...

            no targets selected

            created a column set that gives me information I use

            Right Click Column Set and copy

            Right Click the task on the devices or status and hit paste (hoping it would tell me a little more about failures

            LANDesk created a "Targeted Queries" group and then hits a ton of machines based on who knows what, I am unable to actually make a query out of the column set that runs.

            • 3. Re: Column set copied to Scheduled task bug?
              phoffmann SupportEmployee

              That sounds like you've discovered a bug to me. I'd log it with support.

               

              Console shouldn't allow the targeting of column sets -- since it's a relatively new feature, I guess no one thought of this possibility going awry in this particular case. Quite amusing really .

               

              I usually apply column sets to scheduled tasks not via copy/paste but via drag & drop (into the right-hand side of the scheduled task) ... see if that does the same thing ... no - that works for me fine (IEM 2017.1 + SU2).

               

              ... but I *can* replicate that "copy / paste" based behaviour you're seeing. So that you should definitely file as a bug.

               

              In the meantime, just drag & drop column sets on to scheduled tasks instead of copy pasting them & then it works as intended.

              • 4. Re: Column set copied to Scheduled task bug?
                Recursion SupportEmployee

                Looks like this only affects some tasks. I originally tried reproducing it using an agent deployment task, and the paste option is greyed out. Software dist let me though.

                 

                I've logged this as a bug. ID is 439514.

                • 5. Re: Column set copied to Scheduled task bug?
                  phoffmann SupportEmployee

                  Aye - it's a bit odd.

                   

                  We'd still need (affected) customers logging this though, so we can attach the to the defect (so - please, do log those support tickets).

                   

                  At least we've got a simple enough workaround for it.

                  • 6. Re: Column set copied to Scheduled task bug?
                    rvlasak Rookie

                    I am unclear on how you are dragging a Colum view to a scheduled task, in my version of LANDesk I can either view Column set configuration from the Administrative tab in the lower view panel, or scheduled task from the distribution tab.  How are you dragging and dropping?  I can drag to a group in network view and I can select the default columns in the task view but I don't see a way to drag and drop to a task, are you dragging it to the group of machines before you run the task?

                     

                    • 7. Re: Column set copied to Scheduled task bug?
                      Recursion SupportEmployee

                      You click and hold the column set, then hover over the scheduled tasks tab in the lower pane. This will switch focus to scheduled tasks. You can then proceed to drop it on the task itself.

                      • 8. Re: Column set copied to Scheduled task bug?
                        phoffmann SupportEmployee

                        Another method is this (ongoing theme of "there's usually at least 3 different ways of achieving the same thing" that I usually do):

                         

                        2x-click on the tool you want to de-couple:

                         

                        With the column sets tool now de-coupled, it's very easy to drag & drop....

                         

                        Leaving us with this end-result (notice the changed columns):

                         

                        Finally, to re-couple the Column sets, just click 2x on the title bar...

                         

                        ... and it goes right back to the hard-linked tools:

                         

                        That's how I've been doing it since ... about 8.0 or thereabouts .