2 Replies Latest reply on Sep 6, 2017 8:37 AM by phoffmann

    No data in report

    BryanNg Apprentice

      Hi,

       

      I tried to run the default report template created by Ivanti but the reports have no data inside it. Any idea what cause this error? Did I configure something wrong?

       

        • 1. Re: No data in report
          rdavidson SupportEmployee

          Try copying the report and pasting it into "My Reports". Then right click it, hit Properties > Preview.

           

          The preview pane will show a sidebar that has the parameters for the report. Change those to be valid for your situation, then hit "View Report".

           

          Running a report right out of the standard reports often provides no results, due to the default parameters.It's best to move it to "My Reports" so you can then adjust it for your needs.

          • 2. Re: No data in report
            phoffmann SupportEmployee

            That's not the problem - the problem is the default setting for the report. It's something that a fair few people trip over.

             

            Easily remedied, you just need to know about it.

             

            Here's what you need to do.

             

            Step 0 - Make sure you've run "Gather Historical" ... certain reports will want/need that data.

             

            1. You run the report. (No surprise there - you've done that)
            2. You EXPAND the sidebar (icon in the left)
            3. Looks like this:
            4. Now with the TOOLBAR expanded, you select the PARAMETERS button (bottom left - 3rd icon on the right). Looks like this:
            5. And *NOW* you can change the important setting. Switch from "AUTO FIX = ENABLED" to either "AUTO FIX = DISABLED" or "AUTO FIX = ENABELD OR DISABLED".
            6. You may want to change other details as well (such as the start & end-dates).
            7. When you're happy with your changes, hit the "VIEW REPORT" button. A few seconds late, you should see something like this:

             

            Remember - you *DO* need to run "Gather Historical" first however. Where is that?

             

            Easy - this is where to look:

            GatherHistorical.jpg

             

            ... and then configure it with the settings you want (Warning, CAN take up a lot of disk space if you do stuff like "report back for the last 5 years").