5 Replies Latest reply on Jul 9, 2009 2:36 AM by jameshopkins

    Troubleshooting SWD in Provisioning


      I created a task that runs a SWD package for Adobe Reader 9. This SWD package deploys the application fine when not run through Provisioning however when trying to run it as a task in Provisioning it fails. These sort of issues are a bit difficult to trouble shoot. Has anyone experience anything like this?


      I appreciate the advice.


      - Paul

        • 1. Re: Troubleshooting SWD in Provisioning
          zman Master

          Is the package actually running and failing? If you look in your windows folder you should see AIClient.log, AIClient.log.1, AIClient.log.2, etc... These are the detailed logs for the swd package. Check them out.

          • 2. Re: Troubleshooting SWD in Provisioning

            I do not have any of these logs in the Windows folder. I attached the failed Provisioning Task.

            • 3. Re: Troubleshooting SWD in Provisioning
              zman Master

              Can review/post the following logs:




              \Program Files\LANDesk\ManagementSuite\prov_schedule.exe.log

              \Program Files\LANDesk\ManagementSuite\log\provisioning\provisioning.log






              If the cleint is installed see if there are any sdclient log files for the app in the \program files\landesk\ldclient\data

              • 4. Re: Troubleshooting SWD in Provisioning

                Seeing as how your other software install tasks succeeded you might try to insert a reboot action betwen them.


                If you're not a fan of logs (I love em, but others don't), try to run the install manually or from the system with the command line parameters to see if it generates some sort of error.  For example, as I suspect, it may prompt you to reboot the system since there is another install that requires a reboot already completed -- if you execute the install from the system the GUI may give you a bit more insight.    

                1 of 1 people found this helpful
                • 5. Re: Troubleshooting SWD in Provisioning
                  jameshopkins Apprentice

                  Hi, has anyone found a solution to this, I am having the same issue with provisioning.


                  I have added on a SWD package to the end of a provisioning task, but it fails as soon as it gets to the package, I get the following error:


                  action index=2709 type=Distribute_software
                  error:[8dac4018H]An unknown error occurred. If the problem persists, contact the LANDesk administrator.

                  I have tried different packages, which all have the same result, these packages are working fine through scheduled tasks.


                  I have checked all the logs mentioned above and there are no entries for failures or errors.


                  Please help, thanks in advance.