4 Replies Latest reply on Sep 27, 2017 9:10 AM by Randis

    Windows 10 cumu Patch Service-Problem

    Randis Apprentice

      Hallo,

       

      wir sind gerade dabei die Migration auf Windows 10 vorzubereiten. Leider haben wir während der OS Installation ein Problem, welches sich wie folgt darstellt.

       

      1. während der Rechner Anwendungen installiert werden keine Patche installiert.
      2. Nach Abschluss der Installation startet der Rechner neu und führt dann den Scan sowie die Installation der erkannten Patche durch.
        1. hier wird auch das letzte kumulative Update für Windows 10 installiert (MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German)
      3. Der Rechner fährt herunter (Update wird von Windows angewendet)
      4. Der Rechner startet neu (Update wird von Windows angewenden)
        1. Der Service startet bevor das Update von Windows angewendet wurde und stellt fest, dass dieser Patch fehlt und versucht ihn erneut anzuwenden.
        2. Das Anwenden das Patches schlägt nach ca. 10 Minuten dann fehl.

       

      Ist jemandem dieses Verhalten ebenfalls aufgefallen und hat einen Tipp wie wir es umgehen könnten?

       

      MfG

      Christian

        • 1. Re: Windows 10 cumu Patch Service-Problem
          SitzRieSe Expert

          Hi Christian,

           

          also wenn es wirklich daran liegt das der Service Installer zu schnell startet, kannst du mit einer Verzögerung arbeiten. Im Infrastruktur Reiter kannst du eine Verzögerung für den Start des Runtime Service einstellen. Wir haben diesen Wert bei allen Systemen auf 10 Minuten. Zumindestens könntest du so schon mal sicher gehen das es daran liegt!

           

          Gruß


          Alex

          • 2. Re: Windows 10 cumu Patch Service-Problem
            Randis Apprentice

            Hallo Alex,

             

            danke für die Antwort. Wir haben den Wert bewußt nicht gesetzt.

            In dem konkreten Fall würde eine Verzögerung des Start der Service um 10 Minuten, eine Verlängerung der Installation um ca. 1 Stunde bedeuten. Das könnte sicher das Problem beheben, wäre aber keine Lösung.

             

            Folgendes ist in den Log zu finden, ich habe versucht nur die relevanten Zeilen zu kopieren.

             

            NISRV32...5.log

            >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

            12:29:27.294 2       ->  AdvPmScanForVulnerabilities('scanFailed','scanError')

            12:30:08.637 2        xniSPD.DLL: ComputerMissingPatch.1861788->MS17-09-W10:windows10.0-RS1-kb4038782-x64-RS1.msu:Windows 10 Enterprise 2016 LTSB (x64):0407

            12:32:46.121 2        Run Job (2 of 32) InstallJob:PolicyInstance.955807 (MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German) [ExecFlags: 0x002010 (install, ws)]

            12:32:46.277 1           -------- >>> Executing project db:master\MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German

            12:32:46.293 2             ---->Starting installation of "MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German"

            13:07:48.152 1              xniSPD.DLL: MissingPatchObject ComputerMissingPatch.1861788 status was set: FIXED, fixed by: DSM

            13:07:48.152 2             ---->Installation of MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German complete.

            13:33:05.318 2  SWMSRT: \\------------| Finished Checking if policies should run for the trigger 'Finished OS installation'. |------------//

            13:33:05.318 2  niMW: At least one project exited with code 'Undone'. OS installation will continue in the next installation polling.

            13:33:05.318 2  niMW: At least one project exited with code 'Undone'. Installation will continue in the next installation polling.

            13:33:08.303 2  Returncode 8

            <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

             

            NISRV...6.log

            >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

            13:35:30.694 2       ->  AdvPmScanForVulnerabilities('scanFailed','scanError')

            13:36:03.491 2        xniSPD.DLL: ComputerMissingPatch.1861788->MS17-09-W10:windows10.0-RS1-kb4038782-x64-RS1.msu:Windows 10 Enterprise 2016 LTSB (x64):0407

            13:36:08.851 2        Run Job (1 of 1) InstallJob:PolicyInstance.955807 (MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German) [ExecFlags: 0x012000 (ri, ws)]

            13:36:09.038 1           -------- >>> Executing project db:master\MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German

            13:36:09.038 2             ---->Starting installation of "MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German"

            13:49:02.597 2              xniSPD.DLL: Installation result is 2149842974

            13:49:02.612 2              xniSPD.DLL: Installation failed with code 2149842974: Operation did not complete because the service or system was being shut down.

            13:49:02.612 2             ->  ExitProcEx(Undone,'(2/3) Installation failed and will be retried after reboot  Operation did not complete because the service or system was being shut down. (0x8024001E)')

            13:49:02.722 2             ---->Installation of MS17-09-W10 for Windows 10 Enterprise 2016 LTSB (x64) (KB4038782) German has not completed on exit.

            13:49:02.784 2  SWMSRT: \\------------| Finished Checking if policies should run for the trigger 'Finished OS installation'. |------------//

            13:49:02.784 0  niMW: Deleting 'OSInstallInProgress' key from the registry

            13:49:02.784 0  niMW: Deleting 'InstallInProgress' key from the registry

            13:49:03.269 2  Returncode 0

            <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

             

            EventLog

             

            Zeit - Quelle - Ebene - Meldung

            12:35:46 - Servicing - Information - Änderungen für Paket KB4038782 werden initiiert. Der aktuelle Status ist "Abwesend". Der Zielstatus ist "Installiert". Client-ID: WindowsUpdateAgent.

            12:07:45 - WUSA - Warnung - Das Windows-Update Sicherheitsupdate für Windows (KB4038782) erfordert einen Neustart des Computers, um die Installation abzuschließen. (Befehlszeile: ""C:\Windows\system32\wusa.exe" "C:\AdvPatchManagement\{1B618F96-4E02-48B2-84F9-7CA3E6179CE8}\windows10.0-kb4038782-x64-RS1_GER.msu"  /quiet /norestart ")

            13:07:46 - WUSA - Information - Das Windows-Update "Sicherheitsupdate für Windows (KB4038782)" wurde erfolgreich installiert. (Befehlszeile: ""C:\Windows\system32\wusa.exe" "C:\AdvPatchManagement\{1B618F96-4E02-48B2-84F9-7CA3E6179CE8}\windows10.0-kb4038782-x64-RS1_GER.msu"  /quiet /norestart ")

            13:56:04 - Servicing - Information - Der Status des Pakets KB4038782 wurde erfolgreich in "Installiert" geändert.

             

            Gruß

            Christian

            • 3. Re: Windows 10 cumu Patch Service-Problem
              SitzRieSe Expert

              Mh... warum läuft der eigtl. nochmal los?

               

              Tatsächlich hab ich persönlich so ein Problem noch nicht feststellen können, weil wir unsere Systeme mit einem AutoLogon User installieren und dann die Installation erst nach der Anmeldung weiter geht... Benutzt du die ExecutionPackages für die Patch Installationen oder hast du da noch irgendwas dazu gebastelt und wie sind die zugewiesen?

               

              Du müsstest irgendwie dafür sorgen das vllt der Start des Service nicht verzögert wird sondern das Ausführen des Paket welches nach Updates scannt. Eine bessere Idee hab ich da tatsächlich nicht... das sieht nämlich einfach nach einem Timing Problem aus.

               

              Gruß

               

              Alex

              • 4. Re: Windows 10 cumu Patch Service-Problem
                Randis Apprentice

                Zwischen den beiden Log-Files liegt ein Neustart (13:33:08.303 2  Returncode 8 ).

                Mit Windows 10 stellen wir unsere Installation von AI (so wie bei dir) auf Service um. Die ExecutionPackages wurden nicht geändert. Die Patch-Pakete werden auf eine dyn. Gruppe zugewiesen, in der die Rechner reinfallen wenn eine Computer-Eigenschaft (Adv Patch) einen bestimmten Wert (ja) hat. Während der OS Installation (OSInstallInProgress=1) wird dieser Wert immer auf nein gesetzt. Das letzte Paket (Abschluss OS-Install) aktiviert dann APM und das Standard Paket ExecutionPackage (Job mit dem Trigger Neuinstallation eines Computers: Ende) wird solange ausgeführt bis keine Sicherheitsanfälligkeiten mehr erkannt werden.

                 

                Gruß

                Christian