2 Replies Latest reply on Oct 25, 2017 6:33 AM by tralveller

    LANDesk 2017.1.1 SWD: batch installation package don't show GUI application

    Rookie

      Hello at all,

       

      at the office we use

      LANDesk Management Suite 2017.1.1

       

      I created a batch, where is opening a application GUI with additional information for the logged on end user:

      START User_Wait_Message_x64.exe

       

      and tested by using psexec in system user context, it worked fine.

       

      This batch is as a batch installation package at LANDesk inbounded.

       

      At deployment I recognized that the applications is started and shown in process manager, but the GUI will not shown by loggod on user.

       

       

      How can show the user the GUI of this application during package installation?

       

      P.S.: the only alternative way I now try is during package installation to create a scheduled task and start the task,

       

      Thanks a lot for feedback

      kind regards

      Tralveller

        • 1. Re: LANDesk 2017.1.1 SWD: batch installation package don't show GUI application
          Tanner Lindsay SupportEmployee

          In the task configuration, have you configured it to show the full UI to the end user? Be default it normally hides UI elements.

          • 2. Re: LANDesk 2017.1.1 SWD: batch installation package don't show GUI application
            Rookie

            Hello tanner,

             

            Thanks for feedback.

            hmm, It seems something like that... but the admins may don't know it.. I don't know, too

             

            In the meantime I performed a workaround.

            During batch script I create a scheduled task which includes the GUI application to start and defined the account for running the scheduled task as local "users" group. This mean, that task will started under current logged on user.

             

            Example:

            ECHO Task which starts the GUI at current User Display

            REM

            ECHO Create scheduled task

            REM On english OS

            SCHTASKS /CREATE /TN "GUI_APP" /TR "C:\Windows\System32\cmd.exe '/C START C:\Temp\GUI_APP.exe'" /RU USERS /SC ONCE /sd 01/01/2001 /st 00:00 /F 2>&1

            REM On german OS, cause in our case english "users" value will not recognized as local build-in user group, so first SCHTASKS /CREATE will fail and script continuing..

            SCHTASKS /CREATE /TN "GUI_APP" /TR "C:\Windows\System32\cmd.exe '/C START C:\Temp\GUI_APP.exe'" /RU BENUTZER /SC ONCE /sd 01/01/2001 /st 00:00 /F 2>&1

            ECHO ^=^> Done..

            ECHO\

            ECHO Start GUI

            SCHTASKS /RUN /TN "GUI_APP" 2>&1

            ECHO ^=^> Done..

            ECHO\

            ECHO Wait 5 seconds

            REM Waiting for secure to make sure that Start of Scheduled Task is finished

            PING 127.0.0.1 -n 6 >NUL

            ECHO ^=^> Done..

            ECHO\

            ECHO ^=^> Delete Scheduled Task

            SCHTASKS /DELETE /TN "GUI_APP" /F  2>&1

            ECHO ^=^> Done..

             

            Problem resolved.

             

            Kind regards

            Tralveller

            1 of 1 people found this helpful