2 Replies Latest reply on Dec 15, 2017 10:17 AM by fkshelton

    Avalanche 6.2 installation - DB Connection failed

    soundofthunder Rookie

      Dear all,

      I would like to know if anyone has made a new install of Avalanche 6.2?

      I've attempted this on my PC (Windows 8.1 SQL Server 2012 existing SQL instance) and also Win server 2012 and SQL server - a new machine with nothing installed on it - just Windows server - on which I installed SQL server 2012 and created new instance.

      On both machines, the installation is done, during it, Ava install asks for DB connection credential and server which are on the same machine, creates Avalanche Databases.

      When installation finished, it's not possible to launch http console; Enterprise server service is stopped, and eache time we try to start is, it fall dows after few seconds with the following error in the logs (colored red):

       

      2017-12-13 16:46:43,366 INFO  LoggingProperties        - Avalanche Server version 6.2.0 - (c) 2013-2017 Ivanti

      2017-12-13 16:46:43,368 INFO  LoggingProperties        - log4jAvalancheServer.properties: located in C:\Program Files\Wavelink\Avalanche\conf\main\log4jAvalancheServer.properties

      2017-12-13 16:46:43,369 INFO  LoggingProperties        - Logging level set to: DEBUG

      2017-12-13 16:46:43,372 INFO  ServerConfigProperties   - ServerConfigProperties initializing

      2017-12-13 16:46:43,432 INFO  ServerConfigProperties   - server-config.xml: located in file:/C:/Program%20Files/Wavelink/Avalanche/conf/main/server-config.xml

      2017-12-13 16:46:43,440 INFO  SpringContextInitializer - SpringContextInitializer initializing

      2017-12-13 16:46:45,733 INFO  SpringContextInitializer - api-factory.xml: located in C:\Program Files\Wavelink\Avalanche/conf/main/api-factory.xml; initialized Wed Dec 13 16:46:43 CET 2017

      2017-12-13 16:46:45,734 INFO  InstallationUUID         - InstallationUUID initializing

      2017-12-13 16:46:45,734 INFO  InstallationUUID         - installationUUID: [de4fd05c-809e-4069-9005-443215c951b7]

      2017-12-13 16:46:45,735 DEBUG AvalancheServer          - Installation UUID initialized

      2017-12-13 16:46:45,735 INFO  AvalancheServer          - Starting Avalanche Server...

      2017-12-13 16:46:45,735 INFO  AvalancheServer          - Local drives are:

      2017-12-13 16:46:45,735 INFO  AvalancheServer          - C:\ D:\ E:\ F:\

      2017-12-13 16:46:45,737 INFO  DatabaseProperties       - DatabaseProperties initializing

      2017-12-13 16:46:45,737 INFO  DatabaseProperties       - Hibernate Dialect set to: com.wavelink.avalanche.db.dialect.WavelinkeSQLServerDialect

      2017-12-13 16:46:45,737 INFO  DatabaseProperties       - Database in use: Avalanche

      2017-12-13 16:46:45,738 INFO  DatabaseProperties       - Data Source URL set to: jdbc:sqlserver://NEWSRV2017:1433;databaseName=Avalanche

      2017-12-13 16:46:45,787 ERROR DatabaseProperties       - HibernateSequenceCheck: No DB connection

      2017-12-13 16:46:45,787 ERROR DatabaseProperties       - setDatabaseProperties() failed.

      2017-12-13 16:46:45,787 FATAL AvalancheServer          - Unable to initialize DatabaseProperties.

      2017-12-13 16:46:45,787 FATAL AvalancheServer          - Initialization failed when attempting to set property: setDatabaseProperties()

      2017-12-13 16:46:45,787 FATAL AvalancheServer          - <<<< Avalanche Server will terminate... >>>>

      2017-12-13 16:46:45,788 INFO  AvalancheServer          - <<<< Avalanche Server has terminated >>>>

       

      Could somebody tell me what happens here and why is the wizard able to create database and establish db connection and not the enterprise server service?

      Thx in advance for your help

      Elie