1 Reply Latest reply on Dec 19, 2017 10:16 AM by Casity.chris

    Ivanti Agent on iPhone "not enrolled" when device has been enrolled via DEP

    Rookie

      Hi Everyone,

       

      I've encountered an odd problem which is effecting numerous devices in our organisation.

      We're currently still setting up MDM and in the testing phase.

       

      I've got a iPhone which is enrolled in DEP and assigned. When i wiped and started it up I get presented with the MDM DEP enrolment as expected. This enrolment is successful, and i can then see the device appear in the Management console.

      I'm able to push Apps and Settings successfully, so that bit is working all good as expected.

       

      The issue we're having is when i try to load the Software Catalogue in the LANDESK Workspace app it tells me the device is not enrolled.

      When i open up the Ivanti Agent App on the iPhone, that also tells me the device is not enrolled.

      When we try to go through the enrolment in the Ivanti App, it try's to install the MDM Profile (This profile already exists as it was installed through DEP).

      The exact error which appears is "Profile Installation Failed: The new MDM payload does not match the old payload."

       

      While testing this out, I setup a iPhone that wasn't in DEP and enrolled it through the Ivanti App, When i open LANDESK Workspace i can successfully download/install apps from the Software catalogue.

       

      Thanks in advance for your help.