4 Replies Latest reply on Nov 9, 2009 1:00 PM by technobabble

    Sporadic results with software distribution

    Rookie

      I am getting sporadic results when scheduling a task. Either:

       

      1.  The console states it is done.  I log on and test and everything has been installed successfully.

      2.  The console states it is done.  I log on adn test, but everything is not installed successfully (shortcut not created)

      3.  Getting "Failed to download all additional files for a package"

       

      We are on LDMS 8.8 SP2

      Windows XP Pro SP2

      Office 2003 SP3

       

      I am pushing the same package to all machines at the same time and getting different results.

       

      The complete install includes 4 dependent packages.  The delivery method is a Policy Supported Push.

       

      Has anyone ever experienced anything like this?

        • 1. Re: Sporadic results with software distribution
          egarlepp Employee
          1. In terms of the the first message that is good and not much to do there.  ;-)
          2. 2nd message, have you tried restarting the system to insure that it completes.  Sometimes you can get a successful with extra messages, review task log. 
            1. I would also take a look at the log files for the systems and the core to see if you can see anything different.  Here is a link to find the log files for software as well as other LD stuff - http://community.landesk.com/support/docs/DOC-5130 
            2. Take a look at xtrace for further logging/troubleshooting - This thread will help - http://community.landesk.com/support/message/24453#24453
          3. Are the systems pointing to DFS, local or a package server.  I would check that the hash file matches on these distribution points.  Also if you are using DFS, check that it is available.
            1. Take a look at this thread , it may give you some ideas - http://community.landesk.com/support/message/26269#26269 . It is not directly related to your issues, but has some points to troubleshooting that may help.  Look at the SWD updates to the SP2a agent.

           

          Other things to try:

          • You can also try changing the delivery method or try different packages to see if you get the same results
          • Try to Disable any bandwidth throttling or Targeted Multicasting and do a straight push without any throttling/network checking
          • Try to Disable "require non-RAS connection"


          And if all else fails upgrade the client to SP3 or reinstall the agent.


          • 2. Re: Sporadic results with software distribution
            Rookie

            Thanks for the reply.  Good information.

             

            I found one thing strange in the sdclient.log file of the machine that failed to download additional files.

             

            Download information for http://landesk.venable.com/ldapps/WorkshareProfessional/Source Files/Workshare_Hummingbird.msi : 34,465,792 bytes in 0:00:16.984 seconds, bandwidth 1981.7475 kb/s
            Thu, 28 May 2009 13:36:03 Performing TCP connection with a timeout of -1 milliseconds
            Thu, 28 May 2009 13:36:04 Performing TCP connection with a timeout of 2500 milliseconds
            Thu, 28 May 2009 13:36:04 SAD ProcessNeedFileReply about to download http://landesk.venable.com/ldapps/WorkshareProfessional/Source Files/WorkshareEula.rtf from peer 172.29.68.108

             

            In the first red section it is downloading the files from the LANDesk server.  But the second red section looks like it's trying to download from a peer. 

             

            The delivery method is a Policy-supported push.  Below are the settings:

            1. Use download from source to deploy files
            2. Require a non-RAS network connection and allow any non-RAS network connection are selected
            3. Dynamic bandwidth throttling is selected with minimum available bandwidth to use set to 50%
            4. Delay between packets for peer and source are both set to 1.
            5. Required...Once
            6. Downgrade functionality to level of operating system is selected
            7. Downgrade functionality to level of agent is selected.
            8. Discover devices
              1. Both
              2. Retries = 3
              3. Timeout = 500
              4. Timeout for subnet = 2500
              5. Disable subnet broadcast and disable dns/wins lookup are both selected.

             

             

            • 3. Re: Sporadic results with software distribution
              egarlepp Employee

              Well when doing distribution tasks, the client automatically checks in this order for the files -

              1. It's local cache
              2. then local subnet(peers)
              3. then preferred package server(if set)
              4. then core package setup.

              So what looks to be happenening is that it downloaded the first one from the core successful, then tried to download the next from a peer and that is where it failed.  The peer could have dropped the connection or failed somehow. Did you run a xtrace on system, i would be interested in seeing what it says?

               

              You can also test it out, by going to peer and remove the files from the sdmcache folder and run it again.  Also, i would remove the RAS stuff, i have always seen weirs issues when that is enabled.  It may be causing the hiccup.  See if that helps.

              • 4. Re: Sporadic results with software distribution
                technobabble Apprentice

                This can also happen when DNS lookup fails. Check DNS and insure that there are no duplicate records for machines that have the same IP address. For instance, when a machine attempts to resolve the name of a peer that contains the files, it may attempt to get the files from a machine that may not have the files in cache because RARP will resolve the IP address to the wrong machine.

                 

                For example, run xtrace on an affected machine. Then run nslookup for a peer machine that it attempted to perform a download from to see if the machine resolves to the correct IP address. You can also check your LANDesk database to see if you have machines with the same IP address in the database.