9 Replies Latest reply on Feb 16, 2016 5:00 PM by Jason.Karoub

    GM opens web links in wrong browser under Windows 10

    sbailey@mutualconsultants.ltd.uk Rookie

      My desktop GM (v 2014.1.0.489) on my Windows 10 laptop always opens web links in Internet Explorer even though Google Chrome is set as my default browser.

       

      All other applications open links in Chrome as expected. (Note: on machines running Windows 7, links in GM open in the default browser as expected.)

       

      Does anyone else have this problem, or know of a solution?

       

      Maybe it is a bug in GM?

        • 1. Re: GM opens web links in wrong browser under Windows 10
          TPorte Apprentice

          I think Goldmine always uses IE, that has been my experience.  I don't know if there is a setting in Goldmine to get around this.  You will want to check your default file associations to make sure Chrome is set to open files like .htm and .html.

          1 of 1 people found this helpful
          • 2. Re: GM opens web links in wrong browser under Windows 10
            sbailey@mutualconsultants.ltd.uk Rookie

            For me, it correctly uses the default in Windows 7, but not in Windows 10.

            • 3. Re: GM opens web links in wrong browser under Windows 10
              John Neighbors SSMMVPGroup

              Just to confirm, in case it's helpful...

               

              Sounds like something's awry to me.  My GoldMine opens Chrome for everything.  Yes, I'm running Windows 10.

               

              I suspect it's a Windows-related setting that doesn't have Chrome properly identified (although, as you say: All other applications open links in Chrome as expected).

               

              I have no idea if this will be even remotely helpful, but...

               

              I just went and looked at these settings on my system:

               

                Windows | Settings | System | Default Apps

               

              I was surprised to see "Web browser" is not even set, but rather, reads:  + Choose a default     :-) Wow, really?

               

              I then chose: Choose default apps by protocol (an option at the bottom).

               

              I'm seeing the following are all set to Google Chrome:

               

              FTP

              HTTP

              HTTPS

              IRC

              MAILTO

              MMS

              NEWS

              NNTP

              SMS

              SMSTO

              TEL

              URN

              WEBCAL

               

              Just thought I'd share, in case it's helpful.

              1 of 1 people found this helpful
              • 4. Re: GM opens web links in wrong browser under Windows 10
                sbailey@mutualconsultants.ltd.uk Rookie

                John, that was interesting - thank you. I proves that I should be able to get my GM working correctly because yours does.

                 

                All my relevant Protocol and File Type settings are set to Chrome and I have told Chrome to be the default for everything that it can be, but GM still opens links in Internet Explorer.

                 

                But why Internet Explorer?

                 

                Before I installed Chrome (which I did before I installed GM by the way), the default web browser was Microsoft Edge. This suggests to me that GM is explicitly launching Internet Explorer. So, maybe there is a GM setting that I have not yet been able to find which will cure this.

                • 5. Re: GM opens web links in wrong browser under Windows 10
                  tmarkadr Rookie

                  Not sure if this would cause an issue because it's really pointing the other direction but look at your Email Options in GM. Is the box checked for Use GM as Explorer's e-mail client? If so, try unchecking that. See if it makes any difference.

                  • 6. Re: GM opens web links in wrong browser under Windows 10
                    sbailey@mutualconsultants.ltd.uk Rookie

                    Yes, that box is checked. So, I unchecked it and closed the Options dialog. BUT, if I open the Options dialog again then the check is back! GM refuses to allow me to save it unchecked.

                     

                    However, I very much doubt if it has anything to do with the default browser.

                    • 7. Re: GM opens web links in wrong browser under Windows 10
                      Jason.Karoub SupportEmployee

                      This behavior and resolution is also described in our Knowledge Article 14822.

                       

                      You can access our knowledge base via the Self Service Portal at:

                      https://support.heatsoftware.com and you can select the at the top the Knowledge base. After opening the Knowledge base tab you can search for Knowledge Base e.g. for certain key words and or the provided article 14822.

                       

                       

                      NOTES:

                      While this is solely a Windows related (and not GoldMine related) inquiry in which we usually do not assist with, please see the following suggestion. There is no setting within GoldMine which handles this, but refers only to the Windows Operating System / User profile setting default handler for HTML and HTM URL/files.

                       

                      IMPORTANT: Please keep in mind that this is only provided as is without any warranty of any kind. Also there may be other ways to achieve this even from the front end e.g. by the default handler / default programs feature within Windows which is not stated here.

                       

                      When setting Google Chrome as default browser, certain registry keys are usually changed. If you change this so that internet pages should launch in Internet Explorer instead of Google Chrome but the behavior doesn't change back, the cause might be that the Google Chrome has modified registry keys for default .HTML and .HTM settings on the machine. GoldMine support is not responsible for making changes to your registry.  It is always a good idea to make a backup of your registry before making changes to it.

                       

                      To change this back to default of using the Internet Explorer browser on the machine, you can do the following:

                      1. Open the registry editor on the machine (Start > "Run", type "regedit" and click OK)

                      2. Browse out to HKEY_CURRENT_USER\SOFTWARE\CLASSES\ and click on the .HTM folder/key

                      3. Double-click on the  value on the right and remove the entry:"ChromeHTML" from the "Value Data" field

                      4. Replace this entry with "htmlfile" and click "OK"

                      5. Now Browse out to HKEY_CURRENT_USER\SOFTWARE\CLASSES\ and click on the .HTML folder/key

                      6. Double-click on the  value on the right and remove the entry:"ChromeHTML" from the "Value Data" field

                      7. Replace this entry with "htmlfile" and click "OK"

                      8. Log back into GoldMine and open a hyperlink from here (from an email, etc...) to test NOTE: you may need to reboot the machine since a registry edit has occurred

                       

                       

                      When the situation is reversed, means Google Chrome should open the links but Internet Explorer is still used then the values should be simple changed, means

                       

                      1. Open the registry editor on the machine (Start > "Run", type "regedit" and click OK)

                      2. Browse out to HKEY_CURRENT_USER\SOFTWARE\CLASSES\ and click on the .HTM folder/key

                      3. Double-click on the  value on the right and remove the entry:"htmlfile" from the "Value Data" field

                      4. Replace this entry with "ChromeHTML" and click "OK"

                      5. Now Browse out to HKEY_CURRENT_USER\SOFTWARE\CLASSES\ and click on the .HTML folder/key

                      6. Double-click on the  value on the right and remove the entry:"htmlfile" from the "Value Data" field

                      7. Replace this entry with "ChromeHTML" and click "OK"

                      8. Log back into GoldMine and open a hyperlink from here (from an email, etc...) to test NOTE: you may need to reboot the machine since a registry edit has occurred

                      1 of 1 people found this helpful
                      • 8. Re: GM opens web links in wrong browser under Windows 10
                        sbailey@mutualconsultants.ltd.uk Rookie

                        Jason,

                        I looked in HKEY_CURRENT_USER\SOFTWARE\CLASSES\.htm and the default value was not set to anything at all. I have set it to ChromeHTML (same for .html) and now GM does use Chrome. Fantastic :-) (I wonder why Chrome did not do that when it asked to be the default?)

                         

                        So, thank you very much for your help!

                         

                        (By the way, I tried to look at the Knowledge Base your referred to but when I try to log in I receive this message: "You cannot login to the system now. Please contact your administrator. Additional information is available in the logs". It's been like that for several days that I know of.)

                         

                        Additional information...

                        Since editing my registry, Chrome now thinks it is NOT the default browser any more! So, I said "Yes" when it asked if it should be the default browser. Then I looked at HKEY_CURRENT_USER\SOFTWARE\CLASSES\.htm again and the edit that I made earlier (see above) has been erased! So, I checked GM and it still opens in Chrome as I want it to. Weird or what?

                        1 of 1 people found this helpful
                        • 9. Re: GM opens web links in wrong browser under Windows 10
                          Jason.Karoub SupportEmployee

                          Steve,

                           

                          I am glad the provided information helped you.

                           

                          I am sorry to hear that you cannot login to our Support Portal.  Please either email [email protected] or call 1.800.755.2100 and use the option for Customer Care.  I am not able to alter or otherwise fix your login but I know that Customer Care can fix you up.