13 Replies Latest reply on Aug 29, 2017 10:30 AM by RSanch

    License File is inaccessible. Network Path was Not Found

    RSanch Rookie

      Installing Goldmine on a different domain (these two domains have a trust established) - install went through but when I try to launch the program the following occurs. The computer has the gm.ini in the C:\\Program FIles (x86)\Goldmine.

       

      Goldmine server is on Domain A:

      Trying to get goldmine on Domain B: with a trust established between A and B.

       

      Anyone else run into this issue?

       

      (( I posted this to the get started forum, I think that was the wrong place ))

        • 1. Re: License File is inaccessible. Network Path was Not Found
          TPorte Apprentice

          I think you are in the right place now!

          Have you checked your gm.ini to make sure it is pointing to the right network location?

          Have you mapped a drive from domain a onto domain b?

           

          Just a couple of initial thoughts, never tried this before!

          • 2. Re: License File is inaccessible. Network Path was Not Found
            RSanch Rookie

            Yeah I was able to map the drive from domain A to domain B (had to use IP instead of name) . However as I'm typing this something just hit me. The gm.ini shows the following.

             

            [GoldMine]

            realini=Z:\Goldmine\gm.ini

             

            This is on domain B - i switched the \Goldmine\ to the \IPAddress\ and it gave me the following error 

            I then browsed to locate the LicenseGM94.BIN file on the network drive that was mapped from domain A. I was then able to get to the login screen for goldmine, however it then gave me the following error when I tried to log in.

             

            • 3. Re: License File is inaccessible. Network Path was Not Found
              Doug Castell Expert

              ideally, you'd set the realini= setting to a UNC path pointing to the correct location of the ini file (ie: \\newserverx\apps\goldmine\)  If your logged-in windows user doesn't have appropriate rights to the share, remedy that at the server.

               

              It looks like you've got that pretty much solved. 

               

              What you're facing probably now is SQL connectivity to the server.  That might be because the SQL server hasn't been fully setup to listen for incoming connections or it might be because of firewall on the new server.  In the case of the former, set your server to listen on TCP/IP on all appropriate local IP addresses.  In the case of the latter, either turn off the firewall or poke the proper holes through it for named pipes and/or tcp/ip traffic on the SQL server ports to pass through unhindered. 

               

              Here's a .batch file that will open the ports on the server, when executed as administrator.

               

              @echo ========= SQL Server Ports ===================
              @echo Enabling SQLServer default instance port 1433
              netsh advfirewall firewall add rule name="SQL Server" dir=in action=allow protocol=TCP localport=1433
              @echo Enabling Dedicated Admin Connection port 1434
              netsh advfirewall firewall add rule name="SQL Admin Connection" dir=in action=allow protocol=TCP localport=1434
              @echo Enabling conventional SQL Server Service Broker port 4022
              netsh advfirewall firewall add rule name="SQL Service Broker" dir=in action=allow protocol=TCP localport=4022
              @echo Enabling Transact-SQL Debugger/RPC port 135
              netsh advfirewall firewall add rule name="SQL Debugger/RPC" dir=in action=allow protocol=TCP localport=135
              @echo ========= Analysis Services Ports ==============
              @echo Enabling SSAS Default Instance port 2383
              netsh advfirewall firewall add rule name="Analysis Services" dir=in action=allow protocol=TCP localport=2383
              @echo Enabling SQL Server Browser Service port 2382
              netsh advfirewall firewall add rule name="SQL Browser" dir=in action=allow protocol=TCP localport=2382
              @echo ========= Misc Applications ==============
              netsh advfirewall firewall add rule name="SQL Browser udp 1434" dir=in action=allow protocol=UDP localport=1434
              netsh advfirewall set allprofiles settings unicastresponsetomulticast enable

              2 of 2 people found this helpful
              • 4. Re: License File is inaccessible. Network Path was Not Found
                RSanch Rookie

                Even after running your script its still giving the same database connection problem error. I checked the TCP/IP Properties for the SQL Server Configuration Manager under SQL Server Network Configuration - and I added the following.

                Every other IP in there was not enabled, I enabled this one (that IP is the IP of the domain server I'm trying to set up goldmine on).

                I turned off the firewall and it was still giving the database error. I'm probably trying to poke holes incorrectly.

                 

                Sidenote: I set the realini path and that remedy that small step. Now just connecting to the database is the core issue.

                • 5. Re: License File is inaccessible. Network Path was Not Found
                  Doug Castell Expert

                  You're on the right track with the server network listener...  Tell it to listen on all the various IP and to NOT use dynamic ports.  Then restart the SQL service.  Then try again.

                  • 6. Re: License File is inaccessible. Network Path was Not Found
                    RSanch Rookie

                    So thus far I have it enabled and to listen to all -  I have it to NOT use dynamic ports (remove the 0)

                     

                    Restart the SQL Server and still the same error -

                    • 7. Re: License File is inaccessible. Network Path was Not Found
                      JErste Specialist

                      The issue may be with the database configuration in the alias manager.  If only the server name is used, the end user workstation(s) on the separate domain from the SQL server may only be searching its domain for that server name.  I recommend changing the to the full network name with the domain (i.e. sqlserver.domainname.local) or to an IP address for the SQL server name.  You can change this in the dbalias.ini file.

                      • 8. Re: License File is inaccessible. Network Path was Not Found
                        JMessi Apprentice

                        When I find this error, I do the following steps:

                        1) make sure SQL is running also make sure SQL Browser

                        2) check the firewall

                        3) check the Host= in the dbalias.ini file.  I usually copy this from the studio manager when I first open it.

                        4) check you ports are open.

                         

                        It is usually step 3 that cures the issue for me.

                        • 9. Re: License File is inaccessible. Network Path was Not Found
                          RSanch Rookie

                          1.) sql is running

                          2.) firewall on or off won't allow it to connect to sql

                          3.) the host file points to the correct info (from studio manager) and in response to JErste i changed it to an IP scheme in the dbalias.ini file and still nothing

                          4.) ports are open (1434, 1434 along with other ports from the script I ran by DCastell

                          • 10. Re: License File is inaccessible. Network Path was Not Found
                            JMessi Apprentice

                            please email me and I shall send you some documents that I have acquired over the years to correct the error.

                            maybe something in these old documents might work for you.

                            [email protected]

                            • 11. Re: License File is inaccessible. Network Path was Not Found
                              jshirley338 Rookie

                              RSanch did you ever get this figured out?

                              • 12. Re: License File is inaccessible. Network Path was Not Found
                                CDohme Apprentice

                                This can also happen when a user's Windows domain account it locked.  If they can no longer reach the mapped drive for Goldmine then the license message is displayed.

                                • 13. Re: License File is inaccessible. Network Path was Not Found
                                  RSanch Rookie

                                  Yes I did, here are my notes, start from the bottom and work up.

                                   

                                   

                                  • (Creator) (Assignee) added a comment
                                    10 months ago

                                    Ticket Closed:

                                   

                                  • (Creator) (Assignee) added a comment
                                    10 months ago

                                    Once it was installed it was asking for a license.
                                    On the main domain side, went into Tools > Configure > License Manager
                                    New Site > Goldmine Site License. Site name is DomainB, number of users is 1 (There is only one person on domain B). Clicked Create Site sub-License.
                                    Copied that long serial number it gave, saved out.

                                    Then went back to the Domain B side and input that serial number into goldmine launch and it took it.
                                    Did not import in any windows accounts
                                    Left the login fields blank so it will crate master/access user.
                                    Nothing more needed, goldmine is up and running now on its own new database.

                                   

                                  • (Creator) (Assignee) added a comment
                                    10 months ago

                                    There was a screen before that last punch in, unchecked the demo box.
                                    Left the configuration file box checked.
                                    Installed.

                                   

                                  • (Creator) (Assignee) added a comment
                                    10 months ago

                                    When installing goldmine, instead of installing on existing database. I installed on new Database.
                                    made the name Server name used the IP of the goldmine server on domain A, Made the database name DomainB
                                    Used the SA username and password for sql
                                    Left the boxes unchecked.