5 Replies Latest reply on Aug 30, 2017 9:09 AM by SWilli2

    gmmailatt folder location

    SWilli2 Rookie

      How can I change the default location of GMMailAtt folder?  I do not want it to reside in ProgramData\Goldmine

        • 1. Re: gmmailatt folder location
          JErste Specialist

          Through the GoldMine interface, this is managed on a per-user basis.  In the User Options window, click into the E-mail tab, then click the 'More Options...' button to open the E-mail Options window.  Click into the Retrieval  tab.  The bottom section displays the folder settings for that user.

           

           

           

          The default value should match the System Directory folder defined in the GM.INI file in the GoldMine shared folder.  In the GM.INI file the SysDir= setting under the [GoldMine] section stores the GoldMine System Directory.  This setting should be the network location of the GoldMine share.  If this does not exist, it should be added.  For network configuration, it should be a UNC path or mapped drive to the network share.  If it is C:\ProgramData\GoldMine\, this will be an issue and should be updated.  Be sure to include the '\' at the end of the folder path.  This should update the default attachments directory for new users.  For users that have already logged in, but not manually edited their E-mail Retrieval settings, this may not change the default location.  They can be updated manually through the interface.

           

          If you wish to define a global setting that cannot be overridden you can add a [User-Override:Internet] section to the GM.INI file:

           

          [User-Override:Internet]

          AttachDir=G:\GoldMine\Mailbox\Attach\

           

          The AttachDir= setting defines the 'Attachments Directory' for all users.  Be sure to include the '\' at the end of the folder path.

           

          The check boxes can also be set using the following:

           

          [User-Override:Internet]

          AttachDir=G:\GoldMine\Mailbox\Attach\

          AddUserToAttachDir=1

          AddYearToAttachDir=1

          AddMonthToAttachDir=1

          LinkAttachToCont=0

           

          The AddUserToAttachDir= setting matches the 'Organize attachments in a folder by receiving user' option

          The AddYearToAttachDir= setting matches the 'Organize attachments in a folder by received date year' option

          The AddMonthToAttachDir= setting matches the 'Further organize attachments in a folder by received date month' option

          The LinkAttachToCont= setting matches the 'Save attachments as linked documents' option

           

          For each of the check boxes, setting the value to 1 enables the option (checks the box) and 0 disables the option (unchecks the box)

           

          Using this method, all users will have the same settings.  If they attempt to change those setting, it will be restored the next time they log into GoldMine.

          • 2. Re: gmmailatt folder location
            SWilli2 Rookie

            Thanks Joseph.  I am not sure whether or not your reply deals with our scenario. I should have been clearer when I posted my question.

            I am upgrading an old Goldmine installation from Windows Server 2003 and moving to a new server.  On the old server, the program files and attachments are in a folder structure D:\Apps\Goldmine\...  On the new server I do not want the mail attachments to be saved to the C:\ drive.  In testing I have set the Attachments directory in the user's preferences, as shown in your reply, to a location other than C:\ProgramData\Goldmine\Mailbox.  When external emails are received the attachment is saved where I want it (in this case on the e:\ drive).

            However, when I  create a Goldmine E-Mail and if, in the Edit E-mail Options, I select the option 'Send a copy of the attached file(s) to GM recipients', the resulting attachment is saved in C:\ProgramData\Goldmine\GMMailAtt\(Username).

            I have been unable to find a User Preference or an ini setting to change the default behaviour.  Do you know of a solution?

            • 3. Re: gmmailatt folder location
              JErste Specialist

              I'm not sure if this will work, but you can try updating the User Properties to use e-mail server instead of using GoldMine messaging.  You will need to add their e-mail address and change the sending option.

               

              • 4. Re: gmmailatt folder location
                SWilli2 Rookie

                Thanks Joseph, That looks like a viable workaround.  We have been using Goldmine for about 20 years and have always used GoldMine messages internally.  I will try it out and see what reaction I get from end users.

                • 5. Re: gmmailatt folder location
                  SWilli2 Rookie

                  I have asked Goldmine Support for an answer.

                  They replied: "There is no setting to control this folder location, it is hard coded to the application."

                  I asked for this to be considered as an enhancement but was told that this is considered legacy functionality.

                  They also suggested using an e-mail server to deliver messages to Goldmine Users as Joseph did.

                  I hope this helps if anyone searches on this topic in future.