2 Replies Latest reply on Feb 1, 2018 1:04 AM by Stefan13

    Benutzerbezogene Scriptanteil wird nicht mehr ausgeführt

    Apprentice

      Hallo,

       

      ich rätsel hier gerade warum ein Script der Firefoxinstallation nicht wie (früher) erwartet funktioniert.

      Der Benutzerbezogene Teil wie z.B.

        

      !Standard Profil einrichten

      If not Exist('%appdata%\Mozilla\Firefox\Profiles\Standard.default\')

      InstallFileList('%appdata%\Mozilla\Firefox\Profiles\Standard.default\')

        .\extern$\Standard.default\cert_override.txt

      ...gekürzt.....

        .\extern$\Standard.default\webappsstore.sqlite

      EndProc/F/TU

       

      wird nicht ausgeführt. Im Log sehe ich dann folgende Einträge:

       

      16:10:58.945 1    Evaluating condition "not Exist('_appdata_\Mozilla\Firefox\Profiles\Standard.default\')"
      16:10:58.945 2    Condition TRUE-> entering IF part

       

      16:10:58.960 2    ->  InstallFileList('C:\Users\frs\AppData\Roaming\Mozilla\Firefox\Profiles\Standard.default\') ... /F/TU
      16:10:58.960 1     Skipping user-cmd.

       

      16:10:58.960 2    -> Copy('C:\Program Files (x86)\Common Files\enteo\RepositoryCache\18079\rev\17\extern$\profiles.ini','C:\Users\frs\AppData\Roaming\Mozilla\Firefox\profiles.ini')/TU
      16:10:58.960 1     Skipping user-cmd.

       

      Ich bin während der installation schon mit einem User angemeldet und verstehe nicht warum das Script nicht mehr funktioniert bzw. mit dem frs User hantieren will.

       

      Mfg

      Stefan

        • 1. Re: Benutzerbezogene Scriptanteil wird nicht mehr ausgeführt
          FrankScholer Master

          Hallo Stefan,

           

          ich nehme mal stark an, dein Logfile-Auszug stammt aus dem Service-Installer Log (NiSrv32_frs_#.log), oder? Weil der Service-Installer führt nie User-Teile aus, das macht nur der Auto-Installer. Der Auto-Installer wird normalerweise vom NetInstall Agent gestartet (niagnt32.exe) und der wiederum in aller Regel über ein Login-Script (oder Run-Key oder Autostart-Eintrag)... das Logfile dazu heißt dann NiAi32_<username>_#.log und dort drin solltest du eigentlich keine "Skipping user-cmd" EInträge sehen...

           

          HTH, Grüße Frank

          • 2. Re: Benutzerbezogene Scriptanteil wird nicht mehr ausgeführt
            Apprentice

            Hallo Frank,

             

            ermh, ich sollte so spät nicht mehr nach Fehlern suchen....*g

             

            Im User Log steht nichts (wirklich nichts) ausser folgende Meldung:

             

            08:49:34.642 1  siClnt32: > Action 'Validate Client State' started

            08:49:34.642 1   siClnt32: > Action 'Validate Client State' completed without warnings (Action took 0 ms.)

            08:49:34.642 2  The installer has not yet been started in this user session

            08:49:34.642 2  !!! Problematic GPO detected:

            08:49:34.642 2  !!! The GPO 'Run logon scripts synchronously' is enabled. If the NiAgnt32 is run from a logon script it will be terminated when the script finishes.

            08:49:34.642 2  !!! This policy is found for computers in 'Computer Configuration\Administrative Templates\System\Scripts'.

            08:49:34.642 2  !!! and for users in 'User Configuration\Administrative Templates\System\Scripts'.

            08:49:34.642 2  !!! Please consider deactivating these policies.

            08:49:34.657 0  Status Dialog Thread start

             

            Kann es sein das das die User Script-anteile killt?

             

            Da wir teilweise GPOs der übergeordneten OU vom Rechenzentrum bekommen würde das erklären  das es von einem Tag auf dem anderen nicht mehr geht.

             

             

            Mfg

            Stefan