6 Replies Latest reply on Mar 13, 2018 5:48 AM by 1Z3qogwW

    Domain join failed the error code was 1326

    1Z3qogwW Rookie

      Hello!

      We have a problem with a domain registration. In the past we created a "private data" variable for password under global variables and it worked fine with all PC models so far. Recently we get the error 1326 with some PC models (user data are wrong). As soon as I insert the password directly into the template or the variable as plain text, everything works fine.

      We can live with that, but it would not be bad to correct this mistake.

      Yours sincerely.

      Translated with www.DeepL.com/Translator

        • 1. Re: Domain join failed the error code was 1326
          timothyb SupportEmployee

          I think this might have been posted under the wrong section.  This is for the Ivanti (formerly AppSense) Application Control/Manager product.

          • 2. Re: Domain join failed the error code was 1326
            phoffmann SupportEmployee

            So - if this is a reproducable bug / defect, then...

             

            • Support would be the folks to contact with this (so they can check it / duplicate it / submit it).
            • Since you've not specified what version / release you're on (i.e. "EPM 2017.3  + SU1" for example), can't exactly say how out-of-date / in-date you are with your software stack.

              That's something that support will be able to help out with (for instance, if you're 1 year behind, then chances are that this may have been addressed in the updats during that year).

            That's the way forward on this one. Contact support & submit the bug (/check for updates for your version / build).

            • 3. Re: Domain join failed the error code was 1326
              1Z3qogwW Rookie

              Sorry!

              I don't ask the questions very often.

               

              2017.3 + SU2 yesterday re-recorded yesterday in the hope that all bugs will be fixed.

               

              Variable as private data.

              privatdaten_variable.PNG

              Variable as plain text

              plaintext.PNG

               

              Variable as "private data" but before new start

              fine.PNG

               

              I can't explain why they behave like that. Net drivers have been checked and tested. This also happened overnight. No one has changed settings or made updates.

              • 4. Re: Domain join failed the error code was 1326
                phoffmann SupportEmployee

                No problems. So you're version is pretty recent. Humm ... very odd (especially the "all of a sudden breaking" part).

                 

                OK so ... interesting question (to help get a bit more information perhaps) -- turn on account auditing on the DC when you re-try that ... that MAY give us a bit more information as to why the domain join failed.

                 

                GOTCHA -- essentially, we can only report "hey - it failed", since (really annoyingly) there's not a lot of information for reasons for failure (I suspect mainly a security precaution).

                 

                SO you may have to enable account auditing on a DC to see "its side of the story" (/get a few more bread crumbs as to what's going on).

                 

                Couple of things to think about:

                • Did the DC('s) get patched recently? Possible that one of the more recent Microsoft patches changed something?

                  That may not HELP necessarily right away, but at least it should make sense of things WHY it happened "all of a sudden" & will help with the duplication (may even be down to DC Windows version?) .

                • See what the DC-side account auditing has to say. Essentially, we're looking for the reason *WHY* the domain join hasn't worked. Now - word of warning, the "error messages" from account auditing are not SUPERBLY helpful (mildly put), and there's usually some guesswork / psycho-analysis involved as to what the REAL problem is, but at least it gives you a direction to look at.

                  Having that information should certain help figure out what's ACTUALLY going on, I would hope.
                • Definitely you're doing the right thing - passwords should be sensitive strings & that stuff needs to work. Since you didn't update the LDMS Core, i *SUSPECT* that it's more likely that a Microsoft patch or something like that performed an environmental change (that's just guessing though), so that's why I suggested the above steps.

                 

                Hope that helps you progress this a bit further?

                • 5. Re: Domain join failed the error code was 1326
                  1Z3qogwW Rookie

                  It's gotten worse now. HP EliteBook 850 G4 doesn't work at all Domain Accession. I tried all the tricks. It concerns only the latest models e. g. HP ProBook 650 G3, HP 400 G3.

                  • 6. Re: Domain join failed the error code was 1326
                    1Z3qogwW Rookie

                    I don't have the real explanation. After trying a lot of things, I analyzed the LOG files meticulously and checked every bug. From the several contributions, from different forums, I figured out a solution together.

                    The problem is the UNATTENT. XML file. We have a variable in the TAG <ComputerName>. The value of the variable is read from the database. So far, everything is correct. Only Windows does not play along and causes an error.

                    As soon as I delete the variable from the TAG, everything works fine.

                    ……..

                    <settings pass="specialize">

                            <component name="Microsoft Windows Shell Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="%processorarchitecture%">

                                <ComputerName>%ldHostname%</ComputerName> ERROR 1326

                                <ComputerName></ComputerName> WORK FINE

                                <ProductKey>%productkey%</ProductKey>

                            </component>

                        </Settings>

                    ………..

                     

                    If someone has an explanation....