0 Replies Latest reply on Mar 5, 2018 2:29 AM by richsouth

    Problem installing and after updates

    richsouth Rookie

      sudo /mnt/sccm/heat_inst.sh

       

      UEA HEAT Install Script VERSION: Heat_8_3039

      -------------------------------------------------------

      This script will install HEAT Client

       

      Current VERSION :

      Upgraded VERSION :   Heat_8_3039

       

      OK to install? (y/N)..y

      Loaded plugins: product-id, rhnplugin, search-disabled-repos, security, subscription-manager

      This system is not registered with RHN Classic or RHN Satellite.

      You can use rhn_register to register.

      RHN Satellite or RHN Classic support will be disabled.

      Setting up Install Process

      rhel-6-server-rpms                                                                                        | 3.5 kB     00:00

      rhel-server-dts-6-rpms                                                                                    | 3.4 kB     00:00

      rhel-server-dts2-6-rpms                                                                                   | 3.2 kB     00:00

      Package bc-1.06.95-1.el6.x86_64 already installed and latest version

      Package 1:java-1.8.0-openjdk-1.8.0.161-3.b14.el6_9.x86_64 already installed and latest version

      Nothing to do

       

      Installing HEAT PatchLink Agent 8.3039

      Copyright (c) 2015 HEAT Software USA Inc.

       

      Performing tests for Silent install...

      Checking Group List

      Silent installation tests successfully completed.

      Expanding archive...

      Exception in thread "main" java.lang.ExceptionInInitializerError

              at com.patchlink.deployment.Register.registerMain(Register.java:108)

              at com.patchlink.deployment.Register.main(Register.java:46)

              at register.main(register.java:7)

      Caused by: java.util.MissingResourceException: Can't find bundle for base name patchagent, locale en_US

              at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1573)

              at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1396)

              at java.util.ResourceBundle.getBundle(ResourceBundle.java:854)

              at com.patchlink.deployment.InstallLib.<clinit>(InstallLib.java:16)

              ... 3 more

      cp: cannot stat `/usr/local/patchagent/update.conf': No such file or directory

      grep: /usr/local/patchagent/update.conf: No such file or directory

       

      ERROR: The HEAT PatchLink Agent files were properly installed to /usr/local but did not register successfully.

      Please check the serial number and hostname for errors.

       

      sed: can't read /usr/local/patchagent/update.conf: No such file or directory

       

       

       

      Also, recently on several boxes, the agent isn't registered as running by the server running a patchagent info returns this:

       

      LAST 15 LINES OF updateagent.log:

       

      ##########################################################

      # UPDATE AGENT STARTED #

      ##########################################################

       

      Exception in thread "main" java.lang.ExceptionInInitializerError

      at com.patchlink.deployment.Configuration.initialize(Configuration.java:125)

      at com.patchlink.deployment.PatchLinkAgent.main(PatchLinkAgent.java:30)

      at gravitixagent.main(gravitix.java:27)

      Caused by: java.util.MissingResourceException: Can't find bundle for base name patchagent, locale en_US

      at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1573)

      at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1396)

      at java.util.ResourceBundle.getBundle(ResourceBundle.java:854)

      at com.patchlink.deployment.InstallLib.<clinit>(InstallLib.java:16)

      ... 3 more

      ___________________________

       

      LAST 15 LINES OF detect.log:

       

      DBG: DELTA XML IS:

       

      <reportresults version="1" status="ok">

      </reportresults>

      DBG: reports pass: 3 checksum: 1921105973

      DBG: reportResultsDeltaSoapRequestString: <soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"> <soap:Body>    <ReportResultsDelta xmlns="http://patchlink.com/webservices/"> <AgentID>E62D4BE9-FA0D-4CA1-95A4-3A3292CE910C</AgentID> <xmlReportResults>

      <reportresults version="1" status="ok">

      </reportresults></xmlReportResults> <checkSum>1921105973</checkSum> <passId>3</passId> </ReportResultsDelta>  </soap:Body></soap:Envelope>

      DBG: plusResponse: <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><ReportResultsDeltaResponse xmlns="http://patchlink.com/webservices/"><ReportResultsDeltaResult>Success</ReportResultsDeltaResult></ReportResultsDeltaResponse></soap:Body></soap:Envelope>

        ___________________________

       

      LAST 5 LINES OF err.log:

       

      Failed to update packages.].  at 20180207054226

      Error: RPM update task failed. STDERR:[No Match for argument: kernel-headers-2.6.32-696.20.1.el6.x86_64

      Failed to update packages.].  at 20180207054233

      Agent started at 20180207060105

      Agent started at 20180221061619

      ___________________________

       

      FILESYSTEM DISK USAGE OF HEAT PatchLink Agent DIRECTORY /usr/local/patchagent

      Filesystem 1K-blocks    Used Available Use% Mounted on

      /dev/sdi1 5028480 1287868   3478520  28% /usr

      ___________________________

       

      DISK USAGE (IN KBYTES) OF HEAT PatchLink Agent DIRECTORY /usr/local/patchagent

      378336 /usr/local/patchagent

      ################################################################

       

      So I assume the problems are the same.  This is stopping critical systems from being updated so is causing problems.

       

      Thanks for any help.

       

      Rich