2 Replies Latest reply on Apr 26, 2018 8:48 AM by Jon Miller

    PXE Rep not Broadcasting - Can't PXE Boot

    Jon Miller Apprentice

      All-

       

      I'm having some issues with PXE. The PXE rep, regardless of what elected client it is, is not broadcasting as a rep. Sometimes the appropriate services are running, sometimes they aren't and I restart them. Very very strange that this all of a sudden started happening in our environment (I'm not aware of any changes we have made). For about 2 months prior to this issue reappearing, PXE booting and imaging worked great.

       

      The first time something like this happened, it resolved itself. When a client would boot and search for reps, it would find a rep but the elected rep would have a randomly generated IP on it's own subnet. This was due to our computers using Cisco Umbrella ODNS as a filtering and traffic monitoring solution. At some point between Cisco updating Umbrella endpoint software and the ivanti core being updated/upgraded to the most current version (2017.3 SU2), the PXE reps started functioning properly.

       

      Some notable information:

      ivanti 2017.3 SU2 running on Server 2016 Standard

      Reps vary from desktop to laptop running Windows 7/Windows 10 version 1703 and 1709

      All Dell Optiplex (7010, 5040, 7050) or Dell Latitude (E5480, E5470, E5450, E5440)

      Verified Firewall ports are open and allowing traffic to the best of my abilities on both clients and network appliances

      Made zero changes to the .wim boot file except update the background

      I noticed the .wim images are not replicating with the updated image (followed the troubleshooting on the community with no avail)

      Tried PXE reps with and without any security (all of our security products as well as none and dropping the firewall)

      *I had no luck whatsoever finding the registry keys to change the score of a PXE rep so it was by happen-chance I was working with the right computers

       

      Attached are all of the logs and information I could possibly think of. All help is welcome! I may end up opening a support ticket but thought I'd post on here first. If I remember any other details, I'll be sure to reply with them. Thanks!

       

      -Jon

        • 1. Re: PXE Rep not Broadcasting - Can't PXE Boot
          Kayla.Culpepper SupportEmployee

          Hello Jon!

           

          Thanks for posting to the Ivanti Community.

          Sorry that it seems no one has the answer to be able to assist you on this yet.  Did you manage to get any further information on this? Please share anything you deem useful and the community may be able to offer some help.

          If not then please do consider the other ways to engage with us to get assistance:

          https://community.ivanti.com/community/contact-support

           

           

          Kayla Culpepper
          Customer Service Coordinator
          Ivanti

          • 2. Re: PXE Rep not Broadcasting - Can't PXE Boot
            Jon Miller Apprentice

            Kayla,

            Unfortunately, I have not made any progress. I'm fairly certain it is Cisco's Umbrella DNS filtering solution that is causing the issue. I haven't had much time to open a ticket with Cisco on it yet. I did at one point have a ticket open with LANDesk but don't recall off the top of my head what the outcome was- I think it started randomly working again haha. My current work around is a bootable USB drive with the ISO I made from the core. It bypasses the PXE boot process obviously but still gets provisioning rolling for me.

             

            Thanks for the follow-up! I will post more as I make progress!

             

            -Jon