1 Reply Latest reply on Jun 15, 2009 7:31 PM by zman

    failed to install package with Symantec Endpoint Protection

    Rookie

      So I recently built an MSI package for Symantec Endpoint Protection and we pushed it to 30 + machines successfully last week.  Today all of a sudden the package started generating "Failed to install package" errors in the result column even though the package installs successfully on the client.

       

      The Log file within Landesk contains the following:

       

      ---------------------------------------------

      Stating Action : Action 18:01:45: RemoveSettingsMigrationFiles_Com.03FE01CF_295E_4354_A292_7DC4A810E0DA.

      Stating Action : Action 18:01:45: ForceFreeUnusedCOMLibraries_User.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: UpdateEncCCVer_Rol.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: UpdateEncCCVer.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: UpdateEncCCVer_Com.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: StoreNoCcLU_Rol.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: StoreNoCcLU.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: ForceFreeUnusedCOMLibraries_System.18376EA1_A7B1_41ED_A75C_CD6FAB0434AA.

      Stating Action : Action 18:01:45: SetLiveUpdateSettings.FF07F38E_78C2_412E_B858_64488E808644. Configuring LiveUpdate

      Stating Action : Action 18:01:46: StartServices_CM.FF07F38E_78C2_412E_B858_64488E808644.

      Stating Action : Action 18:01:46: CLEANUPTEMPDIRS.B754A361_3344_430B_92FF_8F9A227A6B90. Cleaning up temporary files

      Stating Action : Action 18:01:46: LaunchCCAppasUser.93C43188_D2F5_461E_B42B_C3A2A318345C. Starting CCApp application

      Stating Action : Action 18:01:47: icDeleteBackupRegkey.9DDC0E81_9620_4441_B4F7_FD077F55D6D2.

      Stating Action : Action 18:01:47: irbExtBackupDatFiles.9DDC0E81_9620_4441_B4F7_FD077F55D6D2.

      Stating Action : Action 18:01:47: iExtDeleteBackupDatFiles.9DDC0E81_9620_4441_B4F7_FD077F55D6D2.

      Stating Action : Action 18:01:47: icUnMarkFilesFromDeletion.9DDC0E81_9620_4441_B4F7_FD077F55D6D2.

      Stating Action : Action 18:01:47: RollbackCleanup. Removing backup files

      Stating Action : Action 18:02:29: . sdi.dat

      Stating Action : Action 18:02:29: . serdef.dat

      Stating Action : Action 18:02:29: . SyLink.xml

      Stating Action : Action 18:02:29: . LUCHECK.EXE

      Stating Action : Action 18:02:29: . LUSETUP.EXE

      Stating Action : Action 18:02:29: . vdefhub.zip

      Stating Action : Action 18:02:29: . IPSDef.zip

      Stating Action : Action 18:02:29: scheduleBBReboot.0723A1DC_DEB6_4A50_874F_3A2D2C99A1C1.

      Stating Action : Action 18:02:30: DisableCancelButton_IF.

      Stating Action : Action 18:02:30: SetRebootMessageJustInternetEmailNeededArgument.

      Failed to install the MSI package.

      Installing MSI package (-302 seconds)

      Installation of the MSI package failed


      Mon, 15 Jun 2009 18:02:30 MSI result 8DAC4002
      Mon, 15 Jun 2009 18:02:30 processing of package is complete, result -1918091262 (0x8dac4002 - code 16386)

       

      ----------------

      The symantec antivirus.log file found in C:\Program Files\LANDesk\LDClient did not contain visible errors.  Here is the last part of that log:

       

      --------

      Property(S): MSIAddWFPAppException.17E5C180_F281_4425_9348_3E891E7F8D1F = SMC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\Smc.exe;SNAC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\SNAC.EXE;Symantec Email;C:\Program Files\Common Files\Symantec Shared\ccApp.exe;
      Property(S): MSIAddWFPAppException_RB.17E5C180_F281_4425_9348_3E891E7F8D1F = SMC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\Smc.exe;SNAC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\SNAC.EXE;Symantec Email;C:\Program Files\Common Files\Symantec Shared\ccApp.exe;
      Property(S): MSIRemoveWFPAppException.17E5C180_F281_4425_9348_3E891E7F8D1F = SMC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\Smc.exe;SNAC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\SNAC.EXE;Symantec Email;C:\Program Files\Common Files\Symantec Shared\ccApp.exe;
      Property(S): MSIRemoveWFPAppException_RB.17E5C180_F281_4425_9348_3E891E7F8D1F = SMC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\Smc.exe;SNAC Service;C:\Program Files\Symantec\Symantec Endpoint Protection\SNAC.EXE;Symantec Email;C:\Program Files\Common Files\Symantec Shared\ccApp.exe;
      Property(S): CRLF =

      Property(S): MsiRebootActionScheduled = 3
      Property(S): RestartServices.B20121BB_4581_4D1A_9151_0BAA265253EF = Wlansvc,EapHost
      Property(S): ProductToBeRegistered = 1
      Property(S): MsiFilterRebootMode_RebootAtEndModeBefore = 1
      MSI (s) (5C:F0) [18:02:30:698]: Product: Symantec Endpoint Protection -- Installation operation completed successfully.

      MSI (s) (5C:F0) [18:02:30:698]: Windows Installer installed the product. Product Name: Symantec Endpoint Protection. Product Version: 11.0.4014.26. Product Language: 1033. Installation success or error status: 0.

      MSI (s) (5C:F0) [18:02:30:698]: Windows Installer requires a system restart. Product Name: Symantec Endpoint Protection. Product Version: 11.0.4014.26. Product Language: 1033. Type of System Restart: 2. Reason for Restart: 4.

      MSI (s) (5C:F0) [18:02:30:698]: Product: Symantec Endpoint Protection. Restart required. The installation or update for the product required a restart for all changes to take effect.  The restart was deferred to a later time.

      === Logging stopped: 6/15/2009  18:02:30 ===

       

      -------

       

      The package was created through SEP Console and points to the MSI file with the the rest of the files added as additional files.  I have the following added to the command line:

       

      ENABLEAUTOPROTECT=1 RUNLIVEUPDATE=1 REBOOT=ReallySuppress

       

      ---

       

      On the client everything installs the way it should and SEP report to the console without issues.  The only issue is it's now displaying a "failed to install package" error.  Everything was working perfect up until today. Not sure what the heck happend.