1 Reply Latest reply on May 29, 2018 4:52 PM by karlehenry

    PXE Client not downloading NBP File

    karlehenry Apprentice

      I am working on setting up and testing PXE Boot via Self-electing subnet services.  I have configured the core with the options and enabled my test machine as the PXE Representative.  I verified the LANDESK PXE Service is running and the LANDESK MTFTP Service is running on the machine.

       

      when the client boots, it gets to downloading NBP file......  and then boots the OS but not the PE environment nor do i see the custom message I set on the core.

       

      When I looked at the Logs found in

       

      c:\programdata\landesk\log\pxesvc.log

       

      I see the message "Unable to write the Disable Netboot value.  Will attempt to service this Netboot request. This is a Non-Secure PXE Rrepresentative."

       

      Both client and PXE rep are on the same subnet.

        • 1. Re: PXE Client not downloading NBP File
          karlehenry Apprentice

          Just wanted to share, I finally solved this and found two problems on our end.

           

          It turns out that we needed to open port 69 for the pxe service on the PXE Rep machine so that a connection can be made.  Once this was done, Everything started working like a charm. 

           

          For troubleshooting I am providing the command for windows 10:

           

           

          netsh advfirewall firewall add rule name="IvantiPXEBoot" protocol=UDP dir=in localport=69 action=allow

           

          For the "Rule Name", you can make it anything you want, but I named it as such so anyone who reviews can understand why this was enabled.

           

          There are other ports that may need to be opened up as well:

           

          UDP port 67 and possibly port 4011.  However, only enabling port 69 on the PXE REP opened up TFTP Communications.

          1 of 1 people found this helpful