1 Reply Latest reply on May 29, 2018 8:12 AM by GreggSmith

    Xtraction. Filter with russian letters does not work.

    SmartServiceDesk Rookie

      Hi

       

      When i add a filter that contains russian letters, dashboard does not give results.

      But without this filter the dashboard works fine and outputs all results.

      The dashboard will also give the results of adding a filter containing the English letters, including those records that contain half-russian and half-english text.

        • 1. Re: Xtraction. Filter with russian letters does not work.
          GreggSmith SupportEmployee

          What data model are you using?

           

          Most likely, the problem is the database field you are filtering against supports Unicode (NVARCHAR, most likely), but the data model field does not have the Unicode checkbox selected.  Therefore, the filter on the string literal does not correctly place the "N" in front of the string, indicating that it contains the extended character set.

           

          To confirm the fix for your situation, find the specific field you are filtering against in the data model and check the Unicode checkbox.  Save the file, reload the data model from the web administration menu, restart your browser instance, and try the filter again.  Assuming it works, you should consider updating the Unicode checkbox for any string fields that have the Filter checkbox checked.  Those should be the only field mappings affected by the Unicode option.

          1 of 1 people found this helpful