13 Replies Latest reply on Jun 30, 2009 1:18 PM by sav2880

    LanDesk PXE Service Crashing




      I'm running into an interesting problem. On a computer that I have installed a PXE representative on, the LanDesk PXE Service seems to crash nearly the exact moment that I start it The error I get is this:


      Event Type:    Error
      Event Source:    PxeServices
      Event Category:    None
      Event ID:    2
      Date:        6/25/2009
      Time:        9:09:31 AM
      User:        N/A
      Computer:    KNYCPXE001
      The description for Event ID ( 2 ) in Source ( PxeServices ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Unable to query master PXE proxyDHCP for multicast Address Allocation parameters

      The host machine is running Windows XP SP3 with all recent Windows Updates. It was originally a client workstation but has had the software scrubbed from the machine, it's down now to just Windows and the PXE boot program.


      What might be causing an issue like this, and has anyone seen it before?

        • 1. Re: LanDesk PXE Service Crashing

          The PXE Rep is not tested or supported without the LANDesk agent.  If you reinstall the agent, does the PXE Rep function smoothly?

          • 2. Re: LanDesk PXE Service Crashing

            The agent software is indeed installed on the workstation, most recent version. Just to be safe, I am doing a re-install of the agent software now. That didn't help. I did also notice that the machine is in a group policy area to give it workstation rights in our environment (which turns off Windows Firewall and Automatic Update). Just to be safe, I'm taking this out and putting the computer into a Server OU (which is less restrictive), much like our working PXE boot server at another office is in.


            Any other things to look at?

            • 3. Re: LanDesk PXE Service Crashing

              OK, I'm glad to hear the agent software is actually running.  I misread your post and thought you were trying to run a PXE Rep as an unmanaged node.


              The GPO is a great thing to check.  I'll do some additional digging about the error you are seeing, but let me know the results of moving it out of the GPO.

              • 4. Re: LanDesk PXE Service Crashing

                Moving out to the server OU, and thus the less restrictive group policy did not help unfortunately. I don't know if these tidbits on timing would help., but ...


                * It always crashes within 30 seconds of service start (I would assume the same for system start as well)

                * It is not consistent in how much time before crashing

                * The machine in question is in our New York office on a differnet subnet (10.30.0.x) than our Core server (10.200.200.x) ... this has not proven to be an issue for another PXE boot server in another office, also on a different subnet, so I don't think this is playing a role.

                • 5. Re: LanDesk PXE Service Crashing
                  ahe Expert

                  Hello Scott,


                  did you reinstall the PXE Server with the LANDesk script (PXE Representative Deployment)?


                  Did you try to run the file osdrep.msi manually or in this way Modified PXE Representative Deployment script with local copy of osdrep.msi. ?


                  Can you start the PXE config tool? "C:\Program Files\LANDesk\PXE\System\PxeConfig.exe"





                  LANDesk pached something in the original intel MSI for their own. So before WinPE arrived in 8.7 SPx we use not the LANDesk PXE Server, we use the original by intel and configured it by ourself. And we use Linux to install XP clients... (s http://unattended.sourceforge.net/index.php), so no LANDesk core server or installed agent were necessary...

                  (Cause for Linux: DOS method was too slow, can't use DNS aliases, unflexible, too less memory for newer network cards and SCSI devices, etc.)




                  • 6. Re: LanDesk PXE Service Crashing

                    ahe: I did install using the PXE Representative Deployment script. I have not tried to use the modified deployment script just yet, but I am definitely willing to try it out.


                    I am able to run the PXEConfig.exe file, but when I attempt to Start/Stop services from there, it shows the state of the service as <unknown>, so this config app is definitely NOT communicating with the service properly. As a gut reaction, what might that indicate?

                    • 7. Re: LanDesk PXE Service Crashing
                      ahe Expert

                      Hello Scott,


                      no idea 'til now, I found some hints about reinstallation PXE which solves a lot of problems (did it in our environment too).


                      Are you sure you've only one PXE in your subnet?


                      It seems some additional TFTP serves could make trouble too: http://community.landesk.com/support/message/19197#19197




                      • 8. Re: LanDesk PXE Service Crashing
                        Jared Barneck SupportEmployee

                        Did you ever try changing the MTU size?  Often it is set to 1350 by some apps and should be set to 1500.

                        • 9. Re: LanDesk PXE Service Crashing

                          I think I might be on to something. When I run the PXE Deployment Removal, it does not remove the services, nor the program for that matter. If you try and do an uninstall of osdrep.msi by hand, it denies it saying it can only be done for installed products.


                          So, it's as if the PXE install is in this limbo area, and the "not functioning" services and unfinished uninstall are causing all the issue. How can I get rid of this half-uninstalled app so I can do a proper reinstall?

                          • 10. Re: LanDesk PXE Service Crashing

                            A couple of things can be done:


                            1 - Run MSI Cleanup Utility (formerly MSIZap) from Microsoft to get rid of the PXE Rep install information from the Windows Registry.


                            MSI Cleanup Utility can be found here (a little down the page): http://support.microsoft.com/kb/290301  The direct link is here: http://download.microsoft.com/download/e/9/d/e9d80355-7ab4-45b8-80e8-983a48d5e1bd/msicuu2.exe


                            2 - I recently ran across a scenario where a guy had copied some scripts from his 8.7 core to his 8.8 core during an upgrade.  He ran into a problem that the scripts are not the same, and it was causing the install to fail.  Can you post the contents of your deployment script?



                            1 of 1 people found this helpful
                            • 11. Re: LanDesk PXE Service Crashing

                              I get the same error message and the same results.

                              One minute I can image 14 devices at once and then I try and manually image a device and the PXE rep can't be found.  I try and image a managed device through a scheduled task and it fails because it can't find the PXE rep.  I have to reboot the core server in order for the PXE rep to be working.


                              This looks to be a common problem.


                              8.8 SP3

                              Windows 2003 Server

                              • 12. Re: LanDesk PXE Service Crashing
                                ahe Expert

                                Hello Scott,


                                Try the following uninstall string:


                                MsiExec.exe /X{F238CE99-6614-4072-9D20-1D2FA7ED951A}


                                If you should find some relicts after successful uninstallation:

                                • delete the registry entries below HKLM\Software\Intel\PXE and HKLM\Software\LANDesk\Provisioning
                                • delete all files/dirs below "C:\Program Files\LANDesk\PXE"


                                Reinstall PXE again, but try to start the MSI locally not from Core server...s. Modified PXE Representative Deployment script with local copy of osdrep.msi.




                                • 13. Re: LanDesk PXE Service Crashing

                                  Running the reinstall turned out to be the answer for me, since Windows Installer did not even recognize the presence of a program installed. So, you had these phantom services out there, which had no guidance as to how to work, and that's why they kept crashing.


                                  Reinstalled direct from the MSI locally, and it worked like a champ.