6 Replies Latest reply on Jul 10, 2018 5:29 AM by M.Dheini

    Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!

    M.Dheini Rookie

      Hallo zusammen,

       

      ich soll bei einem Kunden einen neuen Server (2016) installieren und den alten (2012) ablösen.

       

      Im Einsatz ist DSM 2017. Folgende Struktur ist beim Kunden vorhanden:

       

      ORG

      - ASIA

      - EMEA

      --> CH

      --> DE

      >>>>> Illertissen

      ======== 1x Depot

      ======== 1x Management Point

      >>>>> Osnabrück

      ======== 1x Depot

      ======== 1x Management Point

      --> IT

      - VPN

      - ZZ

      master

      1x Management Point (Old, ist bereits inaktiv)

      1x Management Point (MAIN)

       

       

      Pro Site ist ein eigener Managementpoint und ein eigener Depot konfiguriert.

      Sowohl der Managementpoint als auch das Depot liegen auf dem gleichen Server.

       

      Meine Arbeiten:

      Nun habe ich den neuen Server eingerichtet und in Osnabrück einen weiteren Managementpoint installiert, den alten auf Inaktiv gestellt + den neuen Activ gestellt + den alten Server komplett heruntergefahren und das Depot über /AllowSvrMove umbenannt. In den Siteeinstellungen habe ich den neuen Managementpoint als zuständiger Distributionsdienst eingestellt. Auf dem Managementpoint ist der Transport Layer, Event Dispatcher, Service Installation Service und der Distribution Service installiert.

       

      Ebenfalls habe ich geprüft ob die NCPs aktualisiert wurden. Die Server und die Clients haben die aktuellen NCPs erhalten.

       

      Nun zum Problem:

      Ein Client in Osnabrück fängt an zu Syncen (durch Polling etc.).

      Dem LogFile (z.B. NISRV32 oder NIAI) konnte ich entnehmen, dass er den alten Managementpoint als zuständigen Managementpoint erhalten hat.

      Dennoch erfolgen die Installationen in der Site Osnabrück erfolgreich und die Daten zieht er sich vom richtem neuem Depot.

       

      Das hat mich stuzig gemacht. Also habe ich mir die PerformSync.log mal angesehen und folgendes festgestellt:

       

      ...

      ...

      09:12.40.874  1 FtlClient.dll  Selecting management point of type 'BLP' (Destination = 65535, Flags = 0xb)...
      09:12.40.874  0 FtlClient.dllCreating Search Path from 66079 to 65535.
      09:12.40.874  0 FtlClient.dllSearchPath: 66079,65952,65951,65535
      09:12.40.874  0 FtlClient.dllSearching for management point at 66079 (1 Management Points).<-- Jetzt sucht er in Osnabrück! Neuen Managementpoint der Site Osnabrück erkannt!
      09:12.40.874  0 FtlClient.dllManagement point 66081 has rating 0.<-- Das ist der richtige neue Managementpoint für Osnabrück! Managementpoint wird aber nicht angesprochen. Was ist das "Rating = 0" ???
      09:12.40.874  0 FtlClient.dllSearching for management point at 65952 (0 Management Points).<-- Jetzt sucht er in DE
      09:12.40.874  0 FtlClient.dllSearching for management point at 65951 (0 Management Points).<-- Jetzt sucht er in EMEA
      09:12.40.874  0 FtlClient.dllSearching for management point at 65535 (2 Management Points).<-- Jetzt sucht er in ORG = 2 Managementpoints gefunden, den alten und den neuen!
      09:12.40.874  0 FtlClient.dllManagement point 65950 has rating 0.<-- Das ist der alte Managementpoint der bereits inaktiv ist (Loadbalance 0 + Managementpoint auf deaktiviert gestellt, Server physisch noch an. Er überspringt ihn, da ist ok.
      09:12.40.874  0 FtlClient.dllManagement point 66209 has rating 5.<-- Das ist der neue Managementpoint (MAIN, Aktiv und Loadbalance 100). Dieser Managementpoint wird genutzt! Was ist das "Rating = 5" ???
      09:12.40.874  0 FtlClient.dllFound 1 management points with a total load balancing factor of 100<-- Neuer Managementpiont (MAIN) wird genutzt!
      09:12.40.874  1 FtlClient.dll  Found valid management point 66209.<-- Neuer Managementpiont (MAIN) wird genutzt!

      ...

      ...

       

      Ich dachte ich habe irgendetwas falsch gemacht, also habe ich mal auf einer anderen, bereits bestehenden Site Illertissen, welche nicht durch mich eingerichtet wurde, das gleiche überprüft. Der Sachverhalt ist exakt der gleiche!

       

      Bedeutet: Die Struktur an sich funktioniert beim Kunden garnicht erst!!

       

      Frage:

      - Was muss ich einrichten/einstellen, damit der Managementpoint pro Site funktioniert und von den Clients aus der Site auch genutzt wird?

      - Was ist das Rating und wie kann ich das einstellen?

      - Kann ein Managementpoint pro Site nur genutzt werden, wenn dort auch ein RelayProxy konfiguiert ist?

       

      Ich hoffe ich konnte das Problem deutlich schildern und bitte um konstruktive Beiträge.

       

      Viele Grüße,

      Moha

        • 1. Re: Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!
          _Mel_ Master

          das rating gibt an ob auf dem management point das vorhanden ist was der client sucht.

           

          da der sync immer zu einem BLS geht, sucht der client einen BLS oder einen relayproxy und da laut deiner beschreibung kein relayproxy installiert ist, ist das rating 0 also sucht er weiter

          das ist auch kein problem, solange der client direkt mit dem BLS kommunizieren kann. der relayproxy reicht die clientanfragen ja nur an den bls durch, damit man z.B. auch durch firewalls oder nats kommunizieren kann

          • 2. Re: Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!
            M.Dheini Rookie

            Hallo _Mel_,

             

            vielen Dank für die Antwort.

             

            Aktuell funktioniert es ja trotzdem, weil die Clients direkt mit dem BLS kommunizieren können. Wenn nicht, müsste da also zwingend ein RelayProxy hin, dass habe ich verstanden.

             

            Bedeutet es also, dass ein Managementpoint in einer Site immer nur dann Sinn macht und genutzt werden kann, wenn auch ein RelayProxy in der Site verfügbar ist?

            Aktuell wird nämlich darüber diskutiert, ob der Managementpoint pro Site gelöscht werden soll oder ob er bleiben soll da er dennoch irgendwie genutzt wird (bleiben soll er nur dann, wenn trotz der aktuellen konfiguration und dem direkten Kontakt der Clients mit dem BLS der ManagementPoint pro Site genutzt wird/Sinn macht).

             

            Welche Informationen laufen über dem ManagementPoint? Dient er nur dazu, die Anfragen der Clients zu bündeln um diese dann an den BLS/RelayProxy weiterzuleiten?

             

            Viele Grüße

            Moha

            • 3. Re: Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!
              sbr2 Expert

              Ein Managementpoint kann ja die verschiedensten Komponenten beinhalten.

               

              In deinem Beispiel ist ein MP angebracht damit dort auch der Distributionsdienst installiert ist.

              Für OSD ist es auch zum empfehlen im gleichen Netzbereich einen MP zu haben.

               

              Viele Grüße,

              Stefan

              • 4. Re: Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!
                M.Dheini Rookie

                Hi sbr2,

                 

                vielen Dank für die Rückmeldung.

                 

                In dem Fall macht es Sinn den Managementpoint für die jeweilige Site bestehen zu lassen, den Managementpoint aber auf die ORG Ebene zu verschieben?

                Dann müsste doch auf der Site entsprechend der dazugehörige Managementpoint als zuständiger Distributionsdienst konfigurierbar sein und der Managementpoint müsste die Kommunikation zum BLS haben, da er auf der gleichen Ebene ist, nicht?

                Ich hoffe ich habe das nicht falsch verstanden.

                 

                Viele Grüße,

                Moha.

                • 5. Re: Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!
                  _Mel_ Master

                  oft ist es sinnvoll in der infrastruktur die pysikalische struktur abzubilden. d.h. wenn z.B. eine site ein bestimmter standort ist und an diesem standort ein management point steht, dann ist es wahrscheinlich sinnvoll, daß dieser management point auch in der infrastruktur in dieser site eingetragen ist.

                   

                  wenn man das nicht macht, dann bekommt man u.U. probleme bei der kommunikation wenn nicht alle rechner untereinander kommunizieren können

                  • 6. Re: Clients in einer Site nutzen nicht den Managementpoint in der gleichen Site!!
                    M.Dheini Rookie

                    Hallo _Mel_ ,

                     

                    vielen Dank für die Unterstützung.

                     

                    Die Physikalische Struktur ist bereits implementiert, lediglich hatte kein Standort einen RelayProxy.

                     

                    Ich habe nun einen RelayProxy bei ein paar Standorten mit schwacher Anbindung konfiguriert und siehe da, es läuft (Testumgebung).

                    Beim Kunden jedoch Bedarf es keinem RelayProxy, da haben die Clients die Verbindung zum BLS und das soll auch so erst mal bleiben.

                     

                    Vielen Dank nochmal.

                     

                    Grüße Moha.