8 Replies Latest reply on Jul 13, 2018 5:57 AM by JohannesFM

    Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329

    JohannesFM Apprentice

      Hallo zusammen,

       

      Ich habe immer noch mit diversen Problemen bei meinem 1709 upgrade zu kämpfen. Einerseits besteht bei mir das Problem mit der Sprachauswahl während der Installation. Hier habe ich nur die Möglichkeit Die Ausgangsprache auszuwählen. Die Sprachpaket sind aber in meinem OS Paket vorhanden. Während der Installation stimmt die Sprache noch und In meiner unattend.xml sollte eigentlich auch alles stimmen. Zumindest trägt er hier die richtige Sprache ein. In meinen Fall geschieht das über die Variable: %CurrentComputer.Var.EnvironmentVariables.ClientLanguage%. Zwar könnte ich jetzt die Sprache nachträglich über die Registry ändern. Finde das aber jetzt nicht so komfortable weil das wieder ein zusätzliches Paket bedeuten würde.

       

      Mein zweites Problem ist das Inplace upgrade mit angepasster install.wim. Hier bekomme ich als Return -2145124329. Die Orginal wim funktioniert komischerweise ohne Probleme. Auch hier könnte man jetzt das ganze customizing nachträglich machen. Finde ich allerdings nicht so toll. Google konnte mir hier leider auch nicht weiterhelfen. Aber vielleicht weis jemand von euch woran es liegen könnte. Ebenso besteht hier das selbe Probleme mit dem MUI.

      Danke im vorraus

       

      MFG

      Johannes

        • 1. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
          Nico Schmidtbauer Apprentice

          Hallo Johannes,

           

          Bzgl. dem 2. Thema:

          in dem Kontext wäre es hilfreich zu wissen wie du die unattend.xml angepasst hast. Ich kann hatte z.B. bei den ersten Windows 10 Versionen ein Problem mit der Sprache und dem Feature Upgrade. Ausgangssituation war ein Englisches Windows 10 + Deutschem Language Pack und per Powershell (set-winsyslocale) auf Deutsch umgestellt. Das Feature Upgrade (wieder Engl. Basis mit DE MUI) schlug dann genau wegen dieser Einstellung fehl. Ein Upgrade mit nativ-Deutscher Installationssource hat geklappt. Lösung für mich war dann, die winsyslocale wieder auf en-US zu stellen => Reboot => Funktioniert.

           

          Gruß

          Nico

          • 2. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
            JohannesFM Apprentice

            Also meine unattend sieht so aus:

             

              <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="%OSD.TargetArchitecture%" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

                  <SetupUILanguage>

                    <UILanguage>%CurrentComputer.Var.EnvironmentVariables.ClientLanguage%</UILanguage>

                  </SetupUILanguage>

                  <InputLocale>%CurrentComputer.Var.EnvironmentVariables.ClientLanguage%</InputLocale>

                  <SystemLocale>%CurrentComputer.Var.EnvironmentVariables.ClientLanguage%</SystemLocale>

                  <UILanguage>%CurrentComputer.Var.EnvironmentVariables.ClientLanguage%</UILanguage>

                  <UserLocale>%CurrentComputer.Var.EnvironmentVariables.ClientLanguage%</UserLocale>

                </component>

             

             

            SystemLocale ist in meinem Fall de-DE. und das entspricht auch der Ausgangssprache. Er ändert diese ja auch dementsprechend. blos das bringt nicht viel weil die default system UI language immer noch de-DE ist (Ich spreche jetzt grad von einer Neuinstallation, nicht dem Inplace upgrade)

            Bei dem inplace-upgrade ist es dasselbe. Hier ist ausgangssprache Deutsch. Syslocale Deutsch und system UI auch Deutsch. eigtlich genauso wie bei dem Orginalfile. trotzdem krieg ich hier die oben genannte Rückmeldung

            • 3. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
              Nico Schmidtbauer Apprentice

              Sorry, war noch nicht ganz wach. Meine Frage sollte eigentlich lauten: [...]wie du die Install.wim angepasst hast.[...]

              • 4. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
                JohannesFM Apprentice

                Also das ist schon etwas umfangreich. Ein Großteil hat mein vorgänger gemacht und mir in einer vielzahl von ps scripts hinterlassen. So im groben und ganzen werden LPs, fontpacks, dotnets, wupdates installiert, appx packages werden entfernen, installieren von vcredist2005 - 2017, vielzahl von cleanups wie onedrive entfernen, profile säubern, registry cleanups , unser  Themepaket natürlich... und noch einiges mehr xD, ....anschließend sysprep und capture mit GimageX.

                • 5. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
                  Nico Schmidtbauer Apprentice

                  Bingo, und genau das ist dein Problem.

                  Das Feature Upgrade funktioniert NICHT mit Images die Installiert und dann wieder mit Sysprep behandelt worden sind.

                   

                  Du hast, meines wissens nach, nur die Chance indem du die original install.wim nimmst, diese per DISM Mountest und dann modifiziert.

                  Dort kannst du auch LPs, Features on Demand (inkl. .net) und Windows Updates einspielen und APPX Pakete entfernen. Auch am Fileset die eine oder andere Modifikation vornehmen. Aber nicht alles was du beschreibst.

                   

                  Von markus.zierer gab es hier ein schönes Batch Script mal im Forum. Leider finde ich es auf die schnelle nicht.

                  • 6. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
                    JohannesFM Apprentice

                    das macht natürlich schonmal Sinn. Ich schau mal vielleicht find ich ja das batch script. würde mich schonmal interessieren. ansonsten müsste ich halt einiges über ein zusätzliches paket ausführen. trotzdem schonmal Vielen Dank!

                    • 7. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
                      derniwi Master

                      Hallo Johannes,

                       

                      welche DSM-Version verwendet Ihr?

                      Wie ist die angeaßte install.wim für das Inplace-Upgrade erstellt worden?

                       

                      Ich habe bisher einige Tests mit der Instalaltion von Windows 10 (verschiedene Versionen von 1607 bis 1803) durchgeführt und auch hier das reine Inplace-Upgrade getestet. Das lief mit DSM 2018.1 eigentlich immer gut.

                       

                      Mit angepaßten Wims hatte ich das Problem mit der Sprache ebenfalls. Auch wenn ich später die Sprache auf Deutsch umstellen wollte, war die Sprache nicht dierkt verfügbar - aber es sieht so aus, als ob sie auch nicht nachgeladen werden musste. Eine schöne Lösung für dieses Problem habe ich noch nicht gefunden.

                       

                      Gruß

                      Nils

                       

                      Edit: Ups. das waren andere schneller, hatte zwar fürh mit der Antwort angefangen, musste dann aber unterbrechen.

                       

                      Und ja, eine abgezogen Installation kann man nicht für Inplace verwenden. Allerdings sollte man auch überlegen, welche Änderungen man direkt an der install.wim macht, und was man vielleicht geschickterweise über DSM-Pakete vornimmt.

                      • 8. Re: Win10 1709 MUI funktioniert nicht + Inplace upgrade -2145124329
                        JohannesFM Apprentice

                        Hat alles geklappt. Danke! Zu Punkt 1. Da hat einfach die entsprechende Einstellung in der Lang.ini gefehlt.