2 Replies Latest reply on Jul 24, 2018 12:26 PM by CParke

    Service Manager user portal slow load times, delayed metadata updates

    CParke Rookie

      We're having some performance issues with our production Service Manager environment which are only present when users are logged in via the user portal. I do not experience these issues when I am logged in via the admin portal as the same user, even when assigned the same role. What's happening is the system often takes an excessively long time to load a page at log on and after a record is updated and saved, like 20 seconds or so. This does not happen with the admin portal. We have a UI server which is separate from our production application server, so I'm not sure if it could be a misconfiguration or performance problem with the two communicating, but there are no other noticeable issues.

       

      The other issue is when I make metadata changes to a form in production, the changes are not immediately reflected for users logged in via the user portal, but they are reflected if the same user logs in via the admin portal. I made some changes last Friday and the form updates were not reflected in the user portal until some time later, not exactly sure how long because I had left for the day and the updates still were not being reflected. I checked this morning and now the forms reflect the updates.

       

      Anybody have an idea what could cause these types of issues when using a separate UI server?

        • 1. Re: Service Manager user portal slow load times, delayed metadata updates
          joyce.bitzer SupportEmployee

          Hi CParke,

           

          I think I was just able to assist you on this with an Support Case.

           

          If I'm wrong and/or for the benefit of others reviewing this thread, I was able to resolve this issue by configuring Service Manager to sync the application cache on port 443 instead of port 80. Instructions to configure this can be found in this KB:

          HowTo: SSL configuration - Configure the App and Web servers to sync cache on port 443 (SSL) instead of port 80

           

          A telltale sign of this issue will be cache sync warnings/errors in the Event Viewer on the App and/or Web servers, as well as the inability to browse to http://<AppServer> from the Web Server, and/or the inability to browse to http://<WebServer> from the App Server.

           

          If I'm not correct, and you still need assistance, please log a Support Case so we can assist with this issue.

           

          Thanks!

          1 of 1 people found this helpful
          • 2. Re: Service Manager user portal slow load times, delayed metadata updates
            CParke Rookie

            Configuring the sync cache to use port 443 did work to resolve the caching issue. We are using SSL for all server-to-server and client-to-server connections.

             

            Regarding the other issue with slow load times, as you stated in your phone call, it seems it was due to the default IIS application timeout configuration. There are multiple ways to work around that issue, but what I'm trying first is I installed an additional feature of IIS called Application Initialization, then set the Start Mode setting for the HEATAppServerAppPool to AlwaysRunning, and enabled the Preload setting for the HEAT website. It still takes a few seconds for the initial load after a period of time, but it should work for us, and it's far better than running a continuous "keep alive" script against the website. We will fine tune if needed, but these configurations have resolved our issues.