7 Replies Latest reply on Jul 15, 2009 9:15 AM by Kothoga

    Gateway not connecting to remote agents

    Rookie

      I am trying to get the gateway appliance functioning.  Everything works except when I try to connect to a remote system it doesn't connect.  I see the system in the list of remotes but the connection times out trying to connect.  I'm using integrated security.  The remote agent is set up to install with the agent.  What can I try to resolve this?

       

      Thanks,

       

      Joy

        • 1. Re: Gateway not connecting to remote agents
          sriley SupportEmployee

          Joy,

          Try the following:

          1. Stop the LANDesk Remote Control service on the machine you are trying to remote control.

          2. Open the registry on that same machine and browse to HKLM\Software\Intel\LANDesk\WUSER32 and change the security type from 9 to 0.

          3. Now try to remote control the machine.

           

          SRR

          • 2. Re: Gateway not connecting to remote agents
            sriley SupportEmployee

            If that works, remember to set the security type back to 9.  There will be a patch coming out shortly that will do this automatically.

             

            One other thing to try is to make sure the Remote control is set to gateway mode. If you see the Remote Control system try icon right click on it and click on Status. Then click on Switch Mode so it says gateway mode.

            • 3. Re: Gateway not connecting to remote agents
              Apprentice

              Also remember that choosing Remote Control in the console window is not the same as choosing Management Gateway Remote Control. Both sides have to match up.

              • 4. Re: Gateway not connecting to remote agents
                Rookie

                The security type is set to 2?

                • 5. Re: Gateway not connecting to remote agents
                  Rookie

                  I am familiar with the different access.  The remote control works perfectly.

                  • 6. Re: Gateway not connecting to remote agents
                    sriley SupportEmployee

                    Joy,

                    1. You will need to use an account with that is in the LANDesk Management Suite group. This user has to have RC rights.

                    2. When you set a machine to gateway mode that i talked about, this is for when you want to right click on a machine fromt he console and do a Management Gateway Remote Control.

                    3. If you are just having users download the remote control agent from your gateway then you have to have them stop the remote control service and set the registry key to 0 like we talked about in this article. This is what will be patched later on that will do that automatically for you.

                     

                    Hope this helps!

                     

                    SRR

                    • 7. Re: Gateway not connecting to remote agents
                      Master

                      Hi Joy,

                       

                      Ok, So we already fixed this but lets cover what we went through to fix the problem.

                       

                      Move the "core" folder from:

                      C:\Program Files\LANDesk\Management Suite\

                      to -

                      C:\Program Files\LANDesk\Management Suite\landesk\managementsuite\

                       

                      Then run "iisreset" from the run menu to restart IIS services.

                       

                      It looks like the "core" folder had been moved and IIS could no longer browse to it since it was in the wrong location.  The Core location also controls SSL communications for the Remote Control.  That SSL communication is key for both Certificate based and Integrated Security modes of remote Control.

                       

                      After getting IIS repaired and restarted, We were able to do all forms of Remote Control, both direct mode, integrated security in the Network, and integrated security through the Gateway.

                       

                      Thanks for the fun.

                       

                      Sincerely,

                      Kothoga