4 Replies Latest reply on Nov 21, 2018 4:15 AM by AKuhl

    Using Multiple Currencies

    maba Apprentice

      Hi all,

       

      Has anyone successfully worked with different currencies in a request offering? I followed the following instructions, but it doesn't work: https://help.ivanti.com/ht/help/en_US/ISM/2017.3/Content/ServiceDesk/RequestOfferings/Example%20Using%20Multiple%20Currencies.htm?Highlight=price

       

      Even if I change my location and there is a price variance for this country, the prices in RO are still displayed in Euro.

       

      Maybe someone can help.

       

      Many thanks and many greetings

      MaBa

        • 1. Re: Using Multiple Currencies
          Jonathan.Schmidt SupportEmployee

          Hi Maba,

           

          If you've followed the appropriate help files and are not getting the expected results, please open a ticket with support.  They can help you find out what went wrong or get it logged to development as a bug if need be.

           

          Jon

          • 2. Re: Using Multiple Currencies
            maba Apprentice

            Hi again,

             

            Does nobody else have this problem? Slowly I am despairing. Meanwhile there is also a ticket, but I don't get any feedback from support if there is a workaround or if there is a solution due to wrong configuration or similar. Unfortunately we depend on this feature.

             

            Thanks in advance

            Best Regards

            • 3. Re: Using Multiple Currencies
              Jonathan.Schmidt SupportEmployee

              Hi Maba,

               

              I can see that this issue was logged to development by the support team.  I see at least one other customer is connected to that Problem ticket and it is accepted as a bug to be worked by our development team.  I'm seeing several emails exchanged between support and your partner on this just today.  I see one other customer is already connected to that same bug report so it's certain you aren't the only one encountering this issue.

               

              Jon

              • 4. Re: Using Multiple Currencies
                AKuhl Apprentice

                Hello all,

                 

                yes, we are facing the very same problem from time to time.

                This error may occur whenever you try to copy a currency field to another. The currency component may be lost and be replaced by the system's default currency.

                (We managed to create correct records, but I cannot tell how nor do we dare to rely on them. Sometimes and unpredictably the system works as expected, sometimes not).

                 

                Workaround: Use an update QuickAction or rule

                "Price=$(ToString([FRS_PriceVariance#.YourRelationTotheVariance]Price))"

                and trigger this either via Editing, Saving or Triggered Rule or a Workflow.

                 

                Note:

                1. Rules could cause timing issues, they sometimes do not fire or have the expected result, try and find out.

                2. WF method is more reliable but may produce a huge amount of WFs that should be cleaned up with a scheduled job.

                 

                Best regards and don't blame me!

                 

                Andreas

                ITSM group - be better