6 Replies Latest reply on Sep 10, 2018 5:57 PM by Doug Castell

    Problem with GMW_LoadAPI in Recent Builds of GM PE?

    Rookie

      We just encountered a problem re GMW_LoadAPI.  We have a number of apps that integrate with GoldMine via GMSX32.DLL.  Testing with GM PE 2018.1.2.15547 revealed the problem.  Subsequent testing with GM PE 2015 does not encounter the same problem.  We haven't tested with all versions of GoldMine between the two yet to determine when the problem arose.

       

      The apps in question have been working successfully with GoldMine for many years, this isn't a question of new code that has never worked.

       

      When testing with GM PE 2018.1.2.15547, calls to GMW_LoadAPI return -4 (cannot validate license file username/password).

       

      We are passing a valid user name and password (MASTER and ACCESS) and have tried various other user name/password pairs, all with the same result.

       

      Our apps trim the user name and password.  Instead we tried padding the user name to length 8 characters and password to length 20 characters, it doesn't solve the problem (the padded values do work in v2015 just as the trimmed ones do).

       

      I can't help but feel that there must be a simple explanation because otherwise there would presumably be posts here on this subject.

       

      What are we missing?

       

      Thanks for any help you can provide.

       

      Barry Chaffe

      519-747-2370 x505

      [email protected]

      Chaffe/Malcolm + Partners Inc.

      GoldMine Third Party Integration Partner