9 Replies Latest reply on Feb 7, 2014 9:48 AM by evizintin

    PXE-E32 error when booting with PXE

    Rookie

      I am trying to deploy a PXE rep on one of my subnets but keep hitting my head against the dreaded PXE-E32 error.

       

      I've tried both with "Transmit MTFTP large packets" on and off in the PXE config, I've tried toying with the MTFTP timeout delay but keep getting the error : the client gets a DHCP IP address without a hitch, I select WinPE and then PXE-E32 happens.

       

      I've tried redeploying the PXE rep, no luck there.

       

      What really troubles me is that if I create a VM on that server and deploy the PXE on that VM....it works flawlessly. The only difference I can see there is that the server has 2 NICs (one with a fixed IP and one with DHCP) whereas the VM only uses one (it's bound to the DHCP NIC on the physical server).

       

      While I could just use the VM as a PXE rep on this subnet, I'm trying -not- to do that : we've done it in the past and the VM would need to be restarted every few days, due to not responding to pings anymore and therefore PXE boot not working. We also have a bad case of VM's and AD not liking each other that much, but that's another story entirely.

       

      I've read that the error could be due to the physical switch not allowing MTFTP (tried with regular TFTP and was greeted by PXE-E35 and PXE-E39) but since it works fine on the VM, I don't see how that could be possible.

       

      Obviously, I've compared the PXE config of the VM to the physical server's one, and they're identical.

       

      This is with LDMS 8.7 SP5, if it makes any difference.

       

      Any ideas before I go ahead and open a case ?