7 Replies Latest reply on Jul 20, 2009 5:38 AM by Tbarton

    Vista .bat and .exe issue

    Rookie

      Hello,

           I created a Batch distribution package. The .bat file basically first creates a folder on the root drive of the target PC. The copies a series of files from a network resource and lastly runs the .exe file that was copied to the created folder.

       

           On XP this works flawlessly. On Vista PCs the folder is created, the files are copied, but the exe never runs. On the target PC I get the "Interactive Message" popup and in LANDesk it says that a restart is needed. I assume that the message is that the system needs a restart, however There should not be any reason for the system to be restarted. There is no user interface for the exe. It creates a registry key in the run folder opens a tcp listening port and places itself into the system tray.

       

           The XP machines do not have to be restarted.

       

      Any help would be appreciated.

       

      Ty

        • 1. Re: Vista .bat and .exe issue
          Employee

          Make sure the package's user setting is set to local system instead of current user.

           

          • 2. Re: Vista .bat and .exe issue
            phoffmann SupportEmployee

            Also. make sure that UAC is disabled.

             

            That's causing no end of problems - particularly when it comes to anything related to software distribution.

             

            Examples of known UAC problems:

            - http://community.landesk.com/support/docs/DOC-2663

            - http://community.landesk.com/support/docs/DOC-2971

             

            Checking the client-side SDCLIENT logs might be interesting too, to see if we run into any errors (which, again, are most likely caused by UAC).

             

            Log-files for software distribution (client-side) can be found in two places:

            * C:\Program Files\LANDesk\LDClient\
            ==> SDCLIENT.LOG

            * C:\Program Files\LANDesk\LDClient\Data\
            => SDCLIENT.LOG
            => SDCLIENT_TASK##.log

            In this case, particularly the SDCLIENT_TASK##.log (where ## == the number/TASK_IDN of the task in the database's "LD_TASK" table) will be useful.

             

            - Paul Hoffmann

            LANDesk EMEA Technical Lead

            • 3. Re: Vista .bat and .exe issue
              Rookie

              Thanks for the input.

               

              UAC is off. We have this set as a domain policy and I checked on the test PC to confirm.

               

              Looking at the log file does not give me any information other than the files were downloaded.

               

              I tried to change the delivery method to Policy this morning. When I run the task it sits there the the target PC is moved from Active to pending and looking at the status it says "Policy has been made available." and the status is "waiting" not sure what that means? I am logged into the target PC with a domain admin account.

               

              Any other thoughts?

               

              Ty

              • 4. Re: Vista .bat and .exe issue
                phoffmann SupportEmployee

                Policy won't change anything here. Policy vs. Scheduled task is just a question of "how" the task gets to the client.

                 

                Once the client-side stuff kicks off, it all runs the same route.

                 

                I would suggest you compare the SDCLIENT logs from an XP-client versus the vista client, and show us where it's stopping. If it's copying the files down, it MUST try and execute them - so if it runs into an error executing them, that's fine - but that should still be logged.

                 

                The fact that it DOESN'T seem to execute indicates a UAC-like problem ... although ...

                 

                Have a read here:

                - http://community.landesk.com/support/docs/DOC-1002

                 

                and run the STREAMS-tool on both your Core and your client ... it could be alternate data streams that are blocking you. The symptoms would be similar.

                 

                - Paul Hoffmann

                LANDesk EMEA Technical Lead

                • 5. Re: Vista .bat and .exe issue
                  Rookie

                  I agree that it does act like a UAC issue, but I know that it is turned off.

                   

                  I looked at both lg files and they are the same. The installation in the VISTA PC does work except that the user has to restart to fire the app which is not a major issue. I'm just trying to understand what would keep the .exe from running and require a reboot.

                   

                  It article you mentioned while similar is not the same. I'm not getting a installation or publisher message. I believe the message that LANDesk is trying to show is that a reboot is needed, but it comes across as that interactive message window in Vista.

                   

                  Ty

                  • 6. Re: Vista .bat and .exe issue
                    phoffmann SupportEmployee

                    The "similar" symptom was meant in terms of "it's not executing" - the publisher message may not show up (user context, etc.). It's something I'd recommend on checking just in case, we've seen STREAMS get in the way of all sorts of things .

                     

                    But OK - thanks for your explanation. In regards to "why it needs a reboot" ... check with the vendor off the app, potentially they know. Or there's something on your vista image which causes a pending file rename, which does not happen on your XP clients because of a different software stack? The possible reasons are legion.

                     

                    - Paul Hoffmann

                    LANDesk EMEA Technical Lead

                    • 7. Re: Vista .bat and .exe issue
                      Rookie

                      I wrote the application and the .bat file so I know they are fine. I'm going to try and find out more about the possible reasons for that type of message in Vista in general and see if that leads me anywhere.

                       

                      Thanks,

                       

                      Ty