3 Replies Latest reply on Oct 18, 2018 4:08 PM by CMulca

    Unable to Sysprep Windows 10 1803

    Mednax Rookie

      Hi guys,

       

      I created a Windows 10 1803 image from scratch, but I'm having an issue with Sysprep.  The reason being is because of some of the Windows store apps.

       

      I even tried using the PS cmdlet Remove-AppxPackage, but it still won't remove the app.

       

      I attached a screenshot. 

       

      Any advice would be greatly appreciated

        • 1. Re: Unable to Sysprep Windows 10 1803
          Robert.Bertino Rookie

          I've run into this before as well. Apparently it has something to do with the Apps being installed on the system but not in the user and you have to get rid of the app in both places.

           

          So you have to remove the same apps from the system with either the Remove-AppxProvisionedPackage command or the DISM command. Here's Microsoft's official article on it:

           

          https://support.microsoft.com/en-us/help/2769827/sysprep-fails-after-you-remove-or-update-windows-store-apps-that-inclu

           

          Here's the instructions I wrote myself on how to do it:

           

          First remove the apps on the local administrator user (you've kind of already done this part just manually and not with the PowerShell commands):

           

          1. To display the currently installed packages, run Get-AppxPackage -AllUser | Format-List -Property PackageFullName,PackageUserInformation
          2. From that list, choose which ones you want to remove (can also export them to a .txt file with an > nameoftext.txt). Remember these for the next section
          3. Run Remove-AppxPackage –Package <packagefullname>

           

          Now remove apps completely from the system:

           

          1. To display the currently installed packages, run Dism /Online /Get-ProvisionedAppxPackages
          2. Remove the same apps that you removed in the previous section otherwise Sysprep will fail
          3. To remove them: Dism /Online /Remove-ProvisionedAppxPackage /PackageName:<packagefullname>
          • 2. Re: Unable to Sysprep Windows 10 1803
            Mednax Rookie

            Wow thanks a lot Robert for sending this to me.

             

            I'll give this a shot and let you know.  Sysprep was so much easier with windows 7.

            • 3. Re: Unable to Sysprep Windows 10 1803
              CMulca Rookie

              I have experienced this issue as well. Several times. It never seemed to really have a solid fix for me aside from one approach. What Robert said is definitely something that had worked for me at times. Other times, sysprep would continue to through the same error just with a different app name until I reached the point it was throwing the error with an app name that I could not locate anywhere on the machine.

               

              My go to fix was to recreate the image with a fresh ISO from Microsoft. Then when you get logged in enable the Built-in Administrator account immediately, log into it, delete the user you had to make during the OOBE (via Control Panel>System and Security>System>Advanced System Settings>User Profiles). Then make sure you do NOT run any Windows updates or anything of the sort. Just run sysprep right away set it to go into "Audit Mode", leave the "Generalize" button unticked. Then setup your custom image from there. (Always generalize when done, prior to capture)

               

              From what I've found as soon as you manipulate any apps (Windows updates) you will likely break sysprep. Just get the most current ISO you can then you can run updates after you push the image if needed.