2 Replies Latest reply on Aug 17, 2009 7:52 AM by karenpeacock

    2 identical incident.rpt ( one works, one does not work)

    Apprentice

      This is a touch one!

       

      I have attached 2 versions of incident.rpt

       

      The one working is a original incident.rpt scaled down to just one table: pm_process. Still working from inside Console.

      The other is a fresh incident.rpt mad exactly as the one working. But whatever i try with I can not get this report to produce any information when initiated from inside console. I have verified that tha guid parameter is sent into the report but it does not set pm:guid to this value.

       

      One thing is that all ootb reports are produced in an earlier version of Crystal. I am using Crystal 11

       

      Anybody have some clever suggestions or ways to test the problem.

       

      Göran

        • 1. Re: 2 identical incident.rpt ( one works, one does not work)
          karenpeacock SupportEmployee

          Hi Goran

           

          If you take away the record selection formula for {pm_process.pm_guid} = {?My Parameter} you will see that the report returns all data for all records on both reports.  If you look at the {pm_process.pm_guid} being returned in the working report this matches exactly the runtime parameter ?My Parameter.  Whereas the Crystal 11 report seems to present the {pm_process.pm_guid} from the SQL database in an entirely different format altogether.  This isn't anything to do with the report design but I will look to see if there is a formula that we can use to convert the guid into a matching guid for the one being passed at runtime.

           

          I'm not sure if you'd already worked this all out yourself already but thought I would let you know where I am with this.  Hope to let you know about a formula shortly.

           

          Best wishes

          Karen

          • 2. Re: 2 identical incident.rpt ( one works, one does not work)
            karenpeacock SupportEmployee

            The latest on this is that I could see the issue with Goran's report but when I created a new identical one from scratch for him, it all worked ok.  We figured out that Goran was on an earlier release of Crystal 11 so he is installing R2 and letting me know the outcome.

            Karen