2 Replies Latest reply on Jul 29, 2009 7:45 PM by Agent007

    sdmcache extended file deletion period


      Core: 8.8 SP2a


      Have a batch file which does the following (using System context),  delivery method is set to 'Use download fom source':


      1. stop the tmcsvc.exe service

      2. call reg file which extends the timeout for 'Discard Period' from the default 2 days to 10 days

      3. start the tmcsvc.exe service

      4. copy 'additional files' to sdmcache\packages directory


      All the actions are happening successfully however the timeout values are not being enforced. When i issue the comand tmcsvc /f |more and look at the times, the timeout is still set to 2 days and not 10 days.

        • 1. Re: sdmcache extended file deletion period
          mrspike SSMMVPGroup

          Bond, James Bond...


          Sorry could not help myself...



          Any tasks / packages / files that had ALREADY been deployed will not have the time to live changed, only those packages deployed AFTER your make the change.


          So, to test, make the change, and then deploy a package and then check, see if that works.



          Also the same goes for the other way around, if you have modified a package to live for 10 days and then change the settings to 2 days, these will not delete themselves until the original 10 days have passed



          I just reread your post, your step #4, how are you copying the files? with a task?


          Also, how are you making the change in the registry?  What commands


          Message was edited by: James Marriott

          • 2. Re: sdmcache extended file deletion period

            JM ..


            This is setup as a scheduled task in the following manner:


            - main file is the batch file which has the: 1) net start/stop of tmcsvc.exe and 2) update registry key HKLM...\DiscardPeriod (regedit /s file.reg)

            - in 'additional files', i have the exes that i am looking to copy to each machine for pre-staging installs


            so the batch copies to ..\sdmcache, all the exes in 'additional files' copy to ..\sdmcache and the batch executes.


            Based on what you wrote, it seems i will have to:

            1) kick off a scheduled task which only executes the batch file


            2) fire a second scheduled task that does a copy of all the exe's


            set a provisioning task where action 1 executes the batch and action 2 does the copy