1 2 Previous Next 18 Replies Latest reply on Dec 17, 2018 12:53 PM by mrcross

    Could not login into GoldMine Incorrect Password!

    mrcross Rookie

      GoldMine PE 8.5.2.8

       

      Hi, I have a working remote site installations on two PC's both running Win 10. However the installation on my server (Win Server 2008 R2) has for no apparent reason stopped allowing logins. This means the remote sync is failing to connect. There's a silent login startup script on the server that is presumably failing because if I try to log in manually I get a dialog saying "Could not login into GoldMine Incorrect Password!".

      SQL Server Management Studio can connect to the database so that's not the problem. I've tried copying the GM directory to a backup directory, then uninstalling GM and re-installing from the setup.exe but even then I get the same dialog, regardless of whether I use MASTER and the default pwd or whether I use my own username and password.

      I have an up to date copy of the database on one of the remote machines that is working fine. What's the best way to get the server install back up and running and synced so it has the same data that is currently on the remote?

       

      Thanks in advance for any advice

       

      Mike

        • 1. Re: Could not login into GoldMine Incorrect Password!
          John Neighbors SSMMVPGroup

          There is PROBABLY an easier way to accomplish your need, but it's not coming to mind at the moment.  Plus, I don't claim to truly know what the real problem is.

           

          Even before embarking upon this procedure that I share below, you might simply run some queries against the USERS table in both the GM that you CAN log into AND the one that you CANNOT and compare basic results.  You might find something really crazy like the problem GoldMine has an EMPTY USERS table or something out of whack like that.  I would also suggest comparing INDEXES on the USERS tables between the GoldMine you CAN log into and the one you cannot.  If an index is missing, that may be the problem.

           

          If the problem is that the USERS data on the server-based GM install is messed up somehow, then this procedure below is probably a reasonable solution.

           

          One approach (which requires that you be SQL savvy):

           

          * Copy the USERS table from the GoldMine SQL DB that you CAN log into, into a temporary SQL DB/table.

           

          For illustration sake, I'm referring to "GoldMine" as the LIVE SQL DB in all cases, and "TempSQLDB" as the temporary SQL DB.

           

          a. Create new SQL DB named TempSQLDB using SQL Server Management Studio (SSMS).

           

          b. Copy data from good users table:

           

              select * into TempSQLDB.dbo.USERS from GoldMine.dbo.USERS.

           

          * Move that temporary SQL DB/table to the server SQL install.  (This could be via a backup/restore or a detach/attach routine, either one.)

           

          * Backup the data in the CURRENT USERS table on the server copy of GM (that you cannot log into).

           

              select * into GoldMine.dbo.users_temp_backup_20181205 from GoldMine.dbo.users

           

          * Empty the CURRENT USERS table on the server copy of GM (that you cannot log into).

           

              delete from GoldMine.dbo.USERS

           

          * Insert the USERS data from the "good" working GoldMine

           

              insert into GoldMine.dbo.USERS select * from TempSQLDB.dbo.USERS

             

          Presuming the only issue to begin with was something with the USERS data itself, you should NOW be able to log into GoldMine.

           

          If the issue was something else altogether, then the above clearly won't resolve it.

           

          Hope this feedback helps.

          • 2. Re: Could not login into GoldMine Incorrect Password!
            Doug Castell Expert

            I'm going to go ahead and say that your problem isn't necessarily the users table or the logins, but that this is just a symptom of a larger issue with your installation/database.

             

            Restoring the entire database/GoldMine file-system root folder to a known good backup (two days ago?) might be a good start.

             

            Otherwise, you may also be looking at some sort of virus situation where some critical system/configuration files have been compromised/removed-by-anti-virus...

            • 3. Re: Could not login into GoldMine Incorrect Password!
              mrcross Rookie

              Many thanks for your responses. I've discovered that the desktop shortcut on the server is not pointing to the correct GM installation. It was assuming that the install was in C:\Program Files (x86)\GoldMine when it is in fact in C:\shares\K\apps\GoldMine\

               

              If I go to that installation and double click on the gmw.exe it produces a dialog "The procedure entry point ATC_DoMacroCommand could not be located in the dynamic link library GMTB32.dll."

              • 4. Re: Could not login into GoldMine Incorrect Password!
                mrcross Rookie

                Further to that, a search for GMTB32.DLL finds 3 copies in C:\shares\K\apps\GoldMine\, C:\Program Files (x86)\GoldMine and C:\Goldmine archive. The one in C:\Program Files (x86)\GoldMine is 214 kb dated 02/12/2009. The others are 164kb dated 08/01/2009

                 

                Mike

                • 5. Re: Could not login into GoldMine Incorrect Password!
                  John Neighbors SSMMVPGroup

                  Sounds like the GoldMine install wizard had some prompts answered incorrectly at some point in the past.  However, even with all this confusion, that doesn't explain why the login attempts you originally reported are failing.

                   

                  Nevertheless, this is what I would recommend doing, on the server in question, just to clean-up and get back to a common playing field:

                   

                  1) Remove these 2 registry keys:

                   

                      HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\gmw.exe

                      HKLM\SOFTWARE\Wow6432Node\FrontRange Solutions\GoldMine

                   

                  2) Make sure and REMOVE the entire GoldMine folder in: C:\Program Files (x86)\GoldMine (back it up or zip it if you wish, but get it out of there).

                   

                  3) Run the GMSETUP.EXE for the version of GoldMine in question.

                   

                  4) At this prompt, choose the SECOND (highlighted) option ("Install GoldMine to connect to an existing database".)

                   

                   

                  5) When the field box opens up below, do NOT click the browse button.  Rather, type or paste in: C:\shares\K\apps\GoldMine\

                   

                  6) At the next screen, click the CHANGE button and change the "Install to" path to: C:\shares\K\apps\GoldMine\

                   

                   

                  This is most likely where a mistake was made before.  Many times folks overlook changing this setting on the server (never change it on a workstation, but you generally always want to change it on the server), and thus run into what you are experiencing with the GM files being in two locations, etc.  However, this usually simply unnecessarily complicates things and does NOT prevent logging in and using GoldMine.

                   

                  7) Finish through the wizard.

                   

                  8) When finished, see if you can now log into GoldMine successfully.  I would NOT be surprised if you cannot, as all of the above should not have prevented logging into GM successfully.

                   

                  If you can now log into GM, great.  If not, then I'd suggest running SQL Server Mgmt Studio and running this simple query on the GoldMine database:

                   

                      select * from USERS order by username

                     

                  The results may or may not prove revealing.

                   

                  9) At some point, you will want to EDIT the GM.INI file located in C:\shares\K\apps\GoldMine\ and make sure the SysDir= value points to a UNC, referencing a SHARE name (and NOT the local C: drive on the server).

                   

                  Hope this feedback helps. Good luck!

                  • 6. Re: Could not login into GoldMine Incorrect Password!
                    mrcross Rookie

                    Many thanks John. I'll try it tomorrow and let you know how I get on. Incidentally I did run the SQL query and it came up with the users. Mike

                    • 7. Re: Could not login into GoldMine Incorrect Password!
                      John Neighbors SSMMVPGroup

                      You might also double check the DBALIAS.INI file in main GoldMine folder and confirm it is as it should be.  Just failed to mention that earlier.

                      • 8. Re: Could not login into GoldMine Incorrect Password!
                        mrcross Rookie

                        Hi John

                        Did all that, install completed OK but it made no difference, still getting the incorrect password message. However I have discovered something strange.

                        On the server (broken) installation if I run select * from USERS order by username against the GoldMine database I get a list of users as expected

                        On the remote (working) installation I only see MASTER, however I am able to log in using my personal login

                         

                        Server is running SQL Server 2005

                        Remote is running SQLEXPRESS

                         

                        Mike

                        • 9. Re: Could not login into GoldMine Incorrect Password!
                          Doug Castell Expert

                          Something is very wrong with your installation(s) of GoldMine there. I'd suggest involving a partner to untangle it.

                          • 10. Re: Could not login into GoldMine Incorrect Password!
                            John Neighbors SSMMVPGroup

                            I agree with DCastell's feedback.  Probably would be best served getting help from a GoldMine Partner.  Something is terribly awry!

                             

                            Whenever you successfully log into GoldMine on the remote, go to Tools | SQL Query and run the same query (select * from USERS order by username) WITHIN GoldMine and see what results you get?  They should clearly be different than JUST MASTER.

                            • 11. Re: Could not login into GoldMine Incorrect Password!
                              mrcross Rookie

                              OK I resolved the issue on the remote (working) installation. Looking at the C:\Program Files (x86)\GoldMine\gm.ini it contains RealIni=C:\ProgramData\GoldMine\gm.ini

                              If I go there I find

                              GoldDir=GoldMine2:

                              CommonDir=GoldMine2:

                               

                              If I look usng SSMS there is indeed a database called GoldMine2 and if I run the query against that database I get a list of users that looks perfectly correct.

                               

                              So I'm back with the issue of the incorrect password message on the server installation. I'll check over the weekend to see if I can see anything similarly weird in the server installation.

                               

                              Thanks for your help guys.

                              • 12. Re: Could not login into GoldMine Incorrect Password!
                                Doug Castell Expert

                                note that the 'GoldMine2:' in the gm.ini file refers only to the alias (server, database name, etc.) listed in the corresponding dbalias.ini file. That is not necessarily a database of the same name (nor is it necessarily even hosted on the same machine.)

                                 

                                Open/check the dbalias.ini to figure out exactly where GoldMine2: points -- yes, it's probably the database on the local machine you found, but, in untangling this mess, it's best to be thorough.

                                • 13. Re: Could not login into GoldMine Incorrect Password!
                                  mrcross Rookie

                                  Thanks Doug. Yes I did check the dbalias.ini and yes it is pointing to the correct database so that's cleared up any suspected anomalies on the remote machine. The problem remains on the server where an attempt to log in produces the dialog "Could not login into GoldMine Incorrect Password!" using either my own username and password or the MASTER login and password. An authoritative reason for this error message to be thrown would help me to know where to look.

                                  • 14. Re: Could not login into GoldMine Incorrect Password!
                                    Doug Castell Expert

                                    start from the gmw.exe you're running, find the associated GM.ini (and, if applicible, the realini pointer to the real gm.ini), then to the dbalias.ini, then to the database that points to and check the users table within.

                                    1 2 Previous Next