4 Replies Latest reply on Aug 17, 2009 1:18 PM by cgatling

    asset.root file missing? Asset Manager

    Rookie

      Recently via a service call with LanDesk support, we had to run .Net 1.1 in order for Asset Manager to run via Internet Explorer. I was able to import data via .csv file fine. The main problem I noticed is I was not able to modify the data after being imported. I tried changing my .net to 2.0 to see if that would help, but then the asset manager page would not display via IE. I reverted back to .Net 1.1 and now Asset manager is showing as "page can not be displayed".

       

      Here is the message shown via IE:

      The page cannot be found

      The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.


      Please try the following:

      • Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
      • If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
      • Click the Back button to try another link.

      HTTP Error 404 - File or directory not found.
      Internet Information Services (IIS)


      Technical Information (for support personnel)

      • Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
      • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.

       

       

      Can I resolve this issue by simply reinstalling Asset Manager software?

       

      I'm currently using Landesk Management Suite 8.7 SP6

        • 1. Re: asset.root file missing? Asset Manager
          phoffmann SupportEmployee

          Is shifting .NET versions the only thing you've done? Because that shouldn't cause a 404 (which means that either the file is gone, or the NTF permissions on it are messed up and IIS can't read it, so it thinks it doesn't exist).

           

          There may be a larger problem here, potentially.

           

          I'm somewhat hesitant to ask, but - do you have a backup, first of all, of the server before this was done? Generally, hopping .NET versions should be discouraged - but it shouldn't normally break "this sort of thing". I'm wondering if more broke along the way ... so potentially restoring it from a working backup and then importing the CSV files with the date you wanted (since you now know what ever you needed to do), may be the less painful way to go in the long run?

           

          I'm rather cautious here, as if one file is missing already, odds are that more might have gone AWOL.

           

          - Paul Hoffmann

          LANDesk EMEA Technical Lead

          • 2. Re: asset.root file missing? Asset Manager
            Rookie

            the shifting of .net versions is really the only thing that has been done. I did what the support tech instructed me to do. In each shift the only command  for the re-registering was C:\Windows\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe –i

             

            then afterwards he had me type iisreset.

             

            We did iisreset after registering 2.0 and when we did 1.1.

             

            I'm sure there is a backup of the core server before these changes. we have a Lan admin here that handles all of the backups for all of the servers daily. but, management suite is working fine. Also, the remote version of management suite is fine as well. At this point, its only viewing the asset manager part that is not visible.

             

            I looked in the directory of where asset.root should be and its not present. I tried an uninstall of asset manager and reinstalled it again, but it did not recreate that file. I'm not sure what else to do at this point.

            • 3. Re: asset.root file missing? Asset Manager
              phoffmann SupportEmployee

              So the ASPNET_REGIIS stuff is perfectly harmless and wouldn't touch Asset manager. It's just forcibly re-hooking a specific version of .NET into IIS. Doesn't touch anything outside of IIS (i.e. LANDesk and co). Perfectly safe.

               

              Which leads me to the conclusion that there may be other things that are / were broken with Asset before this ... so you may potentially have a look at the contents of your backup, and compare folder structures (a tool like WinMerge and/or MD5SUMMER from http://www.md5summer.org/ will help with that).

               

              - Paul Hoffmann

              LANDesk EMEA Technical Lead

              • 4. Re: asset.root file missing? Asset Manager
                Rookie

                Thanks for the help. However, when I went back to retrace my steps, I noticed the default website under IIS Manager was still pointing to .Net 2.0. Once I switched that to .Net 1.1, Asset manager is showing up again.

                 

                I have another issue, but i'll start a new discussion thread for that.

                 

                Now i'm getting a script error message whenever i click on an asset to modify it.

                 

                Thanks again for the assistance.