3 Replies Latest reply on Sep 10, 2009 4:26 AM by phoffmann

    Delete Action fails in Provisioning

    Rookie

      I have a problem during the provisioning of Windows XP. The delete action fails whenever I try to delete the file c:\documents and settings\default user\ntuser.dat.

      I want to delete this file and replace it so that when new users log on to the computer they have the custom settings we want all our users to have. Anyway the delete action reports that it was successful but if I connect to the admin share from another computer (without ever having logged onto the target) I can see the file sitting there. The next action is to copy the new ntuser.dat file from a network share into this folder but that fails, I assume, because the copy wont' overwrite the file.

       

      I've tried using quotes around the path but I get an error message: The path and file name is blank or invalid. Type a vailid path and file name.

      I've tried shortening the file name using 8.3 naming conventions ie. c:\docume~1\Defaul~1\ntuser.data - make no difference it still fails

      I've checked the attributes on the file, the only attribute was the "Hidden" attribute. Removing it didn't help.

      I've tried placing the delete action in the OS installation, Post OS installation and in the System Configuration and have had no success.

      I've checked permissions on the network share but I do a driver copy from the same share earlier in the script and that works no problem.

      I've logged into the admin share on the target after widnows is installed, manually deleted the file and then performed a copy file action and it will copy there from the network provided the file is deleted first.

      The user account I'm using is a domain administrator account so it has the necessary rights.

       

      I think everyone will agree that this is about as basic an action as you can get and still LANDesk fails. There are no errors messages since it thinks it deleted the file. The copy fails afterward and it fails to provide an error message, just some cryptic number that means nothing to me. The log files have nothing meaningful in them. I've sent logs an several emails to Tech Support but I've only had 1 reply in 3 days.

       

      Is there anyone who can provide a reason or a suggestion as to why LANDesk can't delete this file?

       

      P.S

      I'm running LDMS 8.8 with service pack 3 installed.