7 Replies Latest reply on Feb 9, 2010 6:58 PM by lcrossley

    Unable to Publish anything through Launchpad

    Binskin Apprentice

      Initially with the release of 8.8 SP2 we did try to use the LaunchPad feature, but was put on the backburner due to the number of additional issues SP2 itself generated for us. That is behind us now and we have updated / rolled out SP3 and we would like to try again.

       

      I have been going through the online support video / faq trying to chase up where i have gone wrong here, but so far all my clients simply display no links in launchpad.

       

      Today i created a test link, just a basic 'refresh launchpad' link, as done in the video, saved it, scheduled it and pushed it to a single machine. The task id was 1363. I followed it to my test machine and i can see the xml file in \All users\App Data\Landesk\Mgmt Suite\Landesk\files\SDClientTask.MILAPP04.1363

       

      If i browse to c:\program files\landesk\ldclient i find the following logs:

       

      - policy.sync.log

       

      An error (-2147024713, An error occured downloading the file.) occured downloading the remote operation file http://127.0.0.1:9592/landesk/files/.

       

      However the list of files below seems completed, and i can see each of the files mentioned in all users\app data\etc... but i can not find them in the c:\program files\landesk\ldclient\data dir, only 2 tasks (973 / 990) appear here.

       

      - policy.client.invoker.log

       

      Wed, 16 Sep 2009 16:48:14 ProcessInvokerStateRecords() error - unable to sandbox file
      Wed, 16 Sep 2009 16:48:14 ProcessInvokerStateRecords() ready to process 1 records
      Wed, 16 Sep 2009 16:48:14 GetXMLFileName() returning  ()

       

      Lots of errors here, and this message seems to be looping.

       

      If anyone could assist or has seen something similar any notes would be greatly appreciated before i raise a support ticket (i tried to log in last week but my forum profile doesnt match our account on the new support system, so i have emailed the support desk but yet to receive a reply since last friday).

       

      Cheers - ben

        • 1. Re: Unable to Publish anything through Launchpad
          Binskin Apprentice

          As an update to this it looks as though the client machine is now doing the policy.client.invoker 40-60% usage thing as mentioned in other threads.

           

          I did come across a script from zman which i ran on my sql server and it did come up with a number of results

           

          SELECT     *, REMOTE_OBJECT_NAME AS Expr1
          FROM       LD_TASK
          WHERE     (DELIVERYMETHOD_IDN <> 0) AND ((REMOTE_OBJECT_NAME IS NULL) OR (REMOTE_OBJECT_NAME = ' ') OR (REMOTE_OBJECT_HASH IS NULL) OR (REMOTE_OBJECT_HASH = ' '))
          ORDER By  TASK_NAME

          However now that i have these results i am unsure what to do with them.

           

          Cheers - Ben

          • 2. Re: Unable to Publish anything through Launchpad
            SupportEmployee

            This issue is that the XML files for task(s) have gone missing on the core server (or the reference to them). You will want to apply this patch http://community.landesk.com/downloads/patch/SWD-2808788.3-2.exe . You should be good to go in regards to the CPU utalization and your new policies should start to work.

            • 3. Re: Unable to Publish anything through Launchpad
              Binskin Apprentice

              Gerald

                   Ive downloaded and applied the patch to the core / client, still no go although it did resolve the cpu usage issue. However now if i try to run the software distribution portal i receive the following error:

               

              URL Could not be retrieved - http://127.0.0.1:9595/policy.cgi.exe? (update: http://localhost:9595/policy.cgi.exe does?)

               

                   I completed a rebuild of my agents, created a new self installer and ran that also, rebooted, but i receive the same error.

               

                   The test machine now has no files in the all users\app data locations either ....

               

                   Scratch that ... after running the localhost version of the policy.cgi.exe i now have a launchpad!!

               

                   Any ideas on what i can do to fix the 127.0.0.1 version not working?

               

                  Cheers - Ben

              • 4. Re: Unable to Publish anything through Launchpad
                SupportEmployee

                Just to make sure that I understand what you are saying:

                 

                - You installed the patch I mentioned. This resolved the CPU utilization issue you were having.

                - You are unable to get to the web portal using the http://127.0.0.1:9595/policy.cgi.exe

                - You can, however, access the web portal if you use http://localhost:9595/policy.cgi.exe

                 

                That's quite strange for localhost to work and 127.0.0.1 not. From a networking perspective they are the same (more or less). Please post the results of the following test:

                - From a client having this issue, open a command window and do a route print and post the results.

                - If you are using a proxy on the client, disable it to see if this works. If the "resolves" the issue, let me know if you using a scripted proxy or not.

                • 5. Re: Unable to Publish anything through Launchpad
                  Rookie

                  I am having a similar issue with at least one PC. The policy.sync.log file contains

                  Wed, 16 Sep 2009 15:53:25 [START] Policy synchronization stated.
                  Wed, 16 Sep 2009 15:53:25 Sending update request to core server.
                  Wed, 16 Sep 2009 15:53:26 Web request returned 23 unexpected http status.
                  Wed, 16 Sep 2009 15:53:26 [STOP] Error: policy update request has failed.

                   

                  and nothing else. The result is that loading the policy based delivery application hangs on checking the policies.

                   

                  I suspect is the same or a similar issue.

                   

                  I have had the patch mentions applied to the workstation but it has not been applied to the server (this would require change mangement).

                   

                  If you do not think this is the same issue I can start a new thread.

                  • 6. Re: Unable to Publish anything through Launchpad
                    Rookie

                    We had a similar problem where localhost would work and 127.0.0.1 would not. It was our proxy settings causing the problem, it was forcing all ip addresses through the proxy which stuffed the portal around.

                    • 7. Re: Unable to Publish anything through Launchpad
                      Rookie

                      Found the fix. Running a repair on the common base agent fixed the issue.

                       

                      msiexec -f "C:\Program Files\LANDesk\LDClient\cba8inst.msi"