3 Replies Latest reply on Oct 2, 2009 10:37 AM by brandonhyde

    2 Different Machines Using Same GUID

    Apprentice

      Ok guys,

       

      I did a quick search and didn't find anything on this one so hopefully someone has a quick solution...

       

      I think the subject is pretty clear but basically what I have going on is two seperate machines using the same LANDesk GUID.  Below are the facts...

       

      - Agent was installed post-image via a Provisioning task.

      - I tried deleting the GUID (from both Intel and LANDesk locations in the registry) then rebooted and ran a new scan...still no go.

      - The machines have different MAC addresses and different IP's.

      - Sysprep was ran on both so the SID should be different (any way to check this?)

       

      The only thing that has changed in our environment is the fact that I'm testing LANDesk Provisioning on these two machines.  I hate to blame it on Provisioning but it has to be a possibility...

       

      Thanks in advance,

       

                               Brandon

        • 1. Re: 2 Different Machines Using Same GUID
          Jason SupportEmployee

          Brandon,

           

          Do you have restore old device ID's enabled in you duplicate device detection? You can check by going to configure>services>inventory then clicking on  the devices key. If you have this set value set when inventory runs it will readd the GUID in the DB it will not generate a new one. The work around to this would be to either turn that value off and then delete the keys and rescan or delete the keys and the DB entry for said device and then rescan.

           

          As for how it duplicated to begin with, we usually only see this happen when an agent or those keys exist on an image, the keys might not have been removed and with restore old  device ID checked that would explain this happening while ruling out provisioning as the cause.

           

          J

          • 2. Re: 2 Different Machines Using Same GUID
            Apprentice

            Jason,

             

            We do not have "Restore old Device IDs" checked.  I'll give it a shot and let you know.

             

            In regards to the GUID's being left on the image, that was not the case.  We're in the process of switching from Ghost to LANDesk as our primary image tool and when we did use Ghost, we left the agent on the image so we were very familiar with removing the GUID's before capturing the image.

             

            Besides that, as I said before, I tried deleting both GUID's from both machines, rebooting, rescanning, and they still grabbed the same one.  Anways, I'll let you know what I come up with.

             

            - Brandon

            • 3. Re: 2 Different Machines Using Same GUID
              Apprentice

              This has been resolved!!!

               

              So long story short...I did accidentally forget to delete the ID's out of the registry before I pulled my image.  Thus...my nightmare began.  I though surely, even if I made this mistake, it could be resolved by deleting the Device ID's out of the registry and running an inventory scan to create new ones right?  WRONG.  Below are the steps I used to solve this.  Part of the solution came from another discussion.  My apologies but I cannot locate it again to reference it.  Anways, here it goes.  (p.s.  in my situation, I had 3 machines using the same Device ID)

               

              1. From the console, choose the "Configure" menu and then "Services".

              2. Click on the inventory tab.

              3. Click on the "Devices" button and choose "MAC addresses match".  (You might have to un-select "Both devices..." first)

              4. Uncheck "Restore old Device IDs" if it's checked.  Click "Ok".

              5. Click on the "Device IDs" button.  Here you want to set "Computer.Network.NIC Address" as the only ID Attribute.

              6. Make sure the "Identity Attributes change" is set to 1.  Also make sure "Reject Duplicate Identities" is checked.  Click "Ok".

               

              Note: The settings we just changed can be temporary.  If you have laptops in your environment, you'll probably want to change it back when you're done since sometimes they scan in with different NIC's (wireless vs network).

               

              Another Note Before Moving On...DO NOT DELETE THE DEVICE ID'S FROM THE REGISTRY!!!  I cannot stress this enough.  I went in circles for hours and hours because I kept deleting those darn reg keys!!!  You need to leave them along and let LANDesk do what it's designed to do.

               

              So what you'll want to do next is run 2, yes, 2 inventory scans on one of the problematic pc's.  Odds are it will keep the Device ID that is being duplicated, which is fine.  Next, run 2 more scans on the next machine that has this Device ID.  During the second scan, LANDesk is going to reject the Device ID since it's already in use and generate a new one for that machine.  If you have a 3rd problematic machine, do the same thing to it...2 scans.

               

              This is what finally fixed it for me.  It seems simple but there are a lot of solution out there that have you delete the Device IDs from the registry.  The problem is because I kept doing that, LANDesk just kept assigning the last known ID back to the machine so I was going in circles!!!

               

              Good Luck!