3 Replies Latest reply on Oct 2, 2009 11:30 AM by sriley

    Moving the Gateway behind a Reverse Proxy

    Apprentice

      Last evening, our Gateway appliance was moved behind a reverse-proxy.  The reverse proxy receives requests from the internet and forwards them to the correct host.  Therefore, our public IP address has changed.

       

      I went into the core and changed the Gateway config to the new external address.  Restarted the service.  So far so good.

       

      Now, I remoted into a computer off the LAN and ran an inventory and a vulscan.  Good to go.

       

      So then I tried remote control - and it failed.  It had been working before the migration.  I got an error "12", which I looked up to see that the certificate had expired.

       

      I belive that the certificate has to be moved or copied to the reverse proxy, but I don't know if this is for sure, or where to get it from (the gateway?  the core?) or how to install it.

       

      I am also wondering why the inventory and vulscan worked if the remote contol didn't -- isn't the client accessing the core the SAME WAY?

       

      I am looking for a procedure and a detailed explanation.

       

      Thank you,

       

      Scott.....