5 Replies Latest reply on Nov 2, 2009 12:51 AM by sander.reiding

    HII and single core troubles


      Hardware Independed Imaging is not working on our single core machines. Who can give me some insight.


      We use the Hii version 9.1 in combination with winPE to do a Windows XP SP3 deployment. We did build a OSD template in Landesk Suite that we use in combination with a PXE boot.


      The Template runs ok on our dual core machines (HP DC7700, 2530p, etc) but when we use it on single core machines it stops working when it configures the target os (configure_target_os). It stops with a 80001803H error.


      The template uses the following steps in the Post-OS install part :


      Halconfig.exe /cab=sp3.cab /log=c:\confhal.log (expecting return value 0)

      ldprep.exe /path=%DRIVERS%\PnP /log=c:\LDPrep.log (expecting return value 0)

      injectmsd.exe /log=InjecMSD.log


      In the single core config (HP dc7600, nc8230) it will stop after the ldprep.exe part, the logging of the ldprep.exe step gives an END and no log is generated for the injectmsd.exe step.


      I checked if the SP3.cab excists and if the files are copied, the are copied, the sysprep.inf is modified so that's ok I think. Where to look now ?

        • 1. Re: HII and single core troubles

          One small puzzle is why you don't get an injectmsd log. I notice the absence of a path in the /log parameter of your injectmsd command line below (/log=injectmsd.log). If indeed you are using the command line exactly as shown, injectmsd may be trying to create a log in a different place than you think, or (if running from server) in a place where it has no write access. Note that you shouldn't need /log parameters on any of the command lines you are showing because all 3 tools create a log without being told to. You need /log parameters only if you don't like the default (c:\drivers if that's what you have in copydrivers.ini).


          As to the bigger question of why configure target OS ("ctos") fails, can you please clarify how it fails. I'm not sure that the error code tells us much. CTOS ends up rebooting the machine and the action is not considered successful until the machine has successfully rebooted, run through mini-setup and started the provisioning agent. Therefore, one way in which CTOS can fail is the machine doesn't reboot. Therefore, question: does CTOS fail immediately, without even getting as far as rebooting the machine? Or does CTOS reboot the machine, but the machine dies?


          In the former case (CTOS fails immediately, without rebooting the machine), forgot the HII context, forget HALs and mass storage drivers, this is just a problem with CTOS. I seem to remember there have been problems with CTOS failing if you had a cmdlines.txt. Might one difference between the machines that work and the machines that don't be that the latter have a cmdlines.txt and the former don't? You're not stating what version you're running, but if it is not 8.8 SP3, this might be "the old CTOS problem".


          In the other case (machine dies on reboot), then yes, need to start wondering about HALs and mass storage drivers...

          • 2. Re: HII and single core troubles

            The puzzle of the missing log file is solved, `I indeed forgot the drive/path and so looked at the wrong location. It indeed did produce a log file.


            The bigger question ... well we load a OSD template (same as for the dual core machines) and it does the described steps:


            Halconfig.exe /cab=sp3.cab /log=c:\confhal.log (expecting return value 0)

            ldprep.exe /path=%DRIVERS%\PnP /log=c:\LDPrep.log (expecting return value 0)

            injectmsd.exe /log=InjecMSD.log












            Next step in the process is a "configure target os" , this is a command in the template without the "Insert unique ID" selected. Normaly the machine will reboot and continue the template and start on the System Configuration part but a single core machine won't reboot and stops with an 80001803H error.






            Landesk           v 8.8-SP3

            HalConfig.exe     v 2.3

            Injectmsd.exe     v 1.1

            LDPrep.exe        v

            • 3. Re: HII and single core troubles

              Sorry if it looks like I'm deliberatly doing my best to misunderstand you, but your words ("machine won't reboot ... ") can still be read in two ways: (1) "the machine won't reboot", i.e. it hangs on reboot (2) "the machine won't reboot", i.e. the CTOS action fails before it gets to the point where it is supposed to reboot the machine. I believe you are probably saying the latter, but some of the context that you put around the problem (including the title) suggests the former. So please confirm.


              If indeed the problem is that CTOS fails (and not that the machine hangs on reboot), then the correct description of the problem is "CTOS fails". Forget HII, halconfig, ldprep, injectmsd... - none of those are part of the equation. You may want to open a support case with LANDesk customer support to investigate why CTOS is failing. There have been a number of problems with CTOS (including one to do with "insert unique ID", another one to do with cmdlines.txt) - although I believe they are supposed to be fixed in SP3.


              If CTOS works on some machines and not on others, then just about the only explanation I can imagine is something to do with cmdlines.txt. As you will be aware, copydrivers allows you to specify setup commands to be inserted in cmdlines.txt. CTOS as well inserts a line in cmdlines.txt.

              • 4. Re: HII and single core troubles

                Well I got somethings solved, the configure_target_os won't stop with the 80001803H error. It seems you need a cmdlines.txt even when it's empty. Now the only trouble is it won't reboot.  In other words I solved COTS from failing now it stops normaly ? and in the scheduled task it tells me the result : Might Reboot

                Unfortunaly it never will so I suppose I have to contact customer support.

                • 5. Re: HII and single core troubles

                  Well all troubles solved.


                  You need a cmdlines.txt and a Runonce.ini with the Headers in the file ([Commands], [GuiRunonce]). This is even when you dont specify any command in them.


                  When they don't excist the OSD proces will or won't work.