1 Reply Latest reply on Jan 26, 2010 8:40 AM by eclosson

    UltraVNC uninstall through LanDesk

    Rookie

      Within the past 6 months we have migrated to LanDesk. Prior to this we had a smattering of RealVNC, WinVNC, and UltraVNC all over the network depending on when the computer was built and who built it. The time has come to remove VNC from most of the machines. Real and Win went off without a hitch, calling the uninstall executable from a batch file. Ultra on the other hand has been a nightmare.

       

      Ultra uses a different uninstall named unins000.exe in the C:\Program Files\UltraVNC\ directory. If you run the command "unins000.exe /verysilent" on the local machine it uninstalls perfectly with no interaction from the user nor any notification that it has been removed(which is what we want). So my first thought was a batch file like the other two. This was unseccesful, it ran the batch and return...... . Since we have had an issue or two in the past with batches not running correctly I wrote a vbs script to run the same command. It would again run and return succesful but UltraVNC was still on the machine. This returned "processing of package is complete, result 0 (0x00000000 - code 0)". So after tinkering with that for a while and still not having any success I copied the unins000.exe and unins000.dat to the core server and created an exe package. Still no luck. It is failing with the following message

       

      Tue, 26 Jan 2010 10:15:45 Launched application 'C:\Program Files\LANDesk\LDClient\sdmcache\distpackages\UltraVNC Uninstall\unins000.exe' ('/verysilent') result -1
      Tue, 26 Jan 2010 10:15:45 Installation result FFFFFFFF
      Tue, 26 Jan 2010 10:15:45 processing of package is complete, result -1 (0xffffffff - code 65535)

       

      I can run the exe from the core server with the /verysilent switch and it works fine. Same as the other two. Running from the core on the machine uninstalls fine.

       

      Has anyone successfully used landesk to remove ultravnc or have any issues on where to head from here. I have a batch file that stops and removes the service. Unfortunately it leaves the entry in add/remove programs so a query, unless written to look for the service, is still going to report VNC being loaded on the machine.

       

      Thanks,

      Erik