10 Replies Latest reply on Jul 9, 2010 3:40 AM by hoeltermann

    Customize reboot timeout

    Apprentice

      How would I go about customizing the amount of time before a reboot after a successful package deployment? I am setting options in the "Reboot" section of the delivery methods, but there is no option for specifying the amount of time before a reboot. I believe this option exists under agent configuration.

       

      If the option isn't available in the UI, is there a registry key or something on the core server that I can modify? The default time of 10 seconds simply isn't long enough for my users. I would like to be able to set this to 10-15 minutes.

       

      I am on 8.8 SP3

        • 1. Re: Customize reboot timeout
          zman Master

          Shane.

           

          Couple of options:

           

          1. Read this ER and if you agree provide 3 points. http://community.landesk.com/support/thread/9255
          2. Use Security and Patch - create a custom vulnerability for the package.
          3. Create another software distribution package that calls either poweroff or shutdown with the proper time and call it as a Final Package under Scheduled tasks. So your main package does not reboot the secondary package does the reboot.
          1 of 1 people found this helpful
          • 2. Re: Customize reboot timeout
            Apprentice

            On #1, I agree 100%, but how do I provide points?

             

            On the other options, I would like to avoid any of that if possible.

            • 3. Re: Customize reboot timeout
              zman Master

              Edit your ER message response and place a  [3] in the body of the message on a seperate line. http://community.landesk.com/support/docs/DOC-7223 Thanks for the responses.

              • 4. Re: Customize reboot timeout
                Rookie

                Reboot dialog for software distribution is by default set to 30 seconds but can be set from 10 to 300 seconds.

                 

                1. In the LDLOGON folder, search for the INI file with the same name as the Agent (eg. Default Windows Configuration.ini)
                2. Using Notepad, open this file and find the text "SWD.RebootTimeout 30"
                3. Replace 30 with any number between 10 and 300 (ie. 10 seconds to 5 minutes)
                4. Save the file and schedule an agent update.
                • 5. Re: Customize reboot timeout
                  Apprentice

                  I have updated the suggested file and set the timeout to 300 seconds, but it is still timing out at 10 seconds. The original setting of 30 seconds is not what I am seeing on the client. The client is rebooting after 10 seconds, so I don't think that this is the setting that is being used for the timeout when the software is being installed.

                   

                  Is there anywhere else that I can set a timer for policy based installation reboots?

                  • 6. Re: Customize reboot timeout
                    Rookie

                    "SWD.RebootTimeout" setting only applies to the LANDesk's reboot dialog and I suspect from the information provided that the reboot dialog being presented is from the MSI (or equilevant). Therefore it will be necessary to review the package source files to change the reboot. That being said, if a screenshot of the dialog could be attached to this posting, that would be useful in determining the source of the reboot.

                    • 7. Re: Customize reboot timeout
                      Apprentice

                      The full sequence of events are below:

                       

                      Screen shot 2010-02-25 at 8.43.58 AM.png

                      Screen shot 2010-02-25 at 9.21.36 AM.png

                      Screen shot 2010-02-25 at 9.23.11 AM.png

                      This last one was captured as soon as the reboot window appeared, the timer is only for 10 seconds. I have updated the .ini file, "rebuilt all", rebuilt standalone agent, re-installed new agent all to no avail. Is there somewhere on the client I can check for the timer? Is there a registry value?

                       

                      The MSI is definitely prompting the reboot, since it is Acrobat Reader and IE is open it requires a reboot. The restart is being handled by LANDesk though.

                      • 8. Re: Customize reboot timeout
                        Rookie

                        Weird ... changing the "SWD.RebootTimeout" setting and re-deploying the Agent does change the timer in the LANDesk's reboot dialog on our client.

                         

                        However, one workaround is to remove the timer completely from the reboot dialog, which can be performed as follows:

                         

                        1. Goto the LDLOGON\html folder on the LANDesk server (or the LDClient\html folder on the Agent)
                        2. Using Notepad, open the rebootnotification.html file
                        3. Find the line: StartTimer(timeoutValue, "timeout_div");
                        4. Insert a comment ("//") at the beginning of this line
                        5. Find the line: <div name="timeout_div" id="timeout_div"></div>
                        6. Insert a comment ("//") at the beginning of this line
                        • 9. Re: Customize reboot timeout
                          Apprentice

                          Well, that does work, but that doesn't allow me to use different times for different agents, which I think I can work around. I would like to know why this isn't working though!

                           

                          I have also created an entirely new agent, and modified the .ini file accordingly and it is still reboots at 10 seconds! ARGH!!!!

                           

                          I also looked through the 2 JavaScript files that are in use for the reboot window and I can't see where it is pulling the reboot variable from, must be in the querystring somewhere.

                           

                          Anyone else have any ideas?

                          • 10. Re: Customize reboot timeout
                            Apprentice

                            I "solved" the reboot problem via a "dummy/fake" vulscan-call at the end of my batch-package.

                             

                            - create  "scan and repair settings" which do nothing (not scanning anything, not repairing anything)

                            - set it to "show progress dialog: never"

                            - setup the reboot behaviour as desired on the reboot tab

                             

                            Whenever i need to reboot the client machine in one of my batch packages (i only use batch packages) i'll call the above scan and repair setting:

                             

                            :reboot
                            sdclient.exe /msg="%date% %time% - installation needs reboot ..."
                            "%LD_CLIENT_DIR%\vulscan.exe" /rebootIfNeeded /agentbehavior=222 /nosync

                             

                            (222 = ID of the scan and repair setting mentioned above)