11 Replies Latest reply on May 11, 2010 3:37 PM by Mach6

    PXE Error

    Rookie

      We are getting the following error when trying to capture an image on a Lenovo T510:

       

      PXE-E74 bad or missing pxe menu and or prompt information

       

      All other machines are working ok.  This is our first T510.

       

      Thanks

        • 1. Re: PXE Error
          EMiranda Expert
          The BIOS and NIC firmware have a limited capacity for PXE Boot Menu options. This has been seen on a number of computers including:

          Lenovo machines with BIOS 3.11 or later

           

           

           

           

          http://community.landesk.com/support/docs/DOC-2916

          • 2. Re: PXE Error
            Rookie

            I've reduced the menu to three choices but still get the error on the T510.

             

            Any other suggestions?

             

            Thanks

            • 3. Re: PXE Error
              EMiranda Expert

              well the issues seems to be related to the bios.  my other suggestion is to upgrade the bios from the manufacturer's website, sometimes, even the latest version of the bios IS the problem and may need to be downgraded.

              • 4. Re: PXE Error
                Rookie

                We are experiencing a similar error with a batch of new Lenovo T400 laptops with BIOS v3.11. We have since downgraded a couple of the laptops to BIOS v3.10 and the PXE Booting worked.

                 

                Is there a fix from LANDesk that does not require downgrading the BIOS?

                 

                Downgrading a few handful may be OK but hundreds would be very tedious and time consuming. Thanks!

                • 5. Re: PXE Error
                  Jared Barneck SupportEmployee

                  What is the Vendor's response when you reported their BIOS problem to them?

                  • 6. Re: PXE Error
                    Rookie

                    We do not have a response from Lenovo yet!

                     

                    However, since this Lenovo BIOS version issues is not affecting just us but possibly many, many others, I feel LANDesk and Lenovo, who are partners, need to work together and figure out a solution.

                     

                    BTW, we also tried upgrading to the later (latest) v3.12 version of the BIOS, and the problem continued. The only solution was to revert back to v3.10 BIOS!!

                     

                    Thanks!

                    • 7. Re: PXE Error
                      Jared Barneck SupportEmployee

                      Yes, we have a great partnership with Lenovo.

                       

                      I have looked at our internal bug database which documents the discussion between Lenovo and LANDesk.Looks like the issue is diagnosed and Lenvo knows where the issue occurs.

                       

                      We have released this document on this issue:

                      Error: PXE-E74 bad or missing PXE menu and or prompt information

                       

                      This document explains that most poeple who have disabled DOS PE and Linux PE according to this  document have reported no problems.

                      How to hide LinuxPE, WinPE, or DOS PE PXE Boot Options from the F8 Menu

                       

                      After disabling both DOS PE and Linux PE, you should only have the two WinPE boot items remaining, which are quite small.

                       

                      I note that one user in this post says that didn't work for them.  I would like them to verify that they did this to all their PXE Reps and that they booted from a PXE Rep that had these options removed.

                      • 8. Re: PXE Error
                        Rookie

                        The solution worked for us!! Thank you!!!

                         

                        We needed the WinPE options so after a little testing we only set "1" to the Linux options. This seem to be working for us just fine.

                         

                        Thank you again.

                        • 9. Re: PXE Error - New BIOS Available for Lenovo T500 and W500
                          Apprentice

                          We were having this problem with our new Lenovo T500's. Reported it to Lenovo last week and this week we received an email from them. They have a new BIOS update for the T500 and W500. BIOS version 3.13-1.06, released 31 March 2010, has completely fixed this problem for us. Our Lenovo support rep said that it's actually a change in the implementation of Intel's code that caused this problem. I guess that would explain why other vendors such as Dell also appear to be affected.

                           

                          The BIOS update is available from the Lenovo driver update site. (I could post a link but it's probably better if you search and make sure that you get an exact BIOS match for the machine you are trying to update.)

                           

                          Jayson

                          • 10. Re: PXE Error
                            Rookie

                            I experienced the same error messages on my Lenovo X201 laptops (BIOS version 1.13) and was able to correct the issue by flashing the BIOS to the latest version: 1.14.

                             

                            After flashing BIOS, I am able to see all menu items without problem; I didn't have to disable any menu items for Dos, Linux or WinPE.

                            • 11. Re: PXE Error
                              Employee

                              Hi everyone,

                               

                              The last few posts here are exactly right, the issue is involving Intel's boot code.  Lenovo was the first to implement that code, so they were listed specifically in the article.  They are also the first (at this point only) ones to have implemented Intel's fix.  Dell and HP are still affected, so the workaround of removing PXE options will need to be done on them until a BIOS with the fixed Intel code can be released.

                               

                              Thanks!