1 2 Previous Next 16 Replies Latest reply on Feb 22, 2011 4:22 PM by Chetan.Thekkada

    PE Driver Issue - LD90


      So I'm in the process of doing Windows 7 deployment with LD 9, which I believe uses PE 2.1.  We only use Dells here and don't have this PE driver issue with LD88 (PE1).  Here is a description of what's going on:


      Older PCs boot just fine into PE and do a successful ping to the core.  The newer Dell (e4300, e6400, etc.) with the correct NIC drivers don't get a valid IP.  It sits waiting to get IP for the longest time and times out.  If I open up another console and do a ipconfig /renew it does successfully get a Valid IP address, but it doesn't do it automatically.


      I thought it was the NIC driver, so instead of single drivers, I replaced it with the Dell PE Driver Pack listed here:  http://support.dell.com/support/downloads/download.aspx?c=us&cs=555&l=en&s=biz&releaseid=R247360&SystemID=LAT_E6400&servicetag=&os=WLH&osl=en&deviceid=22327&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=0&libid=36&typeid=-1&dateid=-1&formatid=-1&fileid=360733


      Any ideas of what I can do to get this to work correctly?




        • 1. Re: PE Driver Issue - LD90

          WinPE in 9.0 uses Vista 32bit drivers.  You can just download the exact nic drivers for your model and use the gui interface in LDMS under OSD to inject drivers into the PE image.

          • 2. Re: PE Driver Issue - LD90

            Thanks for the reply, but i've already done that from multiple sources.  I don't know if it's the driver or PE itself.  I don't think it's DHCP since it's working with older computers in LD9, and our LD88 environment works flawlessly.  Like I said, I have the correct driver, but it won't get an IP unless I open a new console and do an ipconfig /renew. 

            • 3. Re: PE Driver Issue - LD90

              If you do IPCONFIG /renew you do get a valid IP Address?  That's an important point, because it would indicate that the driver is correct.


              Also, after running ipconfig /renew can you run x:\ldclient\pxemenustart.cmd and get the pxe menu to appear correctly?


              The answers to those questions will help a lot with isolating the problem.



              • 4. Re: PE Driver Issue - LD90

                Yes, i do get an IP if I do an ipconfig /renew.  I tried pxemenustart.cmd, but my console window is just sitting here.  What am I supposed to see happen? 

                • 5. Re: PE Driver Issue - LD90

                  it could be possible that you are getting an ip, but not resolving the cores server name. Looking at the wait4ip.exe options, it will check to see if it resolve the core server name.



                  Return code:
                    0: an IP address was acquired
                    1: an IP address was acquired, but the core server name could not be resolved
                    2: timed out before an IP address was acquired
                    3: no NIC was found
                    4: syntax error


                  When you do have an ip address after the renew, can you ping the core by shortname?


                  Try running the utlity manually after the timeout and see if you get a different error.


                  x:\ldclient\wait4ip.exe /t 0



                  I don't know, definitely an odd issue!

                  • 6. Re: PE Driver Issue - LD90

                    I've only seen this type of issue one time before and it turned out to be caused by DHCP taking an extremely long time to get the IP Address assigned.


                    Here's what would happen:


                    wait4ip would wait and know that and are bad IP Addresses, so they would be ignored


                    DHCP request would time out and NIC would be autoassigned 169.x.x.x


                    wait4ip would allow the script to move on


                    pxemenustart.cmd couldn't download the pxe list, so a blank PXE menu would display


                    valid IP Address would be assigned.



                    In that scenario rerunning pxemenustart.cmd would allow the list to appear.  When you ran pxemenustart.cmd did the PXE Menu show up at all?  Even if it can't download the list of scripts it should still display the empty menu.


                    Going to lunch now, but let me know.

                    • 7. Re: PE Driver Issue - LD90

                      When running pxemenustart.cmd it just sits there in command prompt and no PXE menu is displayed even after 10-15 minutes.


                      wait4ip.exe shows ip addresses,


                      If I do an ipconfig /renew, i immediately (split second) get an IP address.  Like I said, the older lcomputers get an IP right away so I'm hesitant to blame a DHCP timeout.  I am going to reboot the DHCP server (or services) tonight and see if it helps though.

                      Any other suggestions to help troubleshoot this would greatly appreciated.

                      • 8. Re: PE Driver Issue - LD90

                        Okay so I am getting an IP, but maybe 5+ minutes after the automated wait4ip.exe has already timed out.  How would I go about extending how long it waits in the initial automated process?



                        • 9. Re: PE Driver Issue - LD90

                          Here is a guide on how to mount the boot.wim





                          once mounted you want to modify the startnet.cmd which is in Windows\System32


                          you will want to modify this line - \ldclient\wait4ip /t 180


                          replace the 180 with amount of seconds you want to use

                          • 10. Re: PE Driver Issue - LD90

                            Hi Eddie,


                            Looks like EMiranda beat me to this.  I was going to put the same information.  Instead, here's a doc with instructions on how to mount the WinPE image to make manual changes.  Once the changes are made you'll need to redeploy your PXE rep.



                            1 of 1 people found this helpful
                            • 11. Re: PE Driver Issue - LD90

                              Thanks a lot guys, I set it to 600 (10 minutes) and eventually (maybe 4-6 minutes) it got an IP address and worked.  Job well done!




                              • 12. Re: PE Driver Issue - LD90
                                Jared Barneck SupportEmployee

                                Instead of waiting 10 minutes (600 seconds), why not just add this line to the Startnet.cmd immediately after the Wait4IP.exe runs?


                                ipconfig /renew


                                Based on what you have said, it seems like that would work and you would not have to add such a long delay.

                                • 13. Re: PE Driver Issue - LD90

                                  Well waiting for up to 10 minutes doesn't actually affect anything.  Once it has an IP, it goes, so it doesn't hurt to have it there.  If I add an ipconfig /renew afterwards, it has already timed out.  Maybe I can add one before it?

                                  • 14. Re: PE Driver Issue - LD90

                                    I added  the ipconfig /renew line before the wait4ip command and it works much better now!

                                    1 2 Previous Next