1 Reply Latest reply on Mar 16, 2010 9:51 AM by Lionel

    Windows 7 - CTOS - Strange behavior

    Apprentice

      Hi,

       

      I'm trying to deploy Windows 7 x32 custom sysprepped WIM image with LANdesk v9 provisioning. I follow the BKM of Windows 7. And I'm not able to have this working as expected.

      I will explain what's happens. My template is some basic thing, first of all create/format/assign, etc the disk and partition, then I map drive, apply a WIM image of Windows 7 that I have created, then I inject the unattend.xml file and finally I run the CTOS command. I the next phase of the template, I just install the agent and distribute a software.

       

      Everything goes correctly without any error in the provisioning. If I follow the step, like explain in the document: http://community.landesk.com/support/docs/DOC-6948. I'm able to find the folder C:\LDProvisioning, but only one file on it, LDprovisioning.exe. Then my XMl file have no more entry in the specialize pass. But it's not really a problem because I do not have the CMD file into the folder ;-) And finally, the action.ini file is correctly populated with the action to start the provisioning at startup.

       

      Then the strange thing appear; the OS boot and in the first phase of W7 installation is installing device driver (black screen), BUT in the same phase my provisioning is also starting with the install agent (I can see it in the provisioning history into the core). For me the reason is the CBA service has started and the actions.ini say start c:\ldprovisioning\ldprovisioning.exe. It seems to work fine (even without ldprovisioning.cmd??) but the problem reside next, because when Windows 7 has finished to installing device, it reboot automatically... and the provisionong LANDesk is "dans les chous", completely lost.

      As the result into W7, it still the folder C:\LDprovisioning, the agent sometimes is correctly installed sometimes no and the provisioning process never start again...

       

      Once the windows session is OK,  if I run manually the provisioning, the rest of the templates is going well...

       

      Then what I'm doing wrong? Do I understand well the global process or I have done a mistake regarding the usage of provisioning?

       

      Many thanks - regards

      Lionel

        • 1. Re: Windows 7 - CTOS - Strange behavior
          Apprentice

          Hi,

           

          I finally find the problem myself. Explication:

           

          Usually when I put in place the provisioning, I always create 2 provisioning templates. One for creating the master, ans a second one to deploy the master. With that, I can recreate easily a new master and always in the same way. In the first template, I use the scripted install with answer file. I do not install the LANDesk agent and all applications are installed via execute file. Then I run sysprep and capture the image. In the second template, I use the HII and CTOS method.

           

          When the first template runs the scripted install, it always add the CBA part into Windows to be able to restart provisioning after the installation. It also create the service CBA. When I run sysprep and capture this image this information / service still on the image.

           

          The problem is dependant of these information, because when you deploy the captured image, the CTOS action will do nothing because the service is already present and when I boot Windows, automatically the service start but at the wrong deployment phase and the result is describe in the first post.

           

          Moralité: Always use the "UninstallWinClient" before running sysprep and start capturing the image for whole deployment., even if the agent has not been installed but only the provisioning part ;-))

           

          Regards

          Lionel